summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorchenjunyu192018-06-25 17:35:02 +0800
committerchenjunyu192018-06-25 17:35:02 +0800
commit210fdbe21f6eba3f0affc09c6f4fd9b7a041ddd4 (patch)
tree55f03dbb8e762cf6aa43160f66e961e2a47414b8
downloadaur-210fdbe21f6eba3f0affc09c6f4fd9b7a041ddd4.tar.gz
init
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD26
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..671eba520608
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = netease-cloud-music-dl-git
+ pkgdesc = Netease cloud music song downloader, with full ID3 metadata, eg: front cover image, artist name, album name, song title and so on.
+ pkgver = r21.67840ea
+ pkgrel = 1
+ url = https://github.com/codezjx/netease-cloud-music-dl
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python
+ depends = python-requests>=2.17.3
+ depends = python-pycryptodome>=2.6.1
+ depends = python-mutagen>=1.38.0
+ depends = python-pillow>=4.3.0
+ options = !emptydirs
+ source = git+https://github.com/codezjx/netease-cloud-music-dl
+ md5sums = SKIP
+
+pkgname = netease-cloud-music-dl-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eceaec3e6062
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: chenjunyu19 <1335546814@qq.com>
+
+pkgname=netease-cloud-music-dl-git
+pkgver=r21.67840ea
+pkgrel=1
+pkgdesc="Netease cloud music song downloader, with full ID3 metadata, eg: front cover image, artist name, album name, song title and so on."
+arch=('any')
+url="https://github.com/codezjx/netease-cloud-music-dl"
+license=('MIT')
+depends=('python' 'python-requests>=2.17.3' 'python-pycryptodome>=2.6.1' 'python-mutagen>=1.38.0' 'python-pillow>=4.3.0')
+makedepends=('git' 'python-setuptools')
+options=(!emptydirs)
+source=("git+https://github.com/codezjx/netease-cloud-music-dl")
+md5sums=('SKIP')
+_gitname=netease-cloud-music-dl
+
+pkgver() {
+ cd $_gitname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package(){
+ cd "$srcdir/$_gitname"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+} \ No newline at end of file