summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryjun1232020-07-17 19:28:28 +0800
committeryjun1232020-07-17 19:28:28 +0800
commite4e89afaf22fa6c027b1b4690cf9697f348065f7 (patch)
tree038313ec44d8c2fffc28528ce0f6b45aab8347dd
parent2da6b78ca7c7ebff983c9044a0d3889932a31ab9 (diff)
downloadaur-e4e89afaf22fa6c027b1b4690cf9697f348065f7.tar.gz
changed arch to any
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD16
2 files changed, 11 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fee6a88c44af..26b428d91905 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,7 +3,7 @@ pkgbase = netease-music-tui
pkgver = 0.1.2
pkgrel = 2
url = https://github.com/betta-cyber/netease-music-tui
- arch = x86_64
+ arch = any
license = MIT
makedepends = rust
depends = dbus
diff --git a/PKGBUILD b/PKGBUILD
index 17f7eb6e0514..d9d618115e40 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgname=netease-music-tui
pkgver=0.1.2
pkgrel=2
pkgdesc="netease cloud music terminal client by rust"
-arch=('x86_64')
+arch=('any')
url="https://github.com/betta-cyber/netease-music-tui"
license=('MIT')
depends=('dbus' 'alsa-lib')
@@ -13,12 +13,16 @@ provides=('netease-music-tui-bin')
conflicts=('netease-music-tui-bin')
source=(${pkgname}-${pkgver}.tar.gz::"https://github.com/betta-cyber/${pkgname}/archive/v${pkgver}.tar.gz")
sha256sums=('5021c8c9d204b439453a1d3aaacc4802a685988c2cb376d057c48a3dbcc74514')
+
build() {
- cd ${pkgname}-${pkgver}
- cargo build --release --all-features
- # cargo build --release --all-features --locked
+ cd ${pkgname}-${pkgver}
+ cargo build --release --all-features
+ # cargo build --release --all-features --locked
}
+
package() {
- install -Dm755 ${pkgname}-${pkgver}/target/release/ncmt ${pkgdir}/usr/bin/ncmt
- install -Dm644 ${pkgname}-${pkgver}/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ install -Dm755 ${pkgname}-${pkgver}/target/release/ncmt ${pkgdir}/usr/bin/ncmt
+ install -Dm644 ${pkgname}-${pkgver}/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
}
+
+# vim: set sw=2 ts=2 et: