summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryjun1232020-05-16 14:59:08 +0800
committeryjun1232020-05-16 14:59:08 +0800
commitf9ef011a1ce418c0339d6020d185be1ecb75e13d (patch)
treeeec0759133137b51f8025d061344e799c6fcd540
parent88eb9cb16962cfed091bfbf923a61a690415e59a (diff)
downloadaur-f9ef011a1ce418c0339d6020d185be1ecb75e13d.tar.gz
add --all-features compile option with dbus_mpris supported
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
2 files changed, 4 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7fb74af0cc50..fab28f8d7564 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = netease-music-tui
pkgdesc = netease cloud music terminal client by rust
pkgver = 0.1.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/betta-cyber/netease-music-tui
arch = x86_64
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index fc40ebfe79a4..a7d185d86958 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=netease-music-tui
pkgver=0.1.2
-pkgrel=1
+pkgrel=2
pkgdesc="netease cloud music terminal client by rust"
arch=('x86_64')
url="https://github.com/betta-cyber/netease-music-tui"
@@ -14,7 +14,8 @@ source=(${pkgname}-${pkgver}.tar.gz::"https://github.com/betta-cyber/${pkgname}/
sha256sums=('5021c8c9d204b439453a1d3aaacc4802a685988c2cb376d057c48a3dbcc74514')
build() {
cd ${pkgname}-${pkgver}
- cargo build --release
+ cargo build --release --all-features
+ # cargo build --release --all-features --locked
}
package() {
install -Dm755 ${pkgname}-${pkgver}/target/release/ncmt ${pkgdir}/usr/bin/ncmt