summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraxionl2021-01-24 23:38:04 +0800
committeraxionl2021-01-24 23:42:09 +0800
commit184c9be7de83582600763970751c932371dbbe06 (patch)
tree8988168cf15cd8ddd2dac7e4a75b92a2e6270bc1
parent7e2fe8092563ea0739eb055e396750d441c8f82a (diff)
downloadaur-184c9be7de83582600763970751c932371dbbe06.tar.gz
[Update] netease-musicbox: v0.3.1
-rw-r--r--.SRCINFO11
-rw-r--r--0001-Replace_pyqt4_to_pyqt5_as_depends.patch50
-rw-r--r--PKGBUILD21
3 files changed, 13 insertions, 69 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 54cbede5114d..583a7187bd2a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = netease-musicbox
pkgdesc = A sexy command line interface musicbox for NetEase based on Python
- pkgver = 0.3.0
+ pkgver = 0.3.1
pkgrel = 1
url = https://github.com/darknessomi/musicbox
arch = any
@@ -13,19 +13,18 @@ pkgbase = netease-musicbox
depends = python-future
depends = python-fuzzywuzzy
depends = python-requests-cache
- depends = python-levenshtein
optdepends = aria2: music caching
optdepends = libnotify: notifications
optdepends = qt5-base: lyrics support
+ optdepends = python-qtpy: lyrics support
optdepends = python-pyqt5: lyrics support
optdepends = python-dbus: lyrics support
+ optdepends = python-levenshtein: fuzzy search support
provides = musicbox
conflicts = netease-musicbox-git
- source = musicbox-0.3.0.tar.gz::https://github.com/darknessomi/musicbox/archive/0.3.0.tar.gz
+ source = musicbox-0.3.1.tar.gz::https://github.com/darknessomi/musicbox/archive/0.3.1.tar.gz
source = LICENSE::https://raw.githubusercontent.com/darknessomi/musicbox/master/LICENSE
- source = 0001-Replace_pyqt4_to_pyqt5_as_depends.patch
- sha256sums = fc9a6e2947d491b08123ef6b826772c9d6539ce6aaa984e5f737264344edfd42
+ sha256sums = b7f984b0462b553ebc8fccb414783b07936efa49fdd1822d2c79a4c8aa624f4e
sha256sums = 40aaf7aea7939284b07c487929472fa9cc5a842ff5f0c1e474ac93e6de7aa64e
- sha256sums = b7e69d2fe2886ed9e66769e759add027a527089cf2770f8b7377a806e9079a03
pkgname = netease-musicbox
diff --git a/0001-Replace_pyqt4_to_pyqt5_as_depends.patch b/0001-Replace_pyqt4_to_pyqt5_as_depends.patch
deleted file mode 100644
index 813295888225..000000000000
--- a/0001-Replace_pyqt4_to_pyqt5_as_depends.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-diff --unified --recursive --text musicbox-0.3.0/NEMbox/osdlyrics.py musicbox-0.3.0.new/NEMbox/osdlyrics.py
---- musicbox-0.3.0/NEMbox/osdlyrics.py 2020-10-23 19:52:11.000000000 +0800
-+++ musicbox-0.3.0.new/NEMbox/osdlyrics.py 2020-11-05 19:16:55.152042882 +0800
-@@ -13,17 +13,17 @@
- config = Config()
-
- try:
-- from PyQt4 import QtGui, QtCore, QtDBus
-+ from PyQt5 import QtGui, QtWidgets, QtCore, QtDBus
-
- pyqt_activity = True
- except ImportError:
- pyqt_activity = False
-- log.warn("PyQt4 module not installed.")
-+ log.warn("PyQt5 module not installed.")
- log.warn("Osdlyrics Not Available.")
-
- if pyqt_activity:
-
-- class Lyrics(QtGui.QWidget):
-+ class Lyrics(QtWidgets.QWidget):
- def __init__(self):
- super(Lyrics, self).__init__()
- self.__dbusAdaptor = LyricsAdapter(self)
-@@ -47,11 +47,10 @@
- self.setMinimumSize(600, 50)
- osdlyrics_size = config.get("osdlyrics_size")
- self.resize(osdlyrics_size[0], osdlyrics_size[1])
-- scn = QtGui.QApplication.desktop().screenNumber(
-- QtGui.QApplication.desktop().cursor().pos()
-- )
-- bl = QtGui.QApplication.desktop().screenGeometry(scn).bottomLeft()
-- br = QtGui.QApplication.desktop().screenGeometry(scn).bottomRight()
-+ scn = QtWidgets.QApplication.desktop().screenNumber(
-+ QtWidgets.QApplication.desktop().cursor().pos())
-+ bl = QtWidgets.QApplication.desktop().screenGeometry(scn).bottomLeft()
-+ br = QtWidgets.QApplication.desktop().screenGeometry(scn).bottomRight()
- bc = (bl + br) / 2
- frameGeo = self.frameGeometry()
- frameGeo.moveCenter(bc)
-@@ -112,8 +111,7 @@
- self.parent().repaint()
-
- def show_lyrics():
--
-- app = QtGui.QApplication(sys.argv)
-+ app = QtWidgets.QApplication(sys.argv)
- lyrics = Lyrics()
- QtDBus.QDBusConnection.sessionBus().registerService("org.musicbox.Bus")
- QtDBus.QDBusConnection.sessionBus().registerObject("/", lyrics)
diff --git a/PKGBUILD b/PKGBUILD
index 0dfa904c137a..d6f655b1ec66 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,35 +4,30 @@
pkgname=netease-musicbox
_gitname=musicbox
_pyname=NetEase-MusicBox
-pkgver=0.3.0
+pkgver=0.3.1
pkgrel=1
pkgdesc="A sexy command line interface musicbox for NetEase based on Python"
arch=(any)
url="https://github.com/darknessomi/musicbox"
depends=('mpg123' 'python-pycryptodomex' 'python-requests' 'python-future'
- 'python-fuzzywuzzy' 'python-requests-cache' 'python-levenshtein')
+ 'python-fuzzywuzzy' 'python-requests-cache' )
makedepends=('python-setuptools' 'python-poetry')
optdepends=('aria2: music caching'
'libnotify: notifications'
'qt5-base: lyrics support'
+ 'python-qtpy: lyrics support'
'python-pyqt5: lyrics support'
- 'python-dbus: lyrics support')
+ 'python-dbus: lyrics support'
+ 'python-levenshtein: fuzzy search support')
provides=('musicbox')
conflicts=('netease-musicbox-git')
license=('MIT')
source=("musicbox-$pkgver.tar.gz::https://github.com/darknessomi/musicbox/archive/${pkgver}.tar.gz"
- "LICENSE::https://raw.githubusercontent.com/darknessomi/musicbox/master/LICENSE"
- "0001-Replace_pyqt4_to_pyqt5_as_depends.patch")
+ "LICENSE::https://raw.githubusercontent.com/darknessomi/musicbox/master/LICENSE")
-sha256sums=('fc9a6e2947d491b08123ef6b826772c9d6539ce6aaa984e5f737264344edfd42'
- '40aaf7aea7939284b07c487929472fa9cc5a842ff5f0c1e474ac93e6de7aa64e'
- 'b7e69d2fe2886ed9e66769e759add027a527089cf2770f8b7377a806e9079a03')
-
-prepare() {
- cd "${srcdir}/musicbox-${pkgver}"
- patch -Np1 -i "${srcdir}/0001-Replace_pyqt4_to_pyqt5_as_depends.patch"
-}
+sha256sums=('b7f984b0462b553ebc8fccb414783b07936efa49fdd1822d2c79a4c8aa624f4e'
+ '40aaf7aea7939284b07c487929472fa9cc5a842ff5f0c1e474ac93e6de7aa64e')
build() {
cd "${srcdir}/musicbox-${pkgver}"