summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJiachen Yang2015-06-13 23:02:31 +0900
committerJiachen Yang2015-06-13 23:02:31 +0900
commit675780471f28947c400ab2e866822147cc64d595 (patch)
tree6c4dcf8e9a405219b8077cc960d2c5e27b2ca9ee
downloadaur-675780471f28947c400ab2e866822147cc64d595.tar.gz
init netease-musicbox
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD27
-rw-r--r--netease-musicbox.install10
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a0bd99fa05aa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = netease-musicbox
+ pkgdesc = A sexy command line interface musicbox for NetEase based on Python
+ pkgver = r140.31ff39b
+ pkgrel = 1
+ url = https://github.com/darknessomi/musicbox
+ install = netease-musicbox.install
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = python2
+ depends = mpg123
+ depends = python2-beautifulsoup4
+ depends = python2-requests
+ depends = python2-setuptools
+ options = !emptydirs
+ source = git+https://github.com/darknessomi/musicbox
+ sha256sums = SKIP
+
+pkgname = netease-musicbox
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f2dd3e098faf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Jiachen Yang <farseerfc@gmail.com>
+pkgname=netease-musicbox
+_gitname=musicbox
+pkgver=r140.31ff39b
+pkgrel=1
+pkgdesc="A sexy command line interface musicbox for NetEase based on Python"
+arch=(any)
+url="https://github.com/darknessomi/musicbox"
+license=('MIT')
+depends=('python2' 'mpg123' 'python2-beautifulsoup4' 'python2-requests' 'python2-setuptools')
+makedepends=('git')
+options=(!emptydirs)
+source=("git+https://github.com/darknessomi/musicbox")
+sha256sums=('SKIP')
+install=$pkgname.install
+
+pkgver() {
+ cd $_gitname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/netease-musicbox.install b/netease-musicbox.install
new file mode 100644
index 000000000000..2047feb9ffe9
--- /dev/null
+++ b/netease-musicbox.install
@@ -0,0 +1,10 @@
+
+post_install() {
+ echo "The binary is called: 'musicbox'"
+}
+
+post_upgrade() {
+ post_install
+}
+
+# vim:set ts=2 sw=2 et: