summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraxionl2018-06-11 17:18:25 +0800
committeraxionl2018-06-11 17:18:25 +0800
commita55e632c549b89146f14f69503027e04ebe82ccb (patch)
tree39c85f1e715b4a409fb6030c58805c3f75ddb6b6
parentcfa8714d91b5a80160675e6c6662f3655bf4e07a (diff)
downloadaur-a55e632c549b89146f14f69503027e04ebe82ccb.tar.gz
update from pypi.
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD20
2 files changed, 21 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 81b61db54dae..48ba8460427b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,28 @@
pkgbase = netease-musicbox
pkgdesc = A sexy command line interface musicbox for NetEase based on Python
- pkgver = 0.2.4.3
+ pkgver = 0.2.5.2
pkgrel = 1
url = https://github.com/darknessomi/musicbox
install = netease-musicbox.install
arch = any
license = MIT
- makedepends = python-beautifulsoup4
- makedepends = python-requests
- makedepends = python-setuptools
- makedepends = python-future
- makedepends = python-lxml
- depends = mpg123
depends = python
- depends = python-crypto
- depends = python-cryptography
+ depends = python-requests
+ depends = python-setuptools
+ depends = mpg123
+ depends = python-future
+ depends = python-pycryptodomex
+ depends = python-requests-cache
optdepends = aria2: music caching
optdepends = libnotify: notifications
optdepends = python-pyqt4: lyrics support
optdepends = python-dbus: lyrics support
provides = netease-musicbox
conflicts = netease-musicbox
- source = musicbox-0.2.4.3.tar.gz::https://github.com/darknessomi/musicbox/archive/0.2.4.3.tar.gz
- sha256sums = 9ff9403d06f7fa714269d6c46beba6236861c9f639391a88f87a2eb3f6bf2ebb
+ source = musicbox-0.2.5.2.tar.gz::https://files.pythonhosted.org/packages/8e/54/17fb71a184020e2da960c4fbf1a0abf9fc8f774fa39a844ec47ef41ec4d9/NetEase-MusicBox-0.2.5.2.tar.gz
+ source = LICENSE::https://raw.githubusercontent.com/darknessomi/musicbox/master/LICENSE.txt
+ sha256sums = 017d452c2852d5f647e6917ad0d8a5e359fcc32e7ad34f6ea6db2c88d07d4086
+ sha256sums = 50efc98142cfffe413d73c87c91f2687dfb774217af923f03dfdc8426c9d9552
pkgname = netease-musicbox
diff --git a/PKGBUILD b/PKGBUILD
index 211428ac0f33..722b01886173 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,13 @@
pkgname=netease-musicbox
_gitname=musicbox
-pkgver=0.2.4.3
+pkgver=0.2.5.2
pkgrel=1
pkgdesc="A sexy command line interface musicbox for NetEase based on Python"
arch=(any)
url="https://github.com/darknessomi/musicbox"
-depends=('mpg123' 'python' 'python-crypto' 'python-cryptography')
-makedepends=('python-beautifulsoup4'
- 'python-requests' 'python-setuptools'
- 'python-future' 'python-lxml')
+depends=('python' 'python-requests' 'python-setuptools' 'mpg123'
+ 'python-future' 'python-pycryptodomex' 'python-requests-cache')
optdepends=('aria2: music caching'
'libnotify: notifications'
'python-pyqt4: lyrics support'
@@ -21,14 +19,16 @@ conflicts=('netease-musicbox')
install=$pkgname.install
license=('MIT')
-source=("musicbox-$pkgver.tar.gz::https://github.com/darknessomi/musicbox/archive/$pkgver.tar.gz")
+source=("musicbox-$pkgver.tar.gz::https://files.pythonhosted.org/packages/8e/54/17fb71a184020e2da960c4fbf1a0abf9fc8f774fa39a844ec47ef41ec4d9/NetEase-MusicBox-$pkgver.tar.gz"
+ "LICENSE::https://raw.githubusercontent.com/darknessomi/musicbox/master/LICENSE.txt")
-sha256sums=('9ff9403d06f7fa714269d6c46beba6236861c9f639391a88f87a2eb3f6bf2ebb')
+sha256sums=('017d452c2852d5f647e6917ad0d8a5e359fcc32e7ad34f6ea6db2c88d07d4086'
+ '50efc98142cfffe413d73c87c91f2687dfb774217af923f03dfdc8426c9d9552')
package() {
- cd "$srcdir/$_gitname-$pkgver"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cd "$srcdir/NetEase-MusicBox-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1
mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}"
- install -m755 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/"
}
-# vim:set ts=2 sw=2 et: \ No newline at end of file
+# vim:set ts=2 sw=2 et: