summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2021-04-20 16:05:59 +0800
committerlilac2021-04-20 16:05:59 +0800
commit1b8588d5fe1b58b88f1f935efdb5a8478acdaa2a (patch)
tree65f6539e2034c7871ba775e57ae18c3f4c99fb5c
parent2c1e4884a97549a5dc28f4318f2cbf96c1f981bf (diff)
downloadaur-1b8588d5fe1b58b88f1f935efdb5a8478acdaa2a.tar.gz
[lilac] updated to 0.3.1.r1.gcd2874e-2
-rw-r--r--.SRCINFO16
-rw-r--r--0001-Replace_pyqt4_to_pyqt5_as_depends.patch71
-rw-r--r--PKGBUILD31
3 files changed, 25 insertions, 93 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1efef7ee838b..5cc64ac82851 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,31 +1,33 @@
pkgbase = netease-musicbox-git
pkgdesc = A sexy command line interface musicbox for NetEase based on Python
- pkgver = r605.5aadfb6
- pkgrel = 4
+ pkgver = 0.3.1.r1.gcd2874e
+ pkgrel = 2
url = https://github.com/darknessomi/musicbox
arch = any
license = MIT
makedepends = python-setuptools
+ makedepends = python-poetry
makedepends = git
- makedepends = python-dephell
depends = mpg123
+ depends = python-pycryptodomex
+ depends = python-requests
+ depends = python-future
depends = python-fuzzywuzzy
depends = python-requests-cache
- depends = python-pycryptodomex
+ depends = python-importlib-metadata
optdepends = aria2: music caching
optdepends = libnotify: notifications
optdepends = qt5-base: lyrics support
+ optdepends = python-qtpy: lyrics support
optdepends = python-pyqt5: lyrics support
optdepends = python-dbus: lyrics support
- optdepends = python-levenshtein: search support
+ optdepends = python-levenshtein: fuzzy search support
provides = netease-musicbox
conflicts = netease-musicbox
source = musicbox::git+https://github.com/darknessomi/musicbox
source = LICENSE::https://raw.githubusercontent.com/darknessomi/musicbox/master/LICENSE
- source = 0001-Replace_pyqt4_to_pyqt5_as_depends.patch
sha256sums = SKIP
sha256sums = 40aaf7aea7939284b07c487929472fa9cc5a842ff5f0c1e474ac93e6de7aa64e
- sha256sums = 485d7a1e900da50a4d6d055131ebc3b2072cf5760d9e27cd266ff373aedb6d46
pkgname = netease-musicbox-git
diff --git a/0001-Replace_pyqt4_to_pyqt5_as_depends.patch b/0001-Replace_pyqt4_to_pyqt5_as_depends.patch
deleted file mode 100644
index 0d797b705306..000000000000
--- a/0001-Replace_pyqt4_to_pyqt5_as_depends.patch
+++ /dev/null
@@ -1,71 +0,0 @@
-From 399c5524c76c7bf0662aa56047c4f5b686f8c669 Mon Sep 17 00:00:00 2001
-From: axionl <i@axionl.me>
-Date: Thu, 27 Dec 2018 23:20:02 +0900
-Subject: [PATCH] Replace_pyqt4_to_pyqt5_as_depends.patch
-
----
- NEMbox/osdlyrics.py | 20 ++++++++++----------
- 1 file changed, 10 insertions(+), 10 deletions(-)
-
-diff --git a/NEMbox/osdlyrics.py b/NEMbox/osdlyrics.py
-index ca15941..6a51996 100644
---- a/NEMbox/osdlyrics.py
-+++ b/NEMbox/osdlyrics.py
-@@ -17,24 +17,25 @@ log = logger.getLogger(__name__)
- config = Config()
-
- try:
-- from PyQt4 import QtGui, QtCore, QtDBus
-+ from PyQt5 import QtGui, QtWidgets, QtCore, QtDBus
-
- pyqt_activity = True
- except ImportError:
- pyqt_activity = False
-- log.warn("PyQt4 module not installed.")
-+ log.warn("PyQt5 module not installed.")
- log.warn("Osdlyrics Not Available.")
-
- if pyqt_activity:
-
-- class Lyrics(QtGui.QWidget):
-+ class Lyrics(QtWidgets.QWidget):
- def __init__(self):
- super(Lyrics, self).__init__()
- self.__dbusAdaptor = LyricsAdapter(self)
- self.initUI()
-
- def initUI(self):
-- self.setStyleSheet("background:" + config.get("osdlyrics_background"))
-+ self.setStyleSheet(
-+ "background:" + config.get("osdlyrics_background"))
- if config.get("osdlyrics_transparent"):
- self.setAttribute(QtCore.Qt.WA_TranslucentBackground)
- self.setAttribute(QtCore.Qt.WA_ShowWithoutActivating)
-@@ -51,11 +52,10 @@ if pyqt_activity:
- self.setMinimumSize(600, 50)
- osdlyrics_size = config.get("osdlyrics_size")
- self.resize(osdlyrics_size[0], osdlyrics_size[1])
-- scn = QtGui.QApplication.desktop().screenNumber(
-- QtGui.QApplication.desktop().cursor().pos()
-- )
-- bl = QtGui.QApplication.desktop().screenGeometry(scn).bottomLeft()
-- br = QtGui.QApplication.desktop().screenGeometry(scn).bottomRight()
-+ scn = QtWidgets.QApplication.desktop().screenNumber(
-+ QtWidgets.QApplication.desktop().cursor().pos())
-+ bl = QtWidgets.QApplication.desktop().screenGeometry(scn).bottomLeft()
-+ br = QtWidgets.QApplication.desktop().screenGeometry(scn).bottomRight()
- bc = (bl + br) / 2
- frameGeo = self.frameGeometry()
- frameGeo.moveCenter(bc)
-@@ -117,7 +117,7 @@ if pyqt_activity:
-
- def show_lyrics():
-
-- app = QtGui.QApplication(sys.argv)
-+ app = QtWidgets.QApplication(sys.argv)
- lyrics = Lyrics()
- QtDBus.QDBusConnection.sessionBus().registerService("org.musicbox.Bus")
- QtDBus.QDBusConnection.sessionBus().registerObject("/", lyrics)
---
-2.20.1
-
diff --git a/PKGBUILD b/PKGBUILD
index 26ff28849970..eb66fc2a9b28 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,46 +3,47 @@
pkgname=netease-musicbox-git
_gitname=musicbox
-pkgver=r605.5aadfb6
-pkgrel=4
+pkgver=0.3.1.r1.gcd2874e
+pkgrel=2
pkgdesc="A sexy command line interface musicbox for NetEase based on Python"
arch=(any)
url="https://github.com/darknessomi/musicbox"
-depends=('mpg123' 'python-fuzzywuzzy' 'python-requests-cache' 'python-pycryptodomex')
-makedepends=('python-setuptools' 'git' 'python-dephell')
+depends=('mpg123' 'python-pycryptodomex' 'python-requests' 'python-future'
+ 'python-fuzzywuzzy' 'python-requests-cache' 'python-importlib-metadata')
+makedepends=('python-setuptools' 'python-poetry' 'git')
optdepends=('aria2: music caching'
'libnotify: notifications'
'qt5-base: lyrics support'
+ 'python-qtpy: lyrics support'
'python-pyqt5: lyrics support'
'python-dbus: lyrics support'
- 'python-levenshtein: search support')
+ 'python-levenshtein: fuzzy search support')
provides=('netease-musicbox')
conflicts=('netease-musicbox')
license=('MIT')
source=("${_gitname}::git+https://github.com/darknessomi/musicbox"
- "LICENSE::https://raw.githubusercontent.com/darknessomi/musicbox/master/LICENSE"
- "0001-Replace_pyqt4_to_pyqt5_as_depends.patch")
+ "LICENSE::https://raw.githubusercontent.com/darknessomi/musicbox/master/LICENSE")
sha256sums=('SKIP'
- '40aaf7aea7939284b07c487929472fa9cc5a842ff5f0c1e474ac93e6de7aa64e'
- '485d7a1e900da50a4d6d055131ebc3b2072cf5760d9e27cd266ff373aedb6d46')
+ '40aaf7aea7939284b07c487929472fa9cc5a842ff5f0c1e474ac93e6de7aa64e')
pkgver() {
cd "${srcdir}/${_gitname}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
+build() {
cd "${srcdir}/${_gitname}"
- patch -Np1 -i "${srcdir}/0001-Replace_pyqt4_to_pyqt5_as_depends.patch"
- dephell deps convert --from pyproject.toml --to setup.py
+ poetry build -f sdist
+ export mainver=$(echo "${pkgver}" | cut -d "." -f1-3)
+ tar xvf "./dist/NetEase-MusicBox-${mainver}.tar.gz"
}
package() {
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- cd "${srcdir}/${_gitname}"
+
+ cd "${srcdir}/${_gitname}/NetEase-MusicBox-${mainver}"
python setup.py install --root="${pkgdir}/" --optimize=1
- mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}"
}
# vim:set ts=2 sw=2 et: