summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJiachen Yang2016-01-12 23:31:45 +0900
committerJiachen Yang2016-01-12 23:31:45 +0900
commit59d07043fc29b113e246feafe4bd92245c3b7aef (patch)
tree8355275dc6e8681ce0f9506ac9a670f3e85e9038
downloadaur-59d07043fc29b113e246feafe4bd92245c3b7aef.tar.gz
rename netease-musicbox to netease-musicbox-git
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD31
-rw-r--r--netease-musicbox-git.install10
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..307e6b339c61
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = netease-musicbox-git
+ pkgdesc = A sexy command line interface musicbox for NetEase based on Python
+ pkgver = r244.58cd013
+ pkgrel = 1
+ url = https://github.com/darknessomi/musicbox
+ install = netease-musicbox-git.install
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = python2
+ depends = mpg123
+ depends = python2-beautifulsoup4
+ depends = python2-requests
+ depends = python2-setuptools
+ depends = python2-crypto
+ provides = netease-musicbox
+ conflicts = netease-musicbox
+ options = !emptydirs
+ source = git+https://github.com/darknessomi/musicbox
+ sha256sums = SKIP
+
+pkgname = netease-musicbox-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8cedd4d7ff11
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Jiachen Yang <farseerfc@gmail.com>
+pkgname=netease-musicbox-git
+_gitname=musicbox
+pkgver=r244.58cd013
+pkgrel=1
+pkgdesc="A sexy command line interface musicbox for NetEase based on Python"
+arch=(any)
+url="https://github.com/darknessomi/musicbox"
+license=('MIT')
+depends=('python2' 'mpg123' 'python2-beautifulsoup4' 'python2-requests' 'python2-setuptools' 'python2-crypto')
+makedepends=('git')
+options=(!emptydirs)
+source=("git+https://github.com/darknessomi/musicbox")
+sha256sums=('SKIP')
+provides=('netease-musicbox')
+conflicts=('netease-musicbox')
+install=$pkgname.install
+
+pkgver() {
+ cd $_gitname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+ mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m755 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/netease-musicbox-git.install b/netease-musicbox-git.install
new file mode 100644
index 000000000000..2047feb9ffe9
--- /dev/null
+++ b/netease-musicbox-git.install
@@ -0,0 +1,10 @@
+
+post_install() {
+ echo "The binary is called: 'musicbox'"
+}
+
+post_upgrade() {
+ post_install
+}
+
+# vim:set ts=2 sw=2 et: