summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraxionl2019-01-04 00:12:52 +0900
committeraxionl2019-01-04 00:12:52 +0900
commitea453f6cdf23c1df0b6d1594655b53584865ada7 (patch)
tree7778094aa09e998331ea4c722d520c2652e9239c
parentfb8bb468d9ca1a906cbf8606ac0447fc4ea79499 (diff)
downloadaur-ea453f6cdf23c1df0b6d1594655b53584865ada7.tar.gz
[Update] netease-musicbox-git: update the patch to the latest one.
-rw-r--r--.SRCINFO9
-rw-r--r--0001-Replace_pyqt4_to_pyqt5_as_depends.patch (renamed from 0001-Fixed-Replace_pyqt4_to_pyqt5_as_depends.patch)39
-rw-r--r--PKGBUILD12
3 files changed, 36 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 46bc8ef6eb1c..4ce82238a555 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = netease-musicbox-git
pkgdesc = A sexy command line interface musicbox for NetEase based on Python
- pkgver = r579.8ce4a7e
+ pkgver = r586.900d9bd
pkgrel = 1
url = https://github.com/darknessomi/musicbox
install = netease-musicbox-git.install
@@ -12,6 +12,7 @@ pkgbase = netease-musicbox-git
depends = python-pycryptodomex
depends = python-requests
depends = python-future
+ depends = python-requests-cache
optdepends = aria2: music caching
optdepends = libnotify: notifications
optdepends = qt5-base: lyrics support
@@ -21,10 +22,10 @@ pkgbase = netease-musicbox-git
conflicts = netease-musicbox
source = musicbox::git+https://github.com/darknessomi/musicbox
source = LICENSE::https://raw.githubusercontent.com/darknessomi/musicbox/master/LICENSE.txt
- source = 0001-Fixed-Replace_pyqt4_to_pyqt5_as_depends.patch
+ source = 0001-Replace_pyqt4_to_pyqt5_as_depends.patch
sha256sums = SKIP
- sha256sums = 50efc98142cfffe413d73c87c91f2687dfb774217af923f03dfdc8426c9d9552
- sha256sums = 55b4dd116b8b7a1b47854f52ce1e9f8422fb72702beb4c259bda388e23060484
+ sha256sums = e6ce649439eace57267c94e651e38370582f883e6341b3203e951b9497433641
+ sha256sums = 485d7a1e900da50a4d6d055131ebc3b2072cf5760d9e27cd266ff373aedb6d46
pkgname = netease-musicbox-git
diff --git a/0001-Fixed-Replace_pyqt4_to_pyqt5_as_depends.patch b/0001-Replace_pyqt4_to_pyqt5_as_depends.patch
index de94770de8fc..0d797b705306 100644
--- a/0001-Fixed-Replace_pyqt4_to_pyqt5_as_depends.patch
+++ b/0001-Replace_pyqt4_to_pyqt5_as_depends.patch
@@ -1,22 +1,23 @@
-From 9a6793e6dab6811c220222f15c68099d6fc902d2 Mon Sep 17 00:00:00 2001
+From 399c5524c76c7bf0662aa56047c4f5b686f8c669 Mon Sep 17 00:00:00 2001
From: axionl <i@axionl.me>
-Date: Wed, 21 Nov 2018 01:34:22 +0900
-Subject: [PATCH] [Fixed] Replace_pyqt4_to_pyqt5_as_depends
+Date: Thu, 27 Dec 2018 23:20:02 +0900
+Subject: [PATCH] Replace_pyqt4_to_pyqt5_as_depends.patch
---
- NEMbox/osdlyrics.py | 16 ++++++++--------
- 1 file changed, 8 insertions(+), 8 deletions(-)
+ NEMbox/osdlyrics.py | 20 ++++++++++----------
+ 1 file changed, 10 insertions(+), 10 deletions(-)
diff --git a/NEMbox/osdlyrics.py b/NEMbox/osdlyrics.py
-index bd96e09..5e66843 100644
+index ca15941..6a51996 100644
--- a/NEMbox/osdlyrics.py
+++ b/NEMbox/osdlyrics.py
-@@ -19,16 +19,16 @@ log = logger.getLogger(__name__)
+@@ -17,24 +17,25 @@ log = logger.getLogger(__name__)
config = Config()
try:
- from PyQt4 import QtGui, QtCore, QtDBus
+ from PyQt5 import QtGui, QtWidgets, QtCore, QtDBus
+
pyqt_activity = True
except ImportError:
pyqt_activity = False
@@ -28,15 +29,25 @@ index bd96e09..5e66843 100644
- class Lyrics(QtGui.QWidget):
+ class Lyrics(QtWidgets.QWidget):
-
def __init__(self):
super(Lyrics, self).__init__()
-@@ -52,10 +52,10 @@ if pyqt_activity:
+ self.__dbusAdaptor = LyricsAdapter(self)
+ self.initUI()
+
+ def initUI(self):
+- self.setStyleSheet("background:" + config.get("osdlyrics_background"))
++ self.setStyleSheet(
++ "background:" + config.get("osdlyrics_background"))
+ if config.get("osdlyrics_transparent"):
+ self.setAttribute(QtCore.Qt.WA_TranslucentBackground)
+ self.setAttribute(QtCore.Qt.WA_ShowWithoutActivating)
+@@ -51,11 +52,10 @@ if pyqt_activity:
self.setMinimumSize(600, 50)
osdlyrics_size = config.get("osdlyrics_size")
self.resize(osdlyrics_size[0], osdlyrics_size[1])
- scn = QtGui.QApplication.desktop().screenNumber(
-- QtGui.QApplication.desktop().cursor().pos())
+- QtGui.QApplication.desktop().cursor().pos()
+- )
- bl = QtGui.QApplication.desktop().screenGeometry(scn).bottomLeft()
- br = QtGui.QApplication.desktop().screenGeometry(scn).bottomRight()
+ scn = QtWidgets.QApplication.desktop().screenNumber(
@@ -46,15 +57,15 @@ index bd96e09..5e66843 100644
bc = (bl + br) / 2
frameGeo = self.frameGeometry()
frameGeo.moveCenter(bc)
-@@ -114,7 +114,7 @@ if pyqt_activity:
+@@ -117,7 +117,7 @@ if pyqt_activity:
def show_lyrics():
- app = QtGui.QApplication(sys.argv)
+ app = QtWidgets.QApplication(sys.argv)
lyrics = Lyrics()
- QtDBus.QDBusConnection.sessionBus().registerService('org.musicbox.Bus')
- QtDBus.QDBusConnection.sessionBus().registerObject('/', lyrics)
+ QtDBus.QDBusConnection.sessionBus().registerService("org.musicbox.Bus")
+ QtDBus.QDBusConnection.sessionBus().registerObject("/", lyrics)
--
-2.19.1
+2.20.1
diff --git a/PKGBUILD b/PKGBUILD
index 10c01c1eccdd..300211ffab59 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@
pkgname=netease-musicbox-git
_gitname=musicbox
-pkgver=r579.8ce4a7e
+pkgver=r586.900d9bd
pkgrel=1
pkgdesc="A sexy command line interface musicbox for NetEase based on Python"
arch=(any)
url="https://github.com/darknessomi/musicbox"
-depends=('mpg123' 'python-pycryptodomex' 'python-requests' 'python-future')
+depends=('mpg123' 'python-pycryptodomex' 'python-requests' 'python-future' 'python-requests-cache')
makedepends=('python-setuptools' 'git')
optdepends=('aria2: music caching'
'libnotify: notifications'
@@ -22,11 +22,11 @@ license=('MIT')
source=("${_gitname}::git+https://github.com/darknessomi/musicbox"
"LICENSE::https://raw.githubusercontent.com/darknessomi/musicbox/master/LICENSE.txt"
- "0001-Fixed-Replace_pyqt4_to_pyqt5_as_depends.patch")
+ "0001-Replace_pyqt4_to_pyqt5_as_depends.patch")
sha256sums=('SKIP'
- '50efc98142cfffe413d73c87c91f2687dfb774217af923f03dfdc8426c9d9552'
- '55b4dd116b8b7a1b47854f52ce1e9f8422fb72702beb4c259bda388e23060484')
+ 'e6ce649439eace57267c94e651e38370582f883e6341b3203e951b9497433641'
+ '485d7a1e900da50a4d6d055131ebc3b2072cf5760d9e27cd266ff373aedb6d46')
pkgver() {
cd "${srcdir}/${_gitname}"
@@ -35,7 +35,7 @@ pkgver() {
prepare() {
cd "${srcdir}/${_gitname}"
- patch -Np1 -i "${srcdir}/0001-Fixed-Replace_pyqt4_to_pyqt5_as_depends.patch"
+ patch -Np1 -i "${srcdir}/0001-Replace_pyqt4_to_pyqt5_as_depends.patch"
}
package() {