summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSwift Geek2013-06-02 02:25:14 +0000
committerThomas Dziedzic2013-06-02 02:25:14 +0000
commit9ded36ffb7f1def8eaabed29c59de42f86091e0b (patch)
tree1178e840041605d5796a95853dfae1b2b243ce8f
downloadaur-9ded36ffb7f1def8eaabed29c59de42f86091e0b.tar.gz
Import from pkgbuild.com service
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD41
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..130a28a0e579
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = netfabb-basic
+ pkgdesc = view and repair STL files
+ pkgver = 4.9.5
+ pkgrel = 0
+ url = http://www.netfabb.com/download.php
+ arch = i686
+ arch = x86_64
+ license = fix_namcap
+ depends = gtk2
+ depends = gcc-libs
+ depends = desktop-file-utils
+ depends = hicolor-icon-theme
+ source = http://www.netfabb.com/download/netfabb_linux.tar.gz
+ md5sums = SKIP
+
+pkgname = netfabb-basic
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8282eb9b68ef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Swift Geek <swifgeek ɐ google m č0m>
+# Contributor: Nick Østergaard <oe.nick at gmail dot com>
+
+pkgname=netfabb-basic
+pkgver=4.9.5
+pkgrel=0
+pkgdesc="view and repair STL files"
+arch=('i686' 'x86_64')
+url="http://www.netfabb.com/download.php"
+license=('fix_namcap')
+depends=('gtk2' 'gcc-libs' 'desktop-file-utils' 'hicolor-icon-theme')
+#optdepends=('')
+#provides=('slic3r')
+#conflicts=('slic3r')
+#Consider uncommenting line below in case of false negative test results ;)
+#BUILDENV+=('!check')
+source=('http://www.netfabb.com/download/netfabb_linux.tar.gz')
+md5sums=('SKIP')
+
+if test "$CARCH" == x86_64; then
+ source=('http://www.netfabb.com/download/netfabb_linux64.tar.gz')
+ md5sums=('36577e34a3b51742c3ace44cfd15d794')
+fi
+
+prepare() {
+ cd "$srcdir/$pkgname"
+ # sed /usr to $pkgdir/usr in install.sh, TODO: if echo then only after last > / if echo then only last match in line
+ sed -i "s#/usr#$pkgdir/usr#" install.sh
+ #sed "/echo/ s=>>/usr=>>$pkgdir/usr="
+ # remove uninstall.sh lines from install.sh
+ sed -i '/uninstall/d' install.sh
+ # do sth with license/readme/changelog files?
+ bash -i || true
+ sleep 3
+}
+
+package () {
+ cd "$srcdir/$pkgname"
+ ./install.sh
+}
+