summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Savannah2017-06-18 03:38:32 -0400
committerTim Savannah2017-06-18 03:38:32 -0400
commit733f448474f244c725c8b55c8239aed4c9de05bc (patch)
treed0ff0574e4d11c97d0697bc3ef93414b6d068ff4
downloadaur-733f448474f244c725c8b55c8239aed4c9de05bc.tar.gz
Add NetFetch 3.0.3
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD39
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..986dd58291d5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = netfetch
+ pkgdesc = Networked file storage and retrieval with optional password protection and compression using Redis
+ pkgver = 3.0.3
+ pkgrel = 1
+ url = http://github.com/kata198/NetFetch
+ arch = any
+ license = GPLv2
+ makedepends = python-setuptools
+ makedepends = python
+ depends = python-setuptools
+ depends = python
+ depends = python-redis
+ depends = python-indexedredis
+ backup = etc/netfetch.cfg
+ source = https://github.com/kata198/NetFetch/archive/3.0.3.tar.gz
+ sha512sums = 4fa515a1fbf52965b99e08bd694b1010835be71bbf579eecefd5827cdfbb888744ad623d4f998b66e2a44561b0ce414de14b53375dfbfc19d332b8c2a2ff18e5
+
+pkgname = netfetch
+ depends = python-setuptools
+ depends = python
+ depends = python-netfetch
+
+pkgname = python-netfetch
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4eaa331ec02f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Tim Savannah <kata198@gmail.com>
+
+pkgname=('netfetch' 'python-netfetch')
+_realName=NetFetch
+pkgdesc="Networked file storage and retrieval with optional password protection and compression using Redis"
+pkgver=3.0.3
+pkgrel=1
+arch=('any')
+license=('GPLv2')
+url="http://github.com/kata198/NetFetch"
+makedepends=('python-setuptools' 'python')
+depends=('python-setuptools' 'python' 'python-redis' 'python-indexedredis')
+source=("https://github.com/kata198/NetFetch/archive/${pkgver}.tar.gz")
+backup=("etc/netfetch.cfg")
+sha512sums=("4fa515a1fbf52965b99e08bd694b1010835be71bbf579eecefd5827cdfbb888744ad623d4f998b66e2a44561b0ce414de14b53375dfbfc19d332b8c2a2ff18e5")
+
+build() {
+ cd "$srcdir/${_realName}-$pkgver"
+ python setup.py build
+}
+
+package_netfetch() {
+ depends=('python-setuptools' 'python' 'python-netfetch')
+ cd "${_realName}-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+
+ mkdir -p "${pkgdir}/etc"
+
+ install -m 775 example.cfg "${pkgdir}/etc/netfetch.cfg"
+
+ rm -Rf "${pkgdir}/usr/lib"
+}
+
+package_python-netfetch() {
+ cd "${_realName}-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+
+ rm -Rf "${pkgdir}/usr/bin"
+}