summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2023-01-02 04:33:05 +0800
committerlilac2023-01-02 04:33:05 +0800
commit4a8d51a274668a0ad5db9382f169126993062bb7 (patch)
tree01d6a49cbef9d0aa3bfb9042711fb629c1adb1a2
parentd0dbcae45072fa850e2c11c05f3fabf4173c0027 (diff)
downloadaur-4a8d51a274668a0ad5db9382f169126993062bb7.tar.gz
[lilac] updated to r88.74c5e6f-1
-rw-r--r--.SRCINFO6
-rw-r--r--0001-fix-build-error-on-linux-6.1.patch34
-rw-r--r--PKGBUILD10
3 files changed, 5 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9ad3594f9d2e..a07fd5465c34 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = netfilter-fullconenat-dkms-git
pkgdesc = A kernel module that turns MASQUERADE into full cone SNAT
- pkgver = r85.108a36c
- pkgrel = 3
+ pkgver = r88.74c5e6f
+ pkgrel = 1
url = https://github.com/llccd/netfilter-full-cone-nat
arch = any
license = GPL2
@@ -14,11 +14,9 @@ pkgbase = netfilter-fullconenat-dkms-git
source = dkms.conf
source = Kbuild
source = netfilter-fullconenat-dkms-git::git+https://github.com/llccd/netfilter-full-cone-nat.git
- source = 0001-fix-build-error-on-linux-6.1.patch
sha256sums = a17dfdf1fd046219daeacc60065e3a81c80c2eb2cfdf6d8068278c509577f571
sha256sums = d6823506b2c9e99b282d29270b0001de946dfe48462056b80aa9b564d67f7642
sha256sums = 7ff12ad066a68c65f23fc7e01654ca459ce3458172e3dce30f42553fa44dd7c2
sha256sums = SKIP
- sha256sums = 00e7d87199c74b5a76869a9eea364afe803779b2a1bacc1bfd8d75d03ccaa904
pkgname = netfilter-fullconenat-dkms-git
diff --git a/0001-fix-build-error-on-linux-6.1.patch b/0001-fix-build-error-on-linux-6.1.patch
deleted file mode 100644
index a576c452a3f5..000000000000
--- a/0001-fix-build-error-on-linux-6.1.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From 0f213788aff74b0ae55a8689ea3ee18be64e798e Mon Sep 17 00:00:00 2001
-From: edward-p <edward@edward-p.xyz>
-Date: Mon, 12 Dec 2022 16:57:00 +0800
-Subject: [PATCH] fix build error on linux-6.1
-
----
- xt_FULLCONENAT.c | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/xt_FULLCONENAT.c b/xt_FULLCONENAT.c
-index f96cfd8..4f6e24b 100644
---- a/xt_FULLCONENAT.c
-+++ b/xt_FULLCONENAT.c
-@@ -325,7 +325,7 @@ static uint16_t find_appropriate_port6(struct net *net, const u16 zone, const ui
- /* for now we do the same thing for both --random and --random-fully */
-
- /* select a random starting point */
-- start = (uint16_t)(prandom_u32() % (u32)range_size);
-+ start = (uint16_t)(get_random_u32() % (u32)range_size);
- } else {
-
- if ((original_port >= min && original_port <= min + range_size - 1)
-@@ -995,7 +995,7 @@ static uint16_t find_appropriate_port(struct net *net, const u16 zone, const uin
- /* for now we do the same thing for both --random and --random-fully */
-
- /* select a random starting point */
-- start = (uint16_t)(prandom_u32() % (u32)range_size);
-+ start = (uint16_t)(get_random_u32() % (u32)range_size);
- } else {
-
- if ((original_port >= min && original_port <= min + range_size - 1)
---
-2.38.1
-
diff --git a/PKGBUILD b/PKGBUILD
index 4d9588075a9a..26bd3954aabd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Edward Pacman <edward@edward-p.xyz>
pkgname=netfilter-fullconenat-dkms-git
-pkgver=r85.108a36c
-pkgrel=3
+pkgver=r88.74c5e6f
+pkgrel=1
pkgdesc="A kernel module that turns MASQUERADE into full cone SNAT"
arch=('any')
url="https://github.com/llccd/netfilter-full-cone-nat"
@@ -16,18 +16,14 @@ source=("netfilter-fullconenat-dkms.conf"
"dkms.conf"
"Kbuild"
"${pkgname}::git+https://github.com/llccd/netfilter-full-cone-nat.git"
- "0001-fix-build-error-on-linux-6.1.patch"
)
sha256sums=('a17dfdf1fd046219daeacc60065e3a81c80c2eb2cfdf6d8068278c509577f571'
'd6823506b2c9e99b282d29270b0001de946dfe48462056b80aa9b564d67f7642'
'7ff12ad066a68c65f23fc7e01654ca459ce3458172e3dce30f42553fa44dd7c2'
- 'SKIP'
- '00e7d87199c74b5a76869a9eea364afe803779b2a1bacc1bfd8d75d03ccaa904')
+ 'SKIP')
prepare(){
cd "$srcdir/${pkgname}"
-
- patch -Np1 < ../0001-fix-build-error-on-linux-6.1.patch
}
pkgver() {