summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2022-12-12 20:18:26 +0800
committerlilac2022-12-12 20:18:26 +0800
commitd0dbcae45072fa850e2c11c05f3fabf4173c0027 (patch)
tree70bbf5bd8f8c7e2f89f9fbaf5489ece85781df0f
parent3045ad5c384e6b0b35cdc5b39dd511f1195bbc6d (diff)
downloadaur-d0dbcae45072fa850e2c11c05f3fabf4173c0027.tar.gz
[lilac] updated to r85.108a36c-3
-rw-r--r--.SRCINFO6
-rw-r--r--0001-fix-build-error-on-linux-6.1.patch34
-rw-r--r--PKGBUILD17
3 files changed, 51 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6797c9a4224e..9ad3594f9d2e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = netfilter-fullconenat-dkms-git
pkgdesc = A kernel module that turns MASQUERADE into full cone SNAT
- pkgver = r81.7fe0260
- pkgrel = 1
+ pkgver = r85.108a36c
+ pkgrel = 3
url = https://github.com/llccd/netfilter-full-cone-nat
arch = any
license = GPL2
@@ -14,9 +14,11 @@ pkgbase = netfilter-fullconenat-dkms-git
source = dkms.conf
source = Kbuild
source = netfilter-fullconenat-dkms-git::git+https://github.com/llccd/netfilter-full-cone-nat.git
+ source = 0001-fix-build-error-on-linux-6.1.patch
sha256sums = a17dfdf1fd046219daeacc60065e3a81c80c2eb2cfdf6d8068278c509577f571
sha256sums = d6823506b2c9e99b282d29270b0001de946dfe48462056b80aa9b564d67f7642
sha256sums = 7ff12ad066a68c65f23fc7e01654ca459ce3458172e3dce30f42553fa44dd7c2
sha256sums = SKIP
+ sha256sums = 00e7d87199c74b5a76869a9eea364afe803779b2a1bacc1bfd8d75d03ccaa904
pkgname = netfilter-fullconenat-dkms-git
diff --git a/0001-fix-build-error-on-linux-6.1.patch b/0001-fix-build-error-on-linux-6.1.patch
new file mode 100644
index 000000000000..a576c452a3f5
--- /dev/null
+++ b/0001-fix-build-error-on-linux-6.1.patch
@@ -0,0 +1,34 @@
+From 0f213788aff74b0ae55a8689ea3ee18be64e798e Mon Sep 17 00:00:00 2001
+From: edward-p <edward@edward-p.xyz>
+Date: Mon, 12 Dec 2022 16:57:00 +0800
+Subject: [PATCH] fix build error on linux-6.1
+
+---
+ xt_FULLCONENAT.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/xt_FULLCONENAT.c b/xt_FULLCONENAT.c
+index f96cfd8..4f6e24b 100644
+--- a/xt_FULLCONENAT.c
++++ b/xt_FULLCONENAT.c
+@@ -325,7 +325,7 @@ static uint16_t find_appropriate_port6(struct net *net, const u16 zone, const ui
+ /* for now we do the same thing for both --random and --random-fully */
+
+ /* select a random starting point */
+- start = (uint16_t)(prandom_u32() % (u32)range_size);
++ start = (uint16_t)(get_random_u32() % (u32)range_size);
+ } else {
+
+ if ((original_port >= min && original_port <= min + range_size - 1)
+@@ -995,7 +995,7 @@ static uint16_t find_appropriate_port(struct net *net, const u16 zone, const uin
+ /* for now we do the same thing for both --random and --random-fully */
+
+ /* select a random starting point */
+- start = (uint16_t)(prandom_u32() % (u32)range_size);
++ start = (uint16_t)(get_random_u32() % (u32)range_size);
+ } else {
+
+ if ((original_port >= min && original_port <= min + range_size - 1)
+--
+2.38.1
+
diff --git a/PKGBUILD b/PKGBUILD
index 0add8d704421..4d9588075a9a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Edward Pacman <edward@edward-p.xyz>
pkgname=netfilter-fullconenat-dkms-git
-pkgver=r81.7fe0260
-pkgrel=1
+pkgver=r85.108a36c
+pkgrel=3
pkgdesc="A kernel module that turns MASQUERADE into full cone SNAT"
arch=('any')
url="https://github.com/llccd/netfilter-full-cone-nat"
@@ -15,11 +15,20 @@ conflicts=('netfilter-fullconenat')
source=("netfilter-fullconenat-dkms.conf"
"dkms.conf"
"Kbuild"
- "${pkgname}::git+https://github.com/llccd/netfilter-full-cone-nat.git")
+ "${pkgname}::git+https://github.com/llccd/netfilter-full-cone-nat.git"
+ "0001-fix-build-error-on-linux-6.1.patch"
+ )
sha256sums=('a17dfdf1fd046219daeacc60065e3a81c80c2eb2cfdf6d8068278c509577f571'
'd6823506b2c9e99b282d29270b0001de946dfe48462056b80aa9b564d67f7642'
'7ff12ad066a68c65f23fc7e01654ca459ce3458172e3dce30f42553fa44dd7c2'
- 'SKIP')
+ 'SKIP'
+ '00e7d87199c74b5a76869a9eea364afe803779b2a1bacc1bfd8d75d03ccaa904')
+
+prepare(){
+ cd "$srcdir/${pkgname}"
+
+ patch -Np1 < ../0001-fix-build-error-on-linux-6.1.patch
+}
pkgver() {
cd "$srcdir/${pkgname}"