summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgameslayer2022-12-26 13:09:47 +1000
committergameslayer2022-12-26 13:09:47 +1000
commitdee189dac0a18ff4532cb39a1c338117b251eb87 (patch)
tree46b382334d2722cee62ac0ac0af7bce4cc14cf22
parent8a1ecd049f01eb52dfdd862446fa5648ad865cc8 (diff)
downloadaur-dee189dac0a18ff4532cb39a1c338117b251eb87.tar.gz
AUR Hotfix only. - Added launch script for package manager use only, this will also be used to resolve the KDE launch issue as I make some changes to the PKGBUILD file on the AUR. The package will remain as the same version so users affected by the issue will just need to clear their cache and reinstall the AUR package.
-rw-r--r--.SRCINFO4
-rwxr-xr-xPKGBUILD12
2 files changed, 5 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 66565b43c9e2..2ea31b8a84ab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = netflix
pkgdesc = Unnofficial Netflix desktop application
pkgver = 1.0.5
- pkgrel = 2
+ pkgrel = 3
url = https://gitlab.com/netflix-desktop/application
arch = x86_64
license = GPL
@@ -11,7 +11,7 @@ pkgbase = netflix
depends = libxss
depends = git
conflicts = Netflix-bin
- source = https://gitlab.com/netflix-desktop/application/-/archive/1.0.5-2/application-1.0.5-2.tar.bz2
+ source = https://gitlab.com/netflix-desktop/application/-/archive/1.0.5-3/application-1.0.5-3.tar.bz2
sha256sums = SKIP
pkgname = netflix
diff --git a/PKGBUILD b/PKGBUILD
index bdc7f45c5154..e630774e534e 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
pkgname=netflix
_pkgname=Netflix
pkgver=1.0.5
-pkgrel=2
+pkgrel=3
pkgdesc="Unnofficial Netflix desktop application"
arch=('x86_64')
url="https://gitlab.com/netflix-desktop/application"
@@ -15,13 +15,7 @@ sha256sums=('SKIP')
package() {
for dir in application-$pkgver-$pkgrel ; do mv "${dir}" "$_pkgname" ;done
cd "$srcdir/$_pkgname"
- cat <<EOT >> $pkgname
- #!/bin/bash
- cd /opt/$_pkgname &&
- npm start
-EOT
-
- chmod +x $pkgname
+ chmod +x $pkgname.sh
ln -sf "/opt/libelectron/node_modules" "$srcdir/$_pkgname"
install -dm755 "$pkgdir/opt/$_pkgname"
install -dm755 "$pkgdir/usr/share/pixmaps"
@@ -31,7 +25,7 @@ EOT
# Link to binary
install -dm755 "$pkgdir/usr/bin"
- ln -s "/opt/$_pkgname/$pkgname" "$pkgdir/usr/bin"
+ ln -s "/opt/$_pkgname/$pkgname.sh" "$pkgdir/usr/bin/$pkgname"
# Desktop Entry
install -Dm644 "$srcdir/$_pkgname/$_pkgname.desktop" \