summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnish Bhatt2013-09-09 15:43:34 -0700
committerAnish Bhatt2013-09-09 15:43:34 -0700
commit666780db837f85105961396de69cb9381d53fd93 (patch)
treeee1c5d9d2dc6b1b37b3b376ce9431a5c58ac473c
parent3abdd3a4574cf5a3c1d78246da432127c4095da6 (diff)
downloadaur-666780db837f85105961396de69cb9381d53fd93.tar.gz
Don't accidentally use pipelight in netflix-desktop, disable hardware acceleration by default
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rwxr-xr-xnetflix-desktop.launcher22
3 files changed, 22 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 799cda78e58d..60edab44939f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = netflix-desktop
pkgdesc = An automated script for viewing Netflix through Firefox and patched WINE
pkgver = 0.8.5
- pkgrel = 4
+ pkgrel = 5
url = https://launchpad.net/netflix-desktop/
install = netflix-desktop.install
arch = i686
@@ -20,13 +20,13 @@ pkgbase = netflix-desktop
depends = openal
depends = mpg123
depends = libxcomposite
- source = https://launchpad.net/netflix-desktop/trunk/0.8.5/+download/netflix-desktop.tar.gz
+ source = netflix-desktop-0.8.5.tar.gz::https://launchpad.net/netflix-desktop/trunk/0.8.5/+download/netflix-desktop.tar.gz
source = netflix-desktop.desktop
source = netflix-desktop.launcher
source = NetflixIcon.png
md5sums = 139aa89ce9536ff860445ec67777f81a
md5sums = a41f098487affa1de34c8b44d52617b5
- md5sums = bd3492b17011d5acd4e05df1f60ead3b
+ md5sums = ffcf9a2234cfaccf56eaa16c270f9383
md5sums = 0a4c2ef50831a751dae74315eb066c01
pkgname = netflix-desktop
diff --git a/PKGBUILD b/PKGBUILD
index e8a19f26001d..73e8464035d7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname='netflix-desktop'
pkgver=0.8.5
-pkgrel=4
+pkgrel=5
pkgdesc="An automated script for viewing Netflix through Firefox and patched WINE"
url="https://launchpad.net/netflix-desktop/"
arch=('i686' 'x86_64')
@@ -33,14 +33,14 @@ fi
install=netflix-desktop.install
-source=("https://launchpad.net/netflix-desktop/trunk/${pkgver}/+download/${pkgname}.tar.gz"
+source=("${pkgname}-${pkgver}.tar.gz::https://launchpad.net/${pkgname}/trunk/${pkgver}/+download/${pkgname}.tar.gz"
netflix-desktop.desktop
netflix-desktop.launcher
NetflixIcon.png)
md5sums=('139aa89ce9536ff860445ec67777f81a'
'a41f098487affa1de34c8b44d52617b5'
- 'bd3492b17011d5acd4e05df1f60ead3b'
+ 'ffcf9a2234cfaccf56eaa16c270f9383'
'0a4c2ef50831a751dae74315eb066c01')
prepare() {
diff --git a/netflix-desktop.launcher b/netflix-desktop.launcher
index d9cbd02a505c..809681113ab7 100755
--- a/netflix-desktop.launcher
+++ b/netflix-desktop.launcher
@@ -45,9 +45,10 @@ LOCAL_SUMS="${WINEPREFIX}/wine-browser-installer.sha256sums";
SHOWDEBUG="0";
RELAYLOG="0";
${PKG_DIR}/hw-accel-default; HW_ACCELERATION_DISABLED=$?;
+HW_ACCELERATION_DISABLED=1;
HW_ACCELERATION_FORCED="0";
ALLOW_ADDONS="0";
-USE_PIPELIGHT="1";
+USE_PIPELIGHT="0";
WINDOW_MODE="fullscreen";
SUDO=$(which gksudo 2>/dev/null);
if [ "${SUDO}" = "" ]; then
@@ -274,9 +275,17 @@ if [ "${CHECKSUMS_MATCH}" -eq "1" ]; then
(
echo "1";
# ${WINE} wineboot -i > /dev/null;
-# for DEP in $DEPENDENCIES; do
- "${PKG_DIR}/install-dependency" wine-silverlight4-installer;
-# done
+ "${PKG_DIR}/install-dependency" wine-silverlight4-installer;
+ SILVERLIGHT_VERSION="4.1.10329.0"
+ # Configure the plugin registry key for the Windows Firefox version
+ tmpfile="/tmp/wine-browser.$$.reg";
+ cat >"${tmpfile}" <<-EOF
+ REGEDIT4
+
+ [HKEY_LOCAL_MACHINE\\Software\\MozillaPlugins\\@Microsoft.com/NpCtrl,version=1.0]
+ "Path"="C:\\\\Program Files\\\\Silverlight\\\\${SILVERLIGHT_VERSION}\\\\npctrl.dll"
+ EOF
+ ${WINE} regedit ${tmpfile};
echo "100";
) | zenity --progress --pulsate --no-cancel --auto-close --text="${TASK}";
touch ${WINEPREFIX}/run
@@ -403,9 +412,10 @@ fi
if [ "${PIPELIGHT_INSTALLED}" -eq "1" ] && [ "${USE_PIPELIGHT}" -eq "1" ]; then
FIREFOX="$(which firefox)";
FIREFOX_PROFILE="${BROWSER_PROFILE}";
-# export PIPELIGHT_CONFIG="${WINEPREFIX}/pipelight-config";
-# rm "${BROWSER_PROFILE}/pluginreg.dat"; # reset the plugin registry on every load
+ export PIPELIGHT_CONFIG="${WINEPREFIX}/pipelight-config";
+ rm "${BROWSER_PROFILE}/pluginreg.dat"; # reset the plugin registry on every load
else
+ ${WINE} "${WINEPREFIX}/FirefoxSetup.exe" /INI=Z:\\usr\\share\\netflix-desktop\\browser-settings.ini 2>>${OUTPUT};
FIREFOX="${WINE} \"C:\\Program Files\\Mozilla Firefox\\firefox.exe\"";
FIREFOX_PROFILE="C:\\browser-profile";
fi