summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnish Bhatt2013-08-18 13:55:54 -0700
committerAnish Bhatt2013-08-18 13:55:54 -0700
commit8f90920b5329149890d795d6333322ca7fc17e2a (patch)
treeaaa63e02b772c27e65196744527b5c0d48150bfe
parent623d4c25fd90eae5a2c33c041e2a61f5ddd8a733 (diff)
downloadaur-8f90920b5329149890d795d6333322ca7fc17e2a.tar.gz
update both packages
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
-rwxr-xr-xnetflix-desktop.launcher6
3 files changed, 14 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0ed2a9ac4c77..13245b974fa0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = netflix-desktop
pkgdesc = An automated script for viewing Netflix through Firefox and patched WINE
- pkgver = 0.7
- pkgrel = 3
+ pkgver = 0.8
+ pkgrel = 2
url = https://launchpad.net/netflix-desktop/
install = netflix-desktop.install
arch = i686
@@ -18,13 +18,13 @@ pkgbase = netflix-desktop
depends = openal
depends = mpg123
depends = libxcomposite
- source = https://launchpad.net/netflix-desktop/trunk/0.7.0/+download/netflix-desktop.tar.gz
+ source = https://github.com/anish/archlinux/raw/master/netflix-desktop/netflix-desktop.tar.gz
source = netflix-desktop.desktop
source = netflix-desktop.launcher
source = NetflixIcon.png
md5sums = c6da1fd128cfbe35423fe86ad01f7db3
md5sums = a41f098487affa1de34c8b44d52617b5
- md5sums = 5eb47189f7f8ec959678339f605b7546
+ md5sums = aa3bf2a5686f1b038e1561f8cc28929e
md5sums = 0a4c2ef50831a751dae74315eb066c01
pkgname = netflix-desktop
diff --git a/PKGBUILD b/PKGBUILD
index 59ef9ecde009..60bb6cbd95dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Based on the wine-git in AUR
pkgname='netflix-desktop'
-pkgver=0.7
-pkgrel=3
+pkgver=0.8
+pkgrel=2
pkgdesc="An automated script for viewing Netflix through Firefox and patched WINE"
url="https://launchpad.net/netflix-desktop/"
arch=('i686' 'x86_64')
@@ -32,15 +32,15 @@ fi
install=netflix-desktop.install
-source=("https://launchpad.net/netflix-desktop/trunk/${pkgver}.0/+download/${pkgname}.tar.gz"
+source=("https://github.com/anish/archlinux/raw/master/netflix-desktop/netflix-desktop.tar.gz"
+#source=("https://launchpad.net/netflix-desktop/trunk/${pkgver}.0/+download/${pkgname}.tar.gz"
netflix-desktop.desktop
netflix-desktop.launcher
NetflixIcon.png)
-
md5sums=('c6da1fd128cfbe35423fe86ad01f7db3'
'a41f098487affa1de34c8b44d52617b5'
- '5eb47189f7f8ec959678339f605b7546'
+ 'aa3bf2a5686f1b038e1561f8cc28929e'
'0a4c2ef50831a751dae74315eb066c01')
build() {
diff --git a/netflix-desktop.launcher b/netflix-desktop.launcher
index 6a0cc31ef38c..af97112c0c9d 100755
--- a/netflix-desktop.launcher
+++ b/netflix-desktop.launcher
@@ -10,6 +10,10 @@ WINE="/usr/bin/wine";
SHOWDEBUG="0";
RELAYLOG="0";
+if [ -e /opt/wine-silverlight/bin/wine ];then
+ WINE="/opt/wine-silverlight/bin/wine";
+fi
+
# Use 32bit arch by default required by silverlight
export WINEARCH=win32;
@@ -287,7 +291,7 @@ else
if [ -f "${NETFLIX_DESKTOP}/profile-settings" ]; then
. "${NETFLIX_DESKTOP}/profile-settings";
fi
- WINEVERSION=`/usr/bin/wine --version | sed -e 's/wine-//'`;
+ WINEVERSION=`$WINE --version | sed -e 's/wine-//'`;
OLDVERSION=`cat "${NETFLIX_DESKTOP}/wine-version" 2> /dev/null`;
NEWWINE=`vercomp "${WINEVERSION}" "1.5.19"`;
OLDPROFILE=`vercomp "${OLDVERSION}" "1.5.19"`;