summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimone Scalabrino2018-03-26 19:06:43 +0200
committerSimone Scalabrino2018-03-26 19:06:43 +0200
commita4a7ecfcff3726eb50a02a596c2d4191e1c817f5 (patch)
tree5b5e38650044b67a8e00213bc97ca0c9264433d0
downloadaur-a4a7ecfcff3726eb50a02a596c2d4191e1c817f5.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD23
-rw-r--r--netflix.desktop10
-rw-r--r--netflix.qtws8
-rw-r--r--netflix.svg12
5 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ed88d8488c45
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = netflix-qdesktop
+ pkgdesc = Netflix web-app based on qtws
+ pkgver = 0.9
+ pkgrel = 1
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = qtws-base
+ source = netflix.qtws
+ source = netflix.svg
+ source = netflix.desktop
+ md5sums = 8f0429c6d0d5a9df3c978cbe6021ca4e
+ md5sums = bb2e2f9ffb15061126229ef19464e58e
+ md5sums = 61730709cbde4e0cb8250d94e1dccc58
+
+pkgname = netflix-qdesktop
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..caeaf152cf47
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Simone Scalabrino <s dot scalabrino 9 at gmail dot com>
+webappname=netflix
+pkgname=${webappname}-qdesktop
+pkgver=0.9
+pkgrel=1
+pkgdesc='Netflix web-app based on qtws'
+arch=('i686' 'x86_64')
+license=('GPL3')
+depends=('qtws-base')
+source=("$webappname.qtws" "$webappname.svg" "$webappname.desktop")
+md5sums=('8f0429c6d0d5a9df3c978cbe6021ca4e'
+ 'bb2e2f9ffb15061126229ef19464e58e'
+ '61730709cbde4e0cb8250d94e1dccc58')
+
+package() {
+ mkdir -p ${pkgdir}/usr/share/qtws-apps/$webappname
+ echo ${srcdir}
+
+ install -Dm644 ${srcdir}/$webappname.qtws ${pkgdir}/usr/share/qtws-apps/$webappname/$webappname.qtws
+ install -Dm755 ${srcdir}/$webappname.desktop ${pkgdir}/usr/share/applications/$webappname-desktop.desktop
+ install -Dm644 ${srcdir}/$webappname.svg ${pkgdir}/usr/share/pixmaps/$webappname-desktop.svg
+}
+
diff --git a/netflix.desktop b/netflix.desktop
new file mode 100644
index 000000000000..abb5a2bf116e
--- /dev/null
+++ b/netflix.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=Netflix
+GenericName=Netflix
+Comment=Netflix Standalone Player
+Categories=Network;AudioVideo;Player;
+Exec=/usr/bin/qtws /usr/share/qtws-apps/netflix/netflix.qtws --disable-seccomp-filter-sandbox --register-pepper-plugins="/usr/lib/qt/plugins/ppapi/libwidevinecdmadapter.so; application/x-ppapi-widevine-cdm"
+Icon=netflix-desktop.svg
+StartupNotify=true
+Terminal=false
+Type=Application
diff --git a/netflix.qtws b/netflix.qtws
new file mode 100644
index 000000000000..a00935753147
--- /dev/null
+++ b/netflix.qtws
@@ -0,0 +1,8 @@
+{
+ "name": "Netflix",
+ "scope": ["netflix.com"],
+ "plugins": [],
+ "home": "http://netflix.com",
+ "icon": "/usr/share/pixmaps/netflix-desktop.svg",
+ "saveSession": true
+}
diff --git a/netflix.svg b/netflix.svg
new file mode 100644
index 000000000000..ddcaf3be4851
--- /dev/null
+++ b/netflix.svg
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" viewBox="0 0 48 48" version="1.1" width="48px" height="48px">
+<g id="surface1">
+<path style=" fill:#F44336;" d="M 5 18 C 5.699219 18 6.300781 18 7 18 C 7 22.101563 7 26.101563 7 30.199219 C 6.199219 30.300781 5.398438 30.398438 4.699219 30.5 C 3.699219 28 2 23.699219 2 23.699219 C 2 23.699219 2 28 2 30.800781 C 2.398438 30.800781 1.800781 30.800781 0 31.101563 C 0 26.800781 0 22.398438 0 18.101563 C 0.800781 18.101563 2 18.101563 2 18.101563 L 5 25.398438 C 5 25.398438 5 20.800781 5 18 Z "/>
+<path style=" fill:#F44336;" d="M 14.699219 20 C 14.699219 19.398438 14.699219 18.601563 14.699219 18 C 12.800781 18 10.898438 18 9 18 C 9 22 9 26 9 30 C 10.898438 29.800781 12.800781 29.601563 14.699219 29.398438 C 14.699219 28.800781 14.699219 28 14.699219 27.398438 C 13.5 27.5 12.300781 27.5 11 27.800781 C 11 26.699219 11 26.101563 11 25 C 11.898438 25 13.101563 25 14 25 C 14 24.398438 14 23.601563 14 23 C 13.101563 23 11.898438 23 11 23 C 11 21.898438 11 21.101563 11 20 C 11.601563 20.101563 14.199219 20.101563 14.699219 20 Z "/>
+<path style=" fill:#F44336;" d="M 16 20 C 16.101563 20 17.898438 20 18 20 C 18 23.199219 18 26 18 29.199219 C 18.699219 29.199219 19.300781 29.199219 20 29.101563 C 20 25.898438 20 23.199219 20 20 C 20.699219 20 21.300781 20 22 20 C 22 19.398438 22 18.601563 22 18 C 19.898438 18 18.101563 18 16 18 C 16 18.601563 16 19.398438 16 20 Z "/>
+<path style=" fill:#F44336;" d="M 28.601563 18 C 26.699219 18 24.898438 18 23 18 C 23 21.800781 23 25.199219 23 29 C 23.199219 29 23.398438 29 23.601563 29 C 24 29 24.5 29 25 29 C 25 27.398438 25 26.601563 25 25 C 25.101563 25 27.398438 25 27.699219 25 C 27.699219 24.398438 27.699219 23.601563 27.699219 23 C 27.398438 23 25.101563 23 25 23 C 25 22 25 21 25 20 C 25.199219 20 28.101563 20 28.601563 20 C 28.601563 19.5 28.601563 18.601563 28.601563 18 Z "/>
+<path style=" fill:#F44336;" d="M 32 27.5 C 32 24.199219 32 21.300781 32 18 C 31.300781 18 30.699219 18 30 18 C 30 21.800781 30 25.398438 30 29.199219 C 31.800781 29.300781 33.601563 29.398438 35.398438 29.601563 C 35.398438 29 35.398438 28.300781 35.398438 27.699219 C 34.300781 27.601563 33.101563 27.5 32 27.5 Z "/>
+<path style=" fill:#F44336;" d="M 37 29.699219 C 37.699219 29.800781 38.300781 29.800781 39 29.898438 C 39 25.898438 39 22 39 18 C 38.300781 18 37.699219 18 37 18 C 37 22 37 25.800781 37 29.699219 Z "/>
+<path style=" fill:#F44336;" d="M 45.398438 24.199219 C 46.300781 22.199219 47.101563 20.199219 48 18.101563 C 47.300781 18.101563 46.5 18.101563 45.800781 18.101563 C 45.300781 19.398438 44.898438 20.300781 44.398438 21.5 C 43.898438 20.199219 43.601563 19.300781 43.101563 18.101563 C 42.398438 18.101563 41.601563 18.101563 40.898438 18.101563 C 41.699219 20.101563 42.398438 22.101563 43.300781 24.199219 C 42.398438 26.199219 41.601563 28.199219 40.699219 30.199219 C 41.398438 30.300781 42.101563 30.398438 42.800781 30.5 C 43.300781 29.199219 43.800781 28.300781 44.300781 27 C 44.800781 28.398438 45.300781 29.398438 45.800781 30.800781 C 46.5 30.898438 47.398438 31 48.101563 31.101563 C 47.101563 28.699219 46.199219 26.300781 45.398438 24.199219 Z "/>
+</g>
+</svg>