summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcodywd2018-04-05 15:41:04 -0400
committercodywd2018-04-05 15:41:04 -0400
commita9c5ed4157270aa774149a4eca8f06366ae1977c (patch)
tree6e4f13aee830d7581d6609f7ef85fe696fa35eaf
downloadaur-a9c5ed4157270aa774149a4eca8f06366ae1977c.tar.gz
Initial push to AUR
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD34
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5f951f9a2bd3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = netgui
+ pkgdesc = GUI for netctl, stable but beta. Replaces WiFiz.
+ pkgver = 0.8
+ pkgrel = 1
+ url = https://github.com/codywd/NetGUI
+ arch = any
+ license = custom
+ makedepends = git
+ depends = python
+ depends = python-gobject
+ depends = netctl
+ depends = gtksourceview3
+ depends = libnotify
+ optdepends = notification-daemon: Desktop Notifications
+ optdepends = notify-osd: Desktop Notifications (others dont work for me personally)
+ provides = netgui
+ conflicts = netcfg
+ conflicts = wicd
+ replaces = wifiz
+ replaces = wifiz-git
+ options = !emptydirs
+ source = git+https://github.com/codywd/NetGUI.git
+ md5sums = SKIP
+ sha256sums = SKIP
+
+pkgname = netgui
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0a1e1c3fdee4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Cody Dostal <dostalcody@gmail.com>
+
+pkgname=netgui
+_gitname=NetGUI
+pkgver=0.8
+pkgrel=1
+pkgdesc="GUI for netctl, stable but beta. Replaces WiFiz."
+arch=('any')
+url="https://github.com/codywd/$_gitname"
+license=('custom')
+depends=('python' 'python-gobject' 'netctl' 'gtksourceview3' 'libnotify')
+optdepends=(
+'notification-daemon: Desktop Notifications'
+'notify-osd: Desktop Notifications (others dont work for me personally)'
+)
+makedepends=('git')
+provides=('netgui')
+conflicts=('netcfg' 'wicd')
+replaces=('wifiz' 'wifiz-git')
+options=(!emptydirs)
+source=("git+https://github.com/codywd/$_gitname.git")
+md5sums=('SKIP')
+sha256sums=('SKIP')
+
+pkgver() {
+cd $srcdir/netgui
+# Use the tag of the last commit
+git describe --always --long | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+package() {
+cd $srcdir/$_gitname
+python2 setup.py install --root="$pkgdir/" --optimize=1
+}