summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Keen2015-09-06 04:21:33 -0400
committerKyle Keen2015-09-06 04:21:33 -0400
commitb23bef24bc965763b4e4956ae90222d31c7c46a7 (patch)
tree57c67acfca23821fc13d836ff9391a8d84b833d7
parentfded411695e92a730aebc6959928c989bb3fc9b3 (diff)
downloadaur-b23bef24bc965763b4e4956ae90222d31c7c46a7.tar.gz
update to 4.3 beta2
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD20
2 files changed, 16 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6fcc01595651..57b96d66fe6b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = nethack4
pkgdesc = A modern fork of Nethack
- pkgver = 4.3.0.beta1
+ pkgver = 4.3.0.beta2
pkgrel = 1
url = http://nethack4.org/
arch = i686
@@ -13,8 +13,8 @@ pkgbase = nethack4
depends = gcc-libs
optdepends = sdl2: tiles
optdepends = libpng: tiles
- source = http://nethack4.org/media/releases/nethack4-4.3.0-beta1-source.tar.gz
- md5sums = 4b382dfca5553fce173291cc9840c2e5
+ source = http://nethack4.org/media/releases/nethack4-4.3-beta2.tar.gz
+ md5sums = 737403ba07a18fe3030a153471ba223d
pkgname = nethack4
diff --git a/PKGBUILD b/PKGBUILD
index 16da2ff508b2..17fbd419e722 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Kyle Keen <keenerd@gmail.com>
pkgname=nethack4
-pkgver=4.3.0.beta1
-_pkgver=4.3.0-beta1
+pkgver=4.3.0.beta2
+_pkgver=4.3-beta2
pkgrel=1
pkgdesc="A modern fork of Nethack"
arch=('i686' 'x86_64')
@@ -13,25 +13,31 @@ makedepends=('sdl2' 'libpng' 'chrpath')
optdepends=('sdl2: tiles'
'libpng: tiles')
#source=('git+https://gitorious.org/nitrohack/ais523.git#branch=nicehack')
-source=("http://nethack4.org/media/releases/nethack4-$_pkgver-source.tar.gz")
-md5sums=('4b382dfca5553fce173291cc9840c2e5')
+source=("http://nethack4.org/media/releases/nethack4-$_pkgver.tar.gz")
+md5sums=('737403ba07a18fe3030a153471ba223d')
# postgresql-libs: multiuser server
build() {
- cd "$srcdir"
+ cd "$srcdir/$pkgname-$_pkgver"
+
# allow aimake to run as "root" (fakeroot confuses it)
sed -i "s/\$^O ne 'MSWin32'/0/" aimake
+ # disable check for modified files (refuses to build)
+ sed -i "s/\$objtype eq 'path'/0/" aimake
+
mkdir -p build
mkdir -p opt
cd build
+ msg "Building console version"
../aimake --without=jansson --without=gui --without=server -i ../opt/
mv ../opt/nethack4 ../opt/nethack4-con
+ msg "Building SDL version"
../aimake --without=jansson --with=gui --without=server -i ../opt/
}
package() {
- cd "$srcdir"
+ cd "$srcdir/$pkgname-$_pkgver"
install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
# manually install
@@ -41,7 +47,7 @@ package() {
install -Dm755 nethack4-con "$pkgdir/usr/bin/nethack4"
install -Dm755 nethack4-sdl "$pkgdir/usr/bin/nethack4-sdl"
- chrpath -r "/usr/lib" lib/libnethack.so lib/libnethack_client.so
+ #chrpath -r "/usr/lib" lib/libnethack.so lib/libnethack_client.so
install -Dm755 lib/libnethack.so "$pkgdir/usr/lib/libnethack.so"
install -Dm755 lib/libnethack_client.so "$pkgdir/usr/lib/libnethack_client.so"
install -Dm755 lib/libuncursed_sdl.so "$pkgdir/usr/lib/libuncursed_sdl.so"