summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmil Bay2024-02-27 16:00:43 +0100
committerEmil Bay2024-02-27 16:00:43 +0100
commit770786fb3515957d02e6456bdb0f396ae885d49f (patch)
treee26c634da294f29e30f52f8b67aa4ad3e355576d
parent8cc23b02385059a9662d91366eaab4dbbdb4e2e6 (diff)
downloadaur-770786fb3515957d02e6456bdb0f396ae885d49f.tar.gz
Add signature checking
-rw-r--r--PKGBUILD22
1 files changed, 16 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4c0a158daecf..94787a66684b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,18 +4,28 @@ _pkgname=nethermind
pkgver=1.25.4
_pkgver=1.25.4
_commit=20b10b35
-pkgrel=1
+pkgrel=2
pkgdesc='A robust execution client for Ethereum node operators. Binary distribution.'
arch=('x86_64' 'aarch64')
-url='https://docs.nethermind.io/'
+url='https://downloads.nethermind.io/'
license=('LGPL-3.0-only')
depends=('zlib' 'base-devel')
provides=('nethermind' 'nethermind-cli' 'nethermind-launcher' 'Nethermind.Runner')
conflicts=('nethermind' 'nethermind-cli' 'nethermind-launcher' 'Nethermind.Runner')
-source_x86_64=("https://github.com/NethermindEth/nethermind/releases/download/${_pkgver}/nethermind-${_pkgver}-${_commit}-linux-x64.zip")
-source_aarch64=("https://github.com/NethermindEth/nethermind/releases/download/${_pkgver}/nethermind-${_pkgver}-${_commit}-linux-arm64.zip")
-sha256sums_x86_64=('b843bff5bc7199561aec3e3237caf111a0be6fed6ba386bb879e7a4cee2c6d36')
-sha256sums_aarch64=('726c00ef09ef4e890c742d351657d257b9dd70c8cce91e77ec5d47b1bf5b09b2')
+source_x86_64=(
+ "https://github.com/NethermindEth/nethermind/releases/download/${_pkgver}/nethermind-${_pkgver}-${_commit}-linux-x64.zip"
+ "https://nethdev.blob.core.windows.net/builds/nethermind-${_pkgver}-${_commit}-linux-x64.zip.asc"
+)
+source_aarch64=(
+ "https://github.com/NethermindEth/nethermind/releases/download/${_pkgver}/nethermind-${_pkgver}-${_commit}-linux-arm64.zip"
+ "https://nethdev.blob.core.windows.net/builds/nethermind-${_pkgver}-${_commit}-linux-arm64.zip.asc"
+)
+sha256sums_x86_64=('b843bff5bc7199561aec3e3237caf111a0be6fed6ba386bb879e7a4cee2c6d36' 'SKIP')
+md5sums_x86_64=('05848eaab4b1b621054ff507e8592d17' 'SKIP')
+sha256sums_aarch64=('726c00ef09ef4e890c742d351657d257b9dd70c8cce91e77ec5d47b1bf5b09b2' 'SKIP')
+md5sums_aarch64=('26d48b5bc0759cf70f291839bf6ae2a6' 'SKIP')
+# Can be acquired with `gpg --receive-keys CB6DA407 34E353C6` (listed at the bottom of https://downloads.nethermind.io/)
+validpgpkeys=('6942FB745ECE67D86CDA45704770A0C134E353C6' 'EECCEA1473108E3222D76722D39BE1DDCB6DA407')
package() {