summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEduardo Escobar2022-03-18 20:45:02 -0300
committerEduardo Escobar2022-03-18 20:45:02 -0300
commitcc8da2e37abe8080916e5ec7cf02cbc973f4e0dd (patch)
tree4c6440b7449943979e2a042c1d88c2d714c4f9df
parentdee301b3ba53f4ee6c100c378aa7f7f54b827e8e (diff)
downloadaur-cc8da2e37abe8080916e5ec7cf02cbc973f4e0dd.tar.gz
Updated. Added git makedependency. Grant setcap permission on install
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD5
-rw-r--r--nethogs.install11
3 files changed, 10 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 820677014d7d..7711169e37c8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = nethogs-git
pkgdesc = A net top tool which displays traffic used per process instead of per IP or interface. GIT version
- pkgver = v0.8.5.r59.ga46b3d6
+ pkgver = v0.8.5.r108.ga663b3a
pkgrel = 1
url = https://github.com/raboof/nethogs
install = nethogs.install
arch = x86_64
license = GPL
+ makedepends = git
depends = libpcap
depends = ncurses
depends = gcc-libs
provides = nethogs
conflicts = nethogs
- source = nethogs::git+https://github.com/raboof/nethogs
+ source = nethogs::git+https://github.com/raboof/nethogs#branch=main
md5sums = SKIP
pkgname = nethogs-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 1140f2274eae..d9297b899dd3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,17 +4,18 @@
# Contributor: Daenyth
pkgname=nethogs-git
_pkgname=nethogs
-pkgver=v0.8.5.r59.ga46b3d6
+pkgver=v0.8.5.r108.ga663b3a
pkgrel=1
pkgdesc="A net top tool which displays traffic used per process instead of per IP or interface. GIT version"
arch=("x86_64")
url="https://github.com/raboof/nethogs"
license=("GPL")
depends=("libpcap" "ncurses" "gcc-libs")
+makedepends=("git")
provides=("nethogs")
conflicts=("nethogs")
install="nethogs.install"
-source=("nethogs::git+https://github.com/raboof/nethogs")
+source=("nethogs::git+https://github.com/raboof/nethogs#branch=main")
md5sums=("SKIP")
pkgver() {
diff --git a/nethogs.install b/nethogs.install
index 7a60a8748d83..6c51ba9ca97f 100644
--- a/nethogs.install
+++ b/nethogs.install
@@ -1,16 +1,13 @@
#!/bin/sh
-message(){
- echo "In order to be run by a non-root user, nethogs needs the cap_net_admin and cap_net_raw capabilities. These can be set on the executable by using the setcap command, as follows:
-
-sudo setcap \"cap_net_admin,cap_net_raw+pe\" /usr/bin/nethogs
-"
+run_setcap(){
+ setcap "cap_net_admin,cap_net_raw+pe" /usr/bin/nethogs
}
post_upgrade(){
- message
+ run_setcap
}
post_install(){
- message
+ run_setcap
}