summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGraham Edgecombe2013-12-15 23:24:06 +0000
committerGraham Edgecombe2013-12-15 23:24:06 +0000
commite0fa89fe78520e626c85d6efc2b0515f3536ca5b (patch)
tree2355ce5892521383704b2d30b238580b8be8623d
downloadaur-e0fa89fe78520e626c85d6efc2b0515f3536ca5b.tar.gz
Add original package from AUR.
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD27
-rw-r--r--rwhod.conf1
-rw-r--r--rwhod.install7
-rw-r--r--rwhod.rc40
5 files changed, 98 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a97d7273f7ab
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = netkit-rwho-debian
+ pkgdesc = Remote who
+ pkgver = 0.17
+ pkgrel = 2
+ url = ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/
+ install = rwhod.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = glibc
+ conflicts = netkit-rwho
+ backup = etc/conf.d/rwhod
+ source = http://ftp.de.debian.org/debian/pool/main/n/netkit-rwho/netkit-rwho_0.17.orig.tar.gz
+ source = http://ftp.de.debian.org/debian/pool/main/n/netkit-rwho/netkit-rwho_0.17-12.diff.gz
+ source = rwhod.rc
+ source = rwhod.conf
+ md5sums = 0f71620d45d472f89134ba0d74242e75
+ md5sums = ccbb57e61d8594aa37c33cc906071ce1
+ md5sums = 5ab5042d60e508658e0a676d13556acb
+ md5sums = d052293ac9c851ba8093338c530b349e
+
+pkgname = netkit-rwho-debian
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ac5585643e3d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+pkgname=netkit-rwho-debian
+pkgver=0.17
+pkgrel=2
+arch=('i686' 'x86_64')
+license=('GPL')
+pkgdesc="Remote who"
+depends=('glibc')
+conflicts=('netkit-rwho')
+url="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/"
+install=rwhod.install
+backup=(etc/conf.d/rwhod)
+source=(http://ftp.de.debian.org/debian/pool/main/n/netkit-rwho/netkit-rwho_0.17.orig.tar.gz http://ftp.de.debian.org/debian/pool/main/n/netkit-rwho/netkit-rwho_$pkgver-12.diff.gz rwhod.rc rwhod.conf)
+md5sums=('0f71620d45d472f89134ba0d74242e75' 'ccbb57e61d8594aa37c33cc906071ce1' '5ab5042d60e508658e0a676d13556acb' 'd052293ac9c851ba8093338c530b349e')
+
+build() {
+ cd $srcdir/netkit-rwho-$pkgver
+ patch -Np1 -i ../netkit-rwho_$pkgver-12.diff
+ ./configure --prefix=/usr --installroot=$pkgdir
+ make || return 1
+ mkdir -p $pkgdir/usr/{bin,sbin,man/man1,man/man8} $pkgdir/etc/rc.d
+ make install || return 1
+ mkdir -p $pkgdir/var/spool/rwho
+ install -m755 $srcdir/rwhod.rc $pkgdir/etc/rc.d/rwhod || return 1
+ install -m644 -D $srcdir/rwhod.conf $pkgdir/etc/conf.d/rwhod || return 1
+}
+
+# end of file #
diff --git a/rwhod.conf b/rwhod.conf
new file mode 100644
index 000000000000..1eff3eef59bc
--- /dev/null
+++ b/rwhod.conf
@@ -0,0 +1 @@
+RWHOD_OPTS="-fau root"
diff --git a/rwhod.install b/rwhod.install
new file mode 100644
index 000000000000..5e863eb832bc
--- /dev/null
+++ b/rwhod.install
@@ -0,0 +1,7 @@
+post_install () {
+ echo ">> Place 'rwhod' in DAEMONS= in /etc/rc.conf to enable rwhod on system boot."
+}
+op=$1
+shift
+$op $*
+ \ No newline at end of file
diff --git a/rwhod.rc b/rwhod.rc
new file mode 100644
index 000000000000..f165c62955b9
--- /dev/null
+++ b/rwhod.rc
@@ -0,0 +1,40 @@
+#!/bin/bash
+
+. /etc/rc.conf
+. /etc/rc.d/functions
+. /etc/conf.d/rwhod
+
+PID=`pidof -o %PPID /usr/sbin/rwhod`
+case "$1" in
+ start)
+ stat_busy "Starting Remote WHO Daemon"
+ if [ -z "$PID" ]; then
+ /usr/sbin/rwhod $RWHOD_OPTS &
+ fi
+ if [ ! -z "$PID" ]; then
+ stat_fail
+ else
+ PID=`pidof -o %PPID /usr/sbin/rwhod`
+ echo $PID > /var/run/rwhod.pid
+ add_daemon rwhod
+ stat_done
+ fi
+ ;;
+ stop)
+ stat_busy "Stopping Remote WHO Daemon"
+ [ ! -z "$PID" ] && kill $PID &> /dev/null
+ if [ $? -gt 0 ]; then
+ stat_fail
+ else
+ rm_daemon rwhod
+ stat_done
+ fi
+ ;;
+ restart)
+ $0 stop
+ sleep 1
+ $0 start
+ ;;
+ *)
+ echo "usage: $0 {start|stop|restart}"
+esac