summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMantas Mikulėnas2017-09-05 08:39:09 +0300
committerMantas Mikulėnas2017-09-05 08:39:09 +0300
commit88dfe98e1be24d72c4ba5aa25af53cf4445cbc96 (patch)
tree8dcfd39bc30c9275dd420417726abdbb4e1fa9ab
parente0f943ff9e32187e8c124849812c2dff1f3723c5 (diff)
downloadaur-88dfe98e1be24d72c4ba5aa25af53cf4445cbc96.tar.gz
patch out some obsolete gcc syntax
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
-rw-r--r--netkit-telnet-ssl.gcc7.patch31
3 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1d30815f95a8..c4991397a1f5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,10 +11,12 @@ pkgbase = netkit-telnet-ssl
depends = ncurses
source = https://deb.debian.org/debian/pool/main/n/netkit-telnet-ssl/netkit-telnet-ssl_0.17.41+0.2.orig.tar.gz
source = https://deb.debian.org/debian/pool/main/n/netkit-telnet-ssl/netkit-telnet-ssl_0.17.41+0.2-3.debian.tar.xz
+ source = netkit-telnet-ssl.gcc7.patch
source = netkit-telnet-ssl.sysusers
source = telnet.xinetd
sha256sums = 9c80d5c7838361a328fb6b60016d503def9ce53ad3c589f3b08ff71a2bb88e00
sha256sums = 3f8b155bc5085e37a0d836867af330f2911953055010e30f30ca46698559a0aa
+ sha256sums = 2d3bf162cbb2e3df4ba6014206d95bbccf84ff4a277fdf9c0935a830f52443ee
sha256sums = 79fa821d14e29273da7a0405f7cbc0d8f13a961b168b6b257c71342d06878eb8
sha256sums = 9f1506cbe02b48fe7ac53932f068f3ebc8a8441ad92bdec17e2cd40ca7bcbaa8
diff --git a/PKGBUILD b/PKGBUILD
index a1a379d3bb59..e735219ca81f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,10 +14,12 @@ license=('BSD')
url="http://www.hcs.harvard.edu/~dholland/computers/netkit.html"
source=(https://deb.debian.org/debian/pool/main/n/${pkgname}/${pkgname}_${_debver}.orig.tar.gz
https://deb.debian.org/debian/pool/main/n/${pkgname}/${pkgname}_${_debver}-${_debrel}.debian.tar.xz
+ netkit-telnet-ssl.gcc7.patch
netkit-telnet-ssl.sysusers
telnet.xinetd)
sha256sums=('9c80d5c7838361a328fb6b60016d503def9ce53ad3c589f3b08ff71a2bb88e00'
'3f8b155bc5085e37a0d836867af330f2911953055010e30f30ca46698559a0aa'
+ '2d3bf162cbb2e3df4ba6014206d95bbccf84ff4a277fdf9c0935a830f52443ee'
'79fa821d14e29273da7a0405f7cbc0d8f13a961b168b6b257c71342d06878eb8'
'9f1506cbe02b48fe7ac53932f068f3ebc8a8441ad92bdec17e2cd40ca7bcbaa8')
@@ -28,6 +30,9 @@ prepare() {
msg2 "Applying $patch"
patch -Np1 < ../debian/patches/"$patch"
done
+
+ msg2 "Applying additional patches"
+ patch -Np1 < ../netkit-telnet-ssl.gcc7.patch
}
build() {
diff --git a/netkit-telnet-ssl.gcc7.patch b/netkit-telnet-ssl.gcc7.patch
new file mode 100644
index 000000000000..cde6fd6e8def
--- /dev/null
+++ b/netkit-telnet-ssl.gcc7.patch
@@ -0,0 +1,31 @@
+Only in netkit-telnet-0.17/telnetd: telnetd
+diff -ru netkit-telnet-0.17.orig/telnetd/utility.c netkit-telnet-0.17/telnetd/utility.c
+--- netkit-telnet-0.17.orig/telnetd/utility.c 2017-09-05 08:20:17.150075017 +0300
++++ netkit-telnet-0.17/telnetd/utility.c 2017-09-05 08:35:37.659899201 +0300
+@@ -39,6 +39,7 @@
+
+ #define PRINTOPTIONS
+
++#define _GNU_SOURCE
+ #include <stdarg.h>
+ #include <sys/utsname.h>
+ #include <sys/time.h>
+@@ -55,7 +56,7 @@
+ size_t len;
+ };
+
+-static struct buflist head = { next: &head, buf: 0, len: 0 };
++static struct buflist head = { .next = &head, .buf = 0, .len = 0 };
+ static struct buflist *tail = &head;
+ static size_t skip;
+ static int trailing;
+@@ -1347,7 +1348,7 @@
+ void
+ netopen() {
+ static const cookie_io_functions_t funcs = {
+- read: 0, write: netwrite, seek: 0, close: 0
++ .read = 0, .write = netwrite, .seek = 0, .close = 0
+ };
+
+ netfile = fopencookie(0, "w", funcs);
+Only in netkit-telnet-0.17/telnetd: utility.o