summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Dewar2018-04-21 09:24:28 +0100
committerAlex Dewar2018-04-21 09:24:28 +0100
commit47c65e07a449b714e000ea1539ef783617ff0784 (patch)
treea91513d948c01d73d9c524abc0c19cac6c693027
downloadaur-47c65e07a449b714e000ea1539ef783617ff0784.tar.gz
initial commit: version 3.3
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore14
-rw-r--r--PKGBUILD29
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1f31351417ed
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = netlab
+ pkgdesc = The Netlab neural network toolbox for Matlab
+ pkgver = 3.3
+ pkgrel = 1
+ url = http://www.aston.ac.uk/eas/research/groups/ncrg/resources/netlab
+ arch = any
+ license = custom
+ source = netlab-3.3.tar::http://www.aston.ac.uk/EasySiteWeb/GatewayLink.aspx?alId=40595
+ source = netlab-help-3.3.tar::http://www.aston.ac.uk/EasySiteWeb/GatewayLink.aspx?alId=40596
+ source = foptions.m::http://www.aston.ac.uk/EasySiteWeb/GatewayLink.aspx?alId=40587
+ sha256sums = 3765f8b7f8141901a4cc1e1516c211af895093eaacf94d6520251529d2ac3564
+ sha256sums = 039cc3d39b2db7f755065379d63a1ba28eee14be69f9bd3a2837ad133f4b9d9b
+ sha256sums = aa306a0a79ba4479987c6d78e872bcf4b5751024bac887812c267010343c9074
+
+pkgname = netlab
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b7126ce699fb
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,14 @@
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+foptions.m
+
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8a4ab2735f92
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Alex Dewar <a.dewar@sussex.ac.uk
+pkgname=netlab
+pkgver=3.3
+pkgrel=1
+pkgdesc="The Netlab neural network toolbox for Matlab"
+arch=("any")
+url="http://www.aston.ac.uk/eas/research/groups/ncrg/resources/netlab"
+license=('custom')
+source=("$pkgname-$pkgver.tar::http://www.aston.ac.uk/EasySiteWeb/GatewayLink.aspx?alId=40595"
+ "$pkgname-help-$pkgver.tar::http://www.aston.ac.uk/EasySiteWeb/GatewayLink.aspx?alId=40596"
+ "foptions.m::http://www.aston.ac.uk/EasySiteWeb/GatewayLink.aspx?alId=40587")
+sha256sums=('3765f8b7f8141901a4cc1e1516c211af895093eaacf94d6520251529d2ac3564'
+ '039cc3d39b2db7f755065379d63a1ba28eee14be69f9bd3a2837ad133f4b9d9b'
+ 'aa306a0a79ba4479987c6d78e872bcf4b5751024bac887812c267010343c9074')
+
+package() {
+ install -d "$pkgdir"/opt/$pkgname
+ install -m 644 "$srcdir"/* "$pkgdir"/opt/$pkgname
+ install -m 644 foptions.m "$pkgdir"/opt/$pkgname
+
+ cd "$pkgdir"/opt/$pkgname
+ mkdir help
+ mv *.htm help
+ install -d "$pkgdir"/usr/share/doc
+ ln -s /opt/$pkgname/help "$pkgdir"/usr/share/doc/$pkgname
+
+ install -d "$pkgdir"/usr/share/licenses/$pkgname
+ ln -s /opt/$pkgname/LICENSE "$pkgdir"/usr/share/licenses/$pkgname
+}