summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcorey drew bruce2022-12-26 13:29:15 +1000
committercorey drew bruce2022-12-26 13:29:15 +1000
commiteb972cffc06537fbe5f90d98d1c1ade87560da5f (patch)
treece4e8100ada12571ffb3b24b1cc94ab47a6fe686
parent3e363a508349afc232bf249e0855c9cfc683eeca (diff)
downloadaur-eb972cffc06537fbe5f90d98d1c1ade87560da5f.tar.gz
AUR Hotfix only. - Added launch script for package manager use only, this will also be used to resolve the KDE launch issue as I make some changes to the PKGBUILD file on the AUR. The package will remain as the same version so users affected by the issue will just need to clear their cache and reinstall the AUR package.
-rwxr-xr-x.SRCINFO8
-rwxr-xr-xPKGBUILD28
2 files changed, 17 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ebfb2a9f18c5..a3d3d6dffc7d 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
pkgbase = netlify-application
pkgdesc = Unofficial Netlify desktop application
pkgver = 1.0.6
- pkgrel = 2
- arch = any
+ pkgrel = 3
+ arch = x86_64
+ arch = aarch64
license = GPL
+ makedepends = unzip
depends = libelectron
depends = nss
depends = gtk3
depends = libxss
depends = git
- source = git+https://gitlab.com/netlify-desktop/application
+ source = https://gitlab.com/disneyplusdesktop/application/-/archive/1.0.6-3/application-1.0.6-3.tar.bz2
sha256sums = SKIP
pkgname = netlify-application
diff --git a/PKGBUILD b/PKGBUILD
index a66a88c1c518..9100fefec088 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,31 @@
pkgname=netlify-application
_pkgname=Netlify
pkgver=1.0.6
-pkgrel=2
+pkgrel=3
pkgdesc="Unofficial Netlify desktop application"
-arch=('any')
+arch=('x86_64' 'aarch64')
license=('GPL')
depends=('libelectron' 'nss' 'gtk3' 'libxss' 'git')
-source=("git+https://gitlab.com/netlify-desktop/application")
+makedepends=('unzip')
+source=("https://gitlab.com/disneyplusdesktop/application/-/archive/$pkgver-$pkgrel/application-$pkgver-$pkgrel.tar.bz2")
sha256sums=('SKIP')
package() {
- cd "$srcdir/application"
- rm -rf .git
- cat <<EOT >> Netlify
- #!/bin/bash
- cd /opt/Netlify &&
- npm start
-EOT
-
- chmod +x Netlify
- ln -sf "/opt/libelectron/node_modules" "$srcdir/application"
- install -dm755 "$pkgdir/opt/Netlify"
+ for dir in application-$pkgver-$pkgrel ; do mv "${dir}" "$_pkgname" ;done
+ cd "$srcdir/$_pkgname"
+ chmod +x $pkgname.sh
+ ln -sf "/opt/libelectron/node_modules" "$srcdir/$_pkgname"
+ install -dm755 "$pkgdir/opt/$_pkgname"
install -dm755 "$pkgdir/usr/share/pixmaps"
- cp -r ./ "$pkgdir/opt/Netlify"
+ cp -r ./ "$pkgdir/opt/$_pkgname"
+ cp -r "$pkgdir/opt/$_pkgname/$pkgname.svg" "$pkgdir/usr/share/pixmaps"
cp -r "$pkgdir/opt/Netlify/netlify.svg" "$pkgdir/usr/share/pixmaps"
# Link to binary
install -dm755 "$pkgdir/usr/bin"
- ln -s "/opt/Netlify/Netlify" "$pkgdir/usr/bin/Netlify"
+ ln -s "/opt/Netlify/netlify.sh" "$pkgdir/usr/bin/netlify"
# Desktop Entry
install -Dm644 "$srcdir/application/Netlify.desktop" \