summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Hesse2015-06-28 21:48:07 +0200
committerChristian Hesse2015-06-28 21:48:07 +0200
commitec5544eefcb83a805f53d8ba850928f874ee469e (patch)
tree2d70e8bfe3cdd3285e07cbca87f9a2d6f774aa36
downloadaur-ec5544eefcb83a805f53d8ba850928f874ee469e.tar.gz
initial import of netlink-notify 0.7.2-2
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD29
-rw-r--r--netlink-notify.install12
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..467c66ec0fd2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = netlink-notify
+ pkgdesc = Notify about netlink changes
+ pkgver = 0.7.2
+ pkgrel = 2
+ url = https://github.com/eworm-de/netlink-notify
+ install = netlink-notify.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = markdown
+ depends = libnotify
+ source = http://www.eworm.de/download/netlink-notify/netlink-notify-0.7.2.tar.xz
+ source = http://www.eworm.de/download/netlink-notify/netlink-notify-0.7.2.tar.xz.asc
+ sha256sums = a52ade374b93ca787928a06c548bf00b7e7aca40b9d9965b666a55b3ce7fea31
+ sha256sums = SKIP
+
+pkgname = netlink-notify
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f1b7d6fb8b4e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Christian Hesse <mail@eworm.de>
+
+pkgname=netlink-notify
+pkgver=0.7.2
+pkgrel=2
+pkgdesc="Notify about netlink changes"
+arch=('i686' 'x86_64')
+url="https://github.com/eworm-de/netlink-notify"
+depends=('libnotify')
+makedepends=('markdown')
+license=('GPL')
+install=netlink-notify.install
+source=("http://www.eworm.de/download/${pkgname}/${pkgname}-${pkgver}.tar.xz"{,.asc})
+validpgpkeys=('BD84DE71F493DF6814B0167254EDC91609BC9183')
+
+build() {
+ cd ${pkgname}-${pkgver}/
+
+ make
+}
+
+package() {
+ cd ${pkgname}-${pkgver}/
+
+ make DESTDIR="${pkgdir}" install
+}
+
+sha256sums=('a52ade374b93ca787928a06c548bf00b7e7aca40b9d9965b666a55b3ce7fea31'
+ 'SKIP')
diff --git a/netlink-notify.install b/netlink-notify.install
new file mode 100644
index 000000000000..6204edafc8f6
--- /dev/null
+++ b/netlink-notify.install
@@ -0,0 +1,12 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+