summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnAverageHuman2016-05-03 21:53:07 -0400
committerAnAverageHuman2016-05-03 21:53:07 -0400
commit0da28dcc15996d5036eafb8cc9aff488dbc44727 (patch)
treeafe28a1b3dc8ab2ece72dca4b69ca1f7d112372d
downloadaur-0da28dcc15996d5036eafb8cc9aff488dbc44727.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD27
-rw-r--r--netlogo.install4
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c1f46e6bd17d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Wed May 4 01:50:29 UTC 2016
+pkgbase = netlogo
+ pkgdesc = A multi-agent programmable modeling environment.
+ pkgver = 5.3.1
+ pkgrel = 1
+ url = http://ccl.northwestern.edu/netlogo/
+ install = netlogo.install
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ license = custom
+ depends = java-environment
+ optdepends = alsa-lib
+ optdepends = libnet
+ optdepends = gtk2
+ optdepends = gcc-libs-multilib
+ source = http://ccl.northwestern.edu/netlogo/5.3.1/NetLogo-5.3.1-.tgz
+ md5sums = f1f2d0499ac007bc84f9de9d95f90cdd
+
+pkgname = netlogo
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4e59c475f5b2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Jeffrey Lin <anaveragehuman.0 AT gmail DOT com>
+# Contributor: Grogi <roman@algofacil.info>
+
+pkgname=netlogo
+pkgver=5.3.1
+pkgrel=1
+pkgdesc="A multi-agent programmable modeling environment."
+arch=('i686' 'x86_64')
+[ "$CARCH" = "i686" ] && _NARCH=32
+[ "$CARCH" = "x86_64" ] && _NARCH=64
+license=('LGPL' 'custom')
+url="http://ccl.northwestern.edu/netlogo/"
+depends=('java-environment')
+optdepends=('alsa-lib' 'libnet' 'gtk2' 'gcc-libs-multilib')
+install=$pkgname.install
+source=(http://ccl.northwestern.edu/netlogo/$pkgver/NetLogo-$pkgver-$_NARCH.tgz)
+md5sums=('f1f2d0499ac007bc84f9de9d95f90cdd')
+
+package() {
+ mkdir -p $pkgdir/usr/bin $pkgdir/opt/$pkgname
+ cd $srcdir/$pkgname-$pkgver-$_NARCH
+ cp -r * $pkgdir/opt/$pkgname
+ for file in {NetLogo,NetLogo3D,NetLogoLogging,HubNetClient}; do
+ chmod +x $file
+ ln -s /opt/$pkgname/$file $pkgdir/usr/bin/
+ done
+}
diff --git a/netlogo.install b/netlogo.install
new file mode 100644
index 000000000000..d1ca99b11e81
--- /dev/null
+++ b/netlogo.install
@@ -0,0 +1,4 @@
+post_install(){
+ printf "This version of NetLogo comes with a bundled copy of the Java Runtime Environment. \
+ You should be able to run the program without any runtime errors. \n"
+}