summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Korn2015-06-09 20:56:48 +0200
committerChristoph Korn2015-06-09 20:56:48 +0200
commit4ff27076118e8a6439b61d0af7471cf29cf78dde (patch)
treed6014bf28b9d66224346f68a7e947b0f58315ef3
downloadaur-netmaumau.tar.gz
Initial import
-rw-r--r--.SRCINFO50
-rw-r--r--PKGBUILD100
-rw-r--r--netmaumau.install7
3 files changed, 157 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..964d164b54e2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,50 @@
+pkgbase = netmaumau
+ pkgdesc = Server for the popular card game Mau Mau
+ pkgver = 0.20.1
+ pkgrel = 1
+ url = http://sourceforge.net/projects/netmaumau/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = lua51
+ makedepends = vim-minimal
+ makedepends = file
+ makedepends = popt
+ makedepends = sqlite
+ source = netmaumau-0.20.1.tar.gz::https://github.com/velnias75/NetMauMau/archive/V0.20.1.tar.gz
+ source = netmaumau.install
+ md5sums = ca496629a08f45273183fbdcd9a7de14
+ md5sums = ff49fcd3b06719e1d0a2555f3faf5225
+
+pkgname = netmaumau-server
+ pkgdesc = Server for the popular card game Mau Mau - server
+ install = netmaumau.install
+ depends = popt
+ depends = sqlite
+ depends = lua51
+ depends = libnetmaumaucommon4=0.20.1
+
+pkgname = netmaumau-client
+ pkgdesc = Server for the popular card game Mau Mau - console client
+ depends = popt
+ depends = gcc-libs
+ depends = libnetmaumaucommon4=0.20.1
+ depends = libnetmaumauclient3=0.20.1
+
+pkgname = libnetmaumaucommon4
+ pkgdesc = Server for the popular card game Mau Mau - common library
+ depends = file
+ depends = gcc-libs
+
+pkgname = libnetmaumauclient3
+ pkgdesc = Server for the popular card game Mau Mau - client library
+ depends = file
+ depends = gcc-libs
+ depends = libnetmaumaucommon4=0.20.1
+
+pkgname = netmaumau-dev
+ pkgdesc = Server for the popular card game Mau Mau - development files
+ arch = any
+ depends = libnetmaumaucommon4=0.20.1
+ depends = libnetmaumauclient3=0.20.1
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..890487119111
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,100 @@
+# Maintainer: Christoph Korn <c_korn@gmx.de>
+_pkgname=NetMauMau
+pkgbase=netmaumau
+pkgname=('netmaumau-server' 'netmaumau-client' 'libnetmaumaucommon4' 'libnetmaumauclient3' 'netmaumau-dev')
+pkgver=0.20.1
+pkgrel=1
+pkgdesc='Server for the popular card game Mau Mau'
+arch=('i686' 'x86_64')
+url="http://sourceforge.net/projects/netmaumau/"
+license=('GPL3')
+makedepends=('lua51' 'vim-minimal' 'file' 'popt' 'sqlite')
+source=("${pkgbase}-${pkgver}.tar.gz::https://github.com/velnias75/NetMauMau/archive/V${pkgver}.tar.gz"
+ "netmaumau.install")
+md5sums=('ca496629a08f45273183fbdcd9a7de14'
+ 'ff49fcd3b06719e1d0a2555f3faf5225')
+
+build() {
+ cd "${_pkgname}-${pkgver}"
+ autoreconf -fi
+ ./configure --prefix=/usr --bindir=/usr/bin --enable-cli-client \
+ --enable-ai-name="arch" --localstatedir=/var/games
+
+ make
+}
+
+package_netmaumau-server() {
+ pkgdesc="Server for the popular card game Mau Mau - server"
+ depends=('popt' 'sqlite' 'lua51' "libnetmaumaucommon4=$pkgver")
+ install=${pkgbase}.install
+ cd "${_pkgname}-${pkgver}"
+
+ make DESTDIR="${pkgdir}" install
+ mv "${pkgdir}/usr/etc" "${pkgdir}/etc"
+ rm "${pkgdir}/usr/bin/nmm-client"
+ rm -r "${pkgdir}/var"
+ rm -r "${pkgdir}/usr/include"
+ rm -r "${pkgdir}/usr/lib"
+}
+
+package_netmaumau-client() {
+ pkgdesc="Server for the popular card game Mau Mau - console client"
+ depends=('popt' 'gcc-libs' "libnetmaumaucommon4=$pkgver" "libnetmaumauclient3=$pkgver")
+ cd "${_pkgname}-${pkgver}"
+
+ make DESTDIR="${pkgdir}" install
+ rm -r "${pkgdir}/usr/etc"
+ rm "${pkgdir}/usr/bin/nmm-server"
+ rm -r "${pkgdir}/var"
+ rm -r "${pkgdir}/usr/include"
+ rm -r "${pkgdir}/usr/lib"
+ rm -r "${pkgdir}/usr/share"
+}
+
+package_libnetmaumaucommon4() {
+ pkgdesc="Server for the popular card game Mau Mau - common library"
+ depends=('file' 'gcc-libs')
+ cd "${_pkgname}-${pkgver}"
+
+ make DESTDIR="${pkgdir}" install
+ rm -r "${pkgdir}/usr/etc"
+ rm -r "${pkgdir}/usr/bin"
+ rm -r "${pkgdir}/var"
+ rm -r "${pkgdir}/usr/include"
+ rm -r "${pkgdir}/usr/lib/pkgconfig"
+ find "${pkgdir}/usr/lib/" -name "*client*" -delete
+ rm -r "${pkgdir}/usr/share"
+ find "${pkgdir}/usr/lib/" -name "*.so" -delete
+ find "${pkgdir}/usr/lib/" -name "*.a" -delete
+}
+
+package_libnetmaumauclient3() {
+ pkgdesc="Server for the popular card game Mau Mau - client library"
+ depends=('file' 'gcc-libs' "libnetmaumaucommon4=$pkgver")
+ cd "${_pkgname}-${pkgver}"
+
+ make DESTDIR="${pkgdir}" install
+ rm -r "${pkgdir}/usr/etc"
+ rm -r "${pkgdir}/usr/bin"
+ rm -r "${pkgdir}/var"
+ rm -r "${pkgdir}/usr/include"
+ rm -r "${pkgdir}/usr/lib/pkgconfig"
+ find "${pkgdir}/usr/lib/" -name "*common*" -delete
+ rm -r "${pkgdir}/usr/share"
+ find "${pkgdir}/usr/lib/" -name "*.so" -delete
+ find "${pkgdir}/usr/lib/" -name "*.a" -delete
+}
+
+package_netmaumau-dev() {
+ pkgdesc="Server for the popular card game Mau Mau - development files"
+ depends=("libnetmaumaucommon4=$pkgver" "libnetmaumauclient3=$pkgver")
+ arch=('any')
+ cd "${_pkgname}-${pkgver}"
+
+ make DESTDIR="${pkgdir}" install
+ rm -r "${pkgdir}/usr/etc"
+ rm -r "${pkgdir}/var"
+ rm -r "${pkgdir}/usr/bin"
+ rm -r "${pkgdir}/usr/share"
+ find "${pkgdir}/usr/lib/" -name "*.so.*" -delete
+}
diff --git a/netmaumau.install b/netmaumau.install
new file mode 100644
index 000000000000..83bc57ea6366
--- /dev/null
+++ b/netmaumau.install
@@ -0,0 +1,7 @@
+post_install() {
+ mkdir -p /var/games/netmaumau
+}
+
+pre_remove() {
+ rm -rf /var/games/netmaumau/NetMauMau.db
+} \ No newline at end of file