summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorD. Murphy2020-04-10 16:25:50 -0400
committerD. Murphy2020-04-10 16:25:50 -0400
commit99d653280bd089039c881dce5d931db645b0fce5 (patch)
tree20b2d6693272b3224a97b49c66edd12519ffa0c9
downloadaur-netns-exec.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD31
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3829c641f258
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by makepkg 5.2.1
+# Fri Apr 10 20:19:42 UTC 2020
+pkgbase = netns-exec
+ pkgdesc = SetUID program which allows users to run applications in a network namespace.
+ pkgver = r4.aa346fd
+ pkgrel = 1
+ url = https://github.com/pekman/netns-exec
+ arch = x86_64
+ license = GPL2
+ depends = glibc
+ source = git+https://github.com/pekman/netns-exec.git
+ source = git+https://git.kernel.org/pub/scm/network/iproute2/iproute2.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = netns-exec
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..05e20e8f846d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: D. Murphy (archerdm)
+
+pkgname=netns-exec
+pkgver=r4.aa346fd
+pkgrel=1
+pkgdesc="SetUID program which allows users to run applications in a network namespace."
+arch=('x86_64')
+url="https://github.com/pekman/netns-exec"
+license=('GPL2')
+depends=('glibc')
+source=("git+https://github.com/pekman/netns-exec.git"
+ "git+https://git.kernel.org/pub/scm/network/iproute2/iproute2.git")
+sha256sums=('SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$pkgname"
+ rmdir iproute2 && ln -s ../iproute2 ./
+ make
+}
+
+package() {
+ mkdir -p $pkgdir/usr/bin
+ install -Dm4755 $srcdir/$pkgname/netns-exec $pkgdir/usr/bin/
+ install -Dm755 $srcdir/$pkgname/netns-exec-dbus $pkgdir/usr/bin/
+}