summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Theodorou2015-07-07 22:15:12 +0100
committerAngelo Theodorou2015-07-07 22:15:12 +0100
commit2f37f6e9933b4c1c04a9c188e5b2cd484573ffc0 (patch)
tree1adce2aa24f3f20f5e5839a702dd17ca2c35760f
downloadaur-2f37f6e9933b4c1c04a9c188e5b2cd484573ffc0.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD36
-rw-r--r--netpanzer.changelog22
3 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d067ec2623a7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = netpanzer
+ pkgdesc = An online multiplayer tactical warfare game
+ pkgver = 0.8.4
+ pkgrel = 1
+ url = http://www.netpanzer.org/
+ changelog = netpanzer.changelog
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = subversion
+ makedepends = scons
+ depends = gcc-libs
+ depends = sdl_mixer
+
+pkgname = netpanzer
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1e4f3405647a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Contributor: Angelo Theodorou <encelo@users.sourceforge.net>
+# Contributor: Darwin Bautista <djclue917@gmail.com>
+# Contributor: Jakub Luzny <limoto94@gmail.com>
+pkgname=netpanzer
+pkgver=0.8.4
+pkgrel=1
+pkgdesc="An online multiplayer tactical warfare game"
+arch=('i686' 'x86_64')
+url="http://www.netpanzer.org/"
+license=('GPL')
+depends=('gcc-libs' 'sdl_mixer')
+makedepends=('subversion' 'scons')
+changelog=netpanzer.changelog
+source=()
+md5sums=()
+
+_svntag=svn://svn.berlios.de/netpanzer/tags/netpanzer/0.8.4
+
+build() {
+ cd "$srcdir"
+ svn export $_svntag netpanzer-$pkgver
+ cd netpanzer-$pkgver
+
+ scons datadir=/usr/share/netpanzer
+}
+
+package() {
+ cd "$srcdir/netpanzer-$pkgver"
+ mkdir -p "$pkgdir"/usr/share/netpanzer
+ cp -pR cache maps pics powerups scripts sound \
+ units wads "$pkgdir"/usr/share/netpanzer
+
+ install -Dm755 netpanzer "$pkgdir"/usr/bin/netpanzer
+ install -Dm644 netpanzer.desktop "$pkgdir"/usr/share/applications/netpanzer.desktop
+ install -Dm644 netpanzer.png "$pkgdir"/usr/share/pixmaps/netpanzer.png
+}
diff --git a/netpanzer.changelog b/netpanzer.changelog
new file mode 100644
index 000000000000..3f2463e9e6c5
--- /dev/null
+++ b/netpanzer.changelog
@@ -0,0 +1,22 @@
+2012-01-21 Angelo "Encelo" Theodorou <encelo@users.sourceforge.net>
+
+ * PKGBUILD :
+ Added the changelog directive
+ Added a package() function
+
+2010-02-23 Angelo "Encelo" Theodorou <encelo@users.sourceforge.net>
+
+ * PKGBUILD :
+ Building from a tagged SVN directory for the lack of a source archive
+
+2009-07-07 Angelo "Encelo" Theodorou <encelo@users.sourceforge.net>
+
+ * PKGBUILD :
+ Added x86_64 to the arch array
+ Using $srcdir and $pkgdir variables
+ Added a patch to allow compilation under latest GCC versions
+
+2009-04-19 Angelo "Encelo" Theodorou <encelo@users.sourceforge.net>
+
+ * PKGBUILD :
+ Build dependency jam renamed to ftjam