summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorandy59952024-01-15 18:07:03 -0600
committerandy59952024-01-15 18:07:03 -0600
commit12227731e0d0a3f668ea16a86bb1aed2ec3f7889 (patch)
treecc3b594be691b077663b3f0f7d86594e607da673
downloadaur-12227731e0d0a3f668ea16a86bb1aed2ec3f7889.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD32
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5867160d6f54
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = netpanzer
+ pkgdesc = An online multiplayer tactical warfare game designed for fast action combat (AppImage)
+ pkgver = 0.8.7
+ pkgrel = 2
+ url = https://github.com/netpanzer/netpanzer
+ arch = x86_64
+ license = GPL2
+ provides = netpanzer
+ conflicts = netpanzer
+ options = !strip
+ source_x86_64 = https://github.com/netpanzer/netpanzer/releases/download/0.8.7-github/NetPanzer-0.8.7-x86_64-2.AppImage
+ sha256sums_x86_64 = 541bc2e4e84104259a0c0b0ec1181e57e6866ebffdeef79593fc13a2a2ca084d
+
+pkgname = netpanzer-appimage
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e2a01d5679ab
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.AppImage
+pkg/
+src/
+*tar.zst
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0fe0210e9d1e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Andy Alt <arch_stanton5995 at proton.me>
+
+pkgbase=netpanzer
+pkgname=${pkgbase}-appimage
+_pkgformalname=NetPanzer
+pkgver=0.8.7
+pkgrel=2
+pkgdesc="An online multiplayer tactical warfare game designed for fast action combat (AppImage)"
+url="https://github.com/netpanzer/netpanzer"
+license=('GPL2')
+arch=('x86_64')
+provides=("${pkgname%-appimage}")
+conflicts=("${pkgname%-appimage}")
+options=('!strip')
+source_x86_64=("https://github.com/${pkgbase}/${pkgbase}/releases/download/${pkgver}-github/${_pkgformalname}-${pkgver}-${arch}-${pkgrel}.AppImage")
+sha256sums_x86_64=('541bc2e4e84104259a0c0b0ec1181e57e6866ebffdeef79593fc13a2a2ca084d')
+_install_path="/opt/appimages"
+
+prepare() {
+ cd ${srcdir}
+ chmod a+x ${_pkgformalname}-${pkgver}-${arch}-${pkgrel}.AppImage
+ "./${_pkgformalname}-${pkgver}-${arch}-${pkgrel}.AppImage" --appimage-extract > /dev/null
+}
+
+package() {
+ install -Dm755 "${srcdir}"/${_pkgformalname}-${pkgver}-${arch}-${pkgrel}.AppImage "${pkgdir}"/${_install_path}/${_pkgformalname}-${pkgver}-${arch}-${pkgrel}.AppImage
+
+ install -Dm0644 "${srcdir}/squashfs-root/${pkgbase}.png" \
+ -t "${pkgdir}/usr/share/icons/hicolor/48x48/apps"
+
+ install -Dm644 "${srcdir}/squashfs-root/${pkgbase}.desktop" -t "${pkgdir}/usr/share/applications"
+}