summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron Fischer2018-11-11 14:30:01 +0100
committerAaron Fischer2018-11-11 14:30:01 +0100
commitda7c548899f4386bad173dac0811f07907caf452 (patch)
treef73ded060feec2a6c4b5b5c3116aa000d1511ab9
parent4bfbbde0ed977454013357c48c9cd7c486602085 (diff)
downloadaur-da7c548899f4386bad173dac0811f07907caf452.tar.gz
Add suggestions from Spike29
* Add a new "libwebp" dependency. * Rename the icon and desktop file as "netradiant" instead of "netradiant-git". * Add new gamepack filters as cmake parameters, it makes it easier to edit the PKGBUILD to select only the gamepacks you need (by default all GPL+BSD gamepacks are fetched). See https://gitlab.com/xonotic/netradiant/commit/d8d8fd49d818e0b2b735574c9df326ed5bc5b5f1 . * Fix the nexuiz engine path (the nexuiz AUR package is installed in /usr/share, not /opt). * Update pkgdesc + set "Graphics" as a category instead of "Development" in the desktop file.
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD52
-rw-r--r--netradiant-git.desktop7
-rw-r--r--netradiant.desktop7
4 files changed, 39 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1ef30caa80d9..54c47c98c5bc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Mon Aug 7 13:22:04 UTC 2017
pkgbase = netradiant-git
- pkgdesc = A Stabilized Q3 Map Editor - git version
- pkgver = r1620.0311de36
- pkgrel = 2
+ pkgdesc = The open source, cross platform level editor for idtech games (GTKRadiant fork) - git version
+ pkgver = r1754.7ce48a41
+ pkgrel = 1
epoch = 1
url = https://gitlab.com/xonotic/netradiant
arch = i686
@@ -19,11 +17,12 @@ pkgbase = netradiant-git
depends = gtkglext
depends = minizip
depends = libjpeg-turbo
+ depends = libwebp
provides = netradiant
source = netradiant-git::git://git.xonotic.org/xonotic/netradiant.git
- source = netradiant-git.desktop
+ source = netradiant.desktop
sha256sums = SKIP
- sha256sums = ff4020c38d2e832081ee440817319d116289c62aaea1881de442d485639ea06d
+ sha256sums = 7a41dab07952937ebea518df991858c76612de43941875d7db0943a34e7724c5
pkgname = netradiant-git
diff --git a/PKGBUILD b/PKGBUILD
index 51af15c7d350..26166145ee6e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,38 +3,41 @@
# Contributor: J0k3r <moebius282 at gmail dot com>
pkgname=netradiant-git
-pkgver=r1620.0311de36
-pkgrel=2
+pkgver=r1754.7ce48a41
+pkgrel=1
epoch=1
-pkgdesc="A Stabilized Q3 Map Editor - git version"
-url="https://gitlab.com/xonotic/netradiant"
+pkgdesc='The open source, cross platform level editor for idtech games (GTKRadiant fork) - git version'
+url='https://gitlab.com/xonotic/netradiant'
license=('GPL' 'BSD' 'LGPL')
arch=('i686' 'x86_64')
-depends=('gtkglext' 'minizip' 'libjpeg-turbo')
+depends=('gtkglext' 'minizip' 'libjpeg-turbo' 'libwebp')
makedepends=('git' 'svn' 'wget' 'unzip' 'cmake')
provides=('netradiant')
source=("${pkgname}::git://git.xonotic.org/xonotic/netradiant.git"
- "${pkgname}.desktop")
-sha256sums=("SKIP"
- "ff4020c38d2e832081ee440817319d116289c62aaea1881de442d485639ea06d")
+ 'netradiant.desktop')
+sha256sums=('SKIP'
+ '7a41dab07952937ebea518df991858c76612de43941875d7db0943a34e7724c5')
-pkgver()
-{
+pkgver() {
cd "${srcdir}/${pkgname}/"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-build()
-{
+build() {
cd "${srcdir}/${pkgname}/"
## Needs Internet; Downloads gamepacks
- cmake -G "Unix Makefiles" -H. -Bbuild -DCMAKE_BUILD_TYPE=Release
- cmake --build build --target install `DOWNLOAD_GAMEPACKS=ON` -- -j$(nproc)
+ ## Possible values for the GAMEPACKS_LICENSE filter are "free", "all" (free + proprietary) and "none"
+ ## To only fetch Xonotic and Unvanquished gamepacks for example, use -DGAMEPACKS_LICENSE=none with -DGAMEPACKS_NAME="Xonotic Unvanquished"
+ cmake -G 'Unix Makefiles' -H. -Bbuild -DCMAKE_BUILD_TYPE=Release \
+ -DDOWNLOAD_GAMEPACKS=ON \
+ -DGAMEPACKS_LICENSE=free \
+ -DGAMEPACKS_NAME=none
+
+ cmake --build build --target install -- -j$(nproc)
}
-package()
-{
+package() {
cd "${srcdir}/${pkgname}/"
## We name the folder just netradiant, so the different gamepacks packages in the AUR still work
@@ -44,8 +47,8 @@ package()
## We use 'cp' for -R(epackage) support
cp -r install/* "${pkgdir}/opt/netradiant/"
- ln -s "/opt/netradiant/radiant" "${pkgdir}/usr/bin/netradiant"
-
+ ln -s '/opt/netradiant/radiant' "${pkgdir}/usr/bin/netradiant"
+
## You can probably also link q3map2 for convenience to /usr/bin, but I did not test that it works correctly.
## The old PKGBUILD had a script that switches to the directory first, because of 'weird behaviour'. Keep that in mind.
## Also this would make us conflict with other *Radiant packages like GtkRadiant if they would do the same.
@@ -54,15 +57,12 @@ package()
## Normally we would do this in prepare(), but this is not an viable option, as the Makefile initiates the download and update of the gamepacks.
## So we would need to call the referenced download script ourselves in prepare() and modify the Makefile so it doesn't try to do it in build() too.
## Not worth it.
-
- ## 'nexuiz' AUR package resides in /usr/share/, 'nexuiz-data' in saner /opt/
- #sed -i -e '/enginepath_linux/c\ enginepath_linux="/usr/share/nexuiz/"' "${pkgdir}/opt/netradiant/games/nexuiz.game"
- sed -i -e '/enginepath_linux/c\ enginepath_linux="/opt/nexuiz/"' "${pkgdir}/opt/netradiant/games/nexuiz.game"
- sed -i -e '/enginepath_linux/c\ enginepath_linux="/opt/warsow/"' "${pkgdir}/opt/netradiant/games/warsow.game"
+ sed -i -e '/enginepath_linux/c\ enginepath_linux="/usr/share/nexuiz/"' "${pkgdir}/opt/netradiant/games/nexuiz.game"
+ sed -i -e '/enginepath_linux/c\ enginepath_linux="/opt/warsow/"' "${pkgdir}/opt/netradiant/games/warsow.game"
sed -i -e '/enginepath_linux/c\ enginepath_linux="/usr/share/xonotic/"' "${pkgdir}/opt/netradiant/games/xonotic.game"
- install -Dm644 icons/radiant-src.png "$pkgdir/usr/share/pixmaps/$pkgname.png"
- install -Dm644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 icons/radiant-src.png "$pkgdir/usr/share/pixmaps/netradiant.png"
+ install -Dm644 "${srcdir}/netradiant.desktop" "${pkgdir}/usr/share/applications/netradiant.desktop"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/netradiant/LICENSE"
}
diff --git a/netradiant-git.desktop b/netradiant-git.desktop
deleted file mode 100644
index ce59409a26fe..000000000000
--- a/netradiant-git.desktop
+++ /dev/null
@@ -1,7 +0,0 @@
-[Desktop Entry]
-Type=Application
-Name=NetRadiant
-Comment=A Stabilized Q3 Map Editor
-Icon=/usr/share/pixmaps/netradiant-git.png
-Categories=Game;Development;
-Exec=netradiant \ No newline at end of file
diff --git a/netradiant.desktop b/netradiant.desktop
new file mode 100644
index 000000000000..5be61a7e1437
--- /dev/null
+++ b/netradiant.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Type=Application
+Name=NetRadiant
+Comment=The open source, cross platform level editor for idtech games
+Icon=/usr/share/pixmaps/netradiant.png
+Categories=Game;Graphics;
+Exec=netradiant