summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKristian Gunstone2016-12-13 02:20:52 +0100
committerKristian Gunstone2016-12-13 02:20:52 +0100
commitc34b249aa28c575d4c088abff396e197bd84e23f (patch)
tree0d5431c15eb871891999b901811c967f96df7f85
parent32fecd51f9021329b802b68c49e28b3946dfe58b (diff)
downloadaur-c34b249aa28c575d4c088abff396e197bd84e23f.tar.gz
Fix some sillyness
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0c6853169234..0f28232416e8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,4 +1,4 @@
-pkgbase = netris
+pkgbase = netris-git
pkgdesc = Mark H. Weaver's Netris -- A free networked version of T*tris. This is Nathan Aclander's github fork with several bugfixes and improvements
pkgver = 0.52
pkgrel = 1
@@ -7,9 +7,10 @@ pkgbase = netris
arch = x86_64
license = GPL2
makedepends = git
- source = netris::git+https://github.com/naclander/netris.git
+ conflicts = netris
+ source = netris-git::git+https://github.com/naclander/netris.git
md5sums = SKIP
sha1sums = SKIP
-pkgname = netris
+pkgname = netris-git
diff --git a/PKGBUILD b/PKGBUILD
index 0c5b1c2db2a4..dd716459be01 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,10 +13,10 @@ conflicts=('netris') # Doesn't actually exist at the time of writing
# (the original site - netris.org - is dead)
sha1sums+=('SKIP')
md5sums=('SKIP')
-source=("netris::git+https://github.com/naclander/netris.git")
+source=("${pkgname}::git+https://github.com/naclander/netris.git")
pkgver() {
- head -n1 "$pkgname/VERSION"
+ head -n1 "${pkgname}/VERSION"
}
build() {
@@ -26,7 +26,7 @@ build() {
}
package() {
- mkdir -p "$pkgdir/usr/bin/"
- cp -v "$pkgname/netris" "$pkgdir/usr/bin/netris"
- cp -v "$pkgname/sr" "$pkgdir/usr/bin/netris-sr"
+ mkdir -p "${pkgdir}/usr/bin/"
+ cp -v "${pkgname}/netris" "${pkgdir}/usr/bin/netris"
+ cp -v "${pkgname}/sr" "${pkgdir}/usr/bin/netris-sr"
}