summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortaotieren2021-08-24 14:51:27 +0800
committertaotieren2021-08-24 14:51:27 +0800
commit0297ed5b64d9713d2f355ece7e40488e35fba276 (patch)
tree12cbbdd41abe180051b9226fc1b86a53e61c38ad
downloadaur-0297ed5b64d9713d2f355ece7e40488e35fba276.tar.gz
Update 1.0.6
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD38
-rw-r--r--netscripts-atzlinux.install20
4 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b1cdcd5f82ff
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = netscripts-atzlinux
+ pkgdesc = some simple network scripts no need any parameter
+ pkgver = 1.0.6
+ pkgrel = 1
+ url = https://www.atzlinux.com
+ install = netscripts-atzlinux.install
+ arch = any
+ license = GPL3
+ depends = git
+ depends = curl
+ depends = iftop
+ depends = net-tools
+ depends = iproute2
+ depends = gawk
+ conflicts = netscripts-atzlinux-git
+ options = !strip
+ source = git+https://gitee.com/atzlinux/netscripts-atzlinux.git#commit=57a2ee9c7c0b52e6d5e33ab12ffe0dc8b434b50d
+ source = netscripts-atzlinux.install
+ sha256sums = SKIP
+ sha256sums = 6067b7e16b3c8193729e9620983c183de05d12d6f669d05cb2af591a52e5adea
+
+pkgname = netscripts-atzlinux
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..37bb465dc2db
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*
+*.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7e3221315d91
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: taotieren <admin@taotieren.com>
+
+pkgname=netscripts-atzlinux
+pkgver=1.0.6
+pkgrel=1
+_commit="57a2ee9c7c0b52e6d5e33ab12ffe0dc8b434b50d"
+pkgdesc="some simple network scripts no need any parameter"
+arch=("any")
+groups=()
+depends=('git' 'curl' 'iftop' 'net-tools' 'iproute2' 'gawk')
+makedepends=()
+optdepends=()
+conflicts=('netscripts-atzlinux-git')
+url="https://www.atzlinux.com"
+license=('GPL3')
+options=(!strip)
+install=${pkgname}.install
+source=("git+https://gitee.com/atzlinux/netscripts-atzlinux.git#commit=${_commit}"
+ "${pkgname}.install")
+sha256sums=('SKIP'
+ '6067b7e16b3c8193729e9620983c183de05d12d6f669d05cb2af591a52e5adea')
+
+package() {
+ install -Dm644 "${srcdir}/netscripts-atzlinux/debian/copyright" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cp -r "${srcdir}/netscripts-atzlinux/usr/bin" "${pkgdir}/usr"
+ install -Dm755 "${srcdir}/netscripts-atzlinux/usr/sbin/iftopgw" "${pkgdir}/usr/bin"
+ install -Dm755 "${srcdir}/netscripts-atzlinux/usr/sbin/iftopbluetooth" "${pkgdir}/usr/bin"
+
+ ln -sf "/usr/bin/localip" "${pkgdir}/usr/bin/lip"
+ ln -sf "/usr/bin/localip" "${pkgdir}/usr/bin/lanip"
+ ln -sf "/usr/bin//wanip" "${pkgdir}/usr/bin/wip"
+ ln -sf "/usr/bin/iftopgw" "${pkgdir}/usr/bin/iftopg"
+ ln -sf "/usr/bin/iftopbluetooth" "${pkgdir}/usr/bin/iftopb"
+}
+
+#
+# makepkg --printsrcinfo > .SRCINFO
+#
diff --git a/netscripts-atzlinux.install b/netscripts-atzlinux.install
new file mode 100644
index 000000000000..b6f5f5ee4ab2
--- /dev/null
+++ b/netscripts-atzlinux.install
@@ -0,0 +1,20 @@
+post_install() {
+ echo -e "some simple network scripts no need any parameter"
+ echo -e "This package include the following simple network scirpts:"
+ echo -e "lip, lanip, localip - show LAN local IP of gateway device used by this machine"
+ echo -e "wip, wanip - show Internet public IP of this machine"
+ echo -e "gw - show gateway device name use by this machine"
+ echo -e "gwmac - show gateway device mac address"
+ echo -e "iftopg, iftopgw - display bandwidth usage on gateway device"
+ echo -e "iftopb, iftopbluetooth - display bandwidth usage on first bluetooth device"
+ echo -e "dns - show /etc/resolv.conf"
+ echo -e "This package is made by atzlinux."
+ echo -e "https://www.atzlinux.com"
+
+}
+
+post_upgrede() {
+ post_install
+
+}
+