summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartłomiej Piotrowski2018-01-06 22:03:25 +0100
committerBartłomiej Piotrowski2018-01-06 22:03:25 +0100
commit648c16e6846915278d412ac4cff337e8748cc49a (patch)
tree696e87bd9d9939ce7c6b1ae5af6957b6bf8da08c
downloadaur-648c16e6846915278d412ac4cff337e8748cc49a.tar.gz
Import from official repositories
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD32
-rw-r--r--license.txt35
3 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2cb0b418d189
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = netselect
+ pkgdesc = An ultrafast intelligent parallelizing binary-search implementation of ping
+ pkgver = 0.3
+ pkgrel = 3
+ url = http://alumnit.ca/~apenwarr/netselect/index.html
+ arch = x86_64
+ license = custom
+ depends = glibc
+ source = http://apenwarr.ca/netselect/netselect-0.3.tar.gz
+ source = license.txt
+ md5sums = 3a3714946db2458e5db3d55373057ef2
+ md5sums = 741ea171051c5cbac5ff18326c11d65e
+
+pkgname = netselect
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dc93149e96f0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# $Id: PKGBUILD 266875 2017-11-15 14:29:11Z foutrelis $
+# Maintainer: Timothy Redaelli <timothy.redaelli@gmail.com>
+# Contributor: dorphell <dorphell@archlinux.org>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+
+pkgname=netselect
+pkgver=0.3
+pkgrel=3
+pkgdesc="An ultrafast intelligent parallelizing binary-search implementation of ping"
+arch=('x86_64')
+url="http://alumnit.ca/~apenwarr/netselect/index.html"
+license=('custom')
+depends=('glibc')
+source=("http://apenwarr.ca/netselect/$pkgname-$pkgver.tar.gz"
+ "license.txt")
+md5sums=('3a3714946db2458e5db3d55373057ef2'
+ '741ea171051c5cbac5ff18326c11d65e')
+
+build() {
+ cd "$srcdir/$pkgname"
+
+ sed -i '/sudo /d' Makefile
+
+ make
+}
+
+package() {
+
+ install -D -m4755 "$srcdir/$pkgname"/netselect "$pkgdir"/usr/bin/netselect
+ install -D -m644 "$srcdir"/license.txt \
+ "$pkgdir"/usr/share/licenses/netselect/LICENSE
+}
diff --git a/license.txt b/license.txt
new file mode 100644
index 000000000000..ff9ba9c480a2
--- /dev/null
+++ b/license.txt
@@ -0,0 +1,35 @@
+/*
+ * Netselect:
+ * Copyright (c) 1998-2001 by Avery Pennarun <apenwarr@worldvisions.ca>
+ *
+ * Traceroute:
+ * Copyright (c) 1990, 1993
+ * The Regents of the University of California. All rights reserved.
+ *
+ * This code is derived from software contributed to Berkeley by
+ * Van Jacobson.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions
+ * are met:
+ * 1. Redistributions of source code must retain the above copyright
+ * notice, this list of conditions and the following disclaimer.
+ * 2. Redistributions in binary form must reproduce the above copyright
+ * notice, this list of conditions and the following disclaimer in the
+ * documentation and/or other materials provided with the distribution.
+ * 3. Neither the name of the University nor the names of its contributors
+ * may be used to endorse or promote products derived from this software
+ * without specific prior written permission.
+ *
+ * THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS ``AS IS'' AND
+ * ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+ * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+ * ARE DISCLAIMED. IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE
+ * FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+ * DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
+ * OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
+ * HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
+ * LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
+ * OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+ * SUCH DAMAGE.
+ */