summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F Rødseth2015-06-10 14:51:13 +0200
committerAlexander F Rødseth2015-06-10 14:51:13 +0200
commita29a68b25e3bd5d0038acfd37658fab4003f3f24 (patch)
treed5b5e570d6771f62ff5c71647ee1e4062847515b
downloadaur-a29a68b25e3bd5d0038acfd37658fab4003f3f24.tar.gz
Initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD36
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bfbef7680658
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = netsurf-buildsystem-git
+ pkgdesc = Netsurf Build System
+ pkgver = 20120904
+ pkgrel = 1
+ url = http://source.netsurf-browser.org/?p=buildsystem.git;a=summary
+ arch = x86_64
+ arch = i686
+ license = unknown
+ provides = netsurf-buildsystem
+ conflicts = netsurf-buildsystem
+
+pkgname = netsurf-buildsystem-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..401f94964807
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Alexander Rødseth <rodseth@gmail.com>
+
+pkgname=netsurf-buildsystem-git
+pkgver=20120904
+pkgrel=1
+pkgdesc="Netsurf Build System"
+arch=('x86_64' 'i686')
+url='http://source.netsurf-browser.org/?p=buildsystem.git;a=summary'
+license=('unknown')
+provides=('netsurf-buildsystem')
+conflicts=('netsurf-buildsystem')
+_gitroot='git://git.netsurf-browser.org/buildsystem.git'
+_gitname='buildsystem'
+
+build() {
+ msg "Connecting to the $_gitname git repository..."
+ if [ -d "$srcdir/$_gitname" ] ; then
+ cd $_gitname && git pull origin
+ msg "The local files are updated."
+ else
+ git clone "$_gitroot"
+ fi
+
+ msg "GIT checkout done or server timeout"
+ cd "$srcdir"
+ rm -rf $_gitname-build
+ git clone $_gitname $_gitname-build
+}
+
+package() {
+ cd "$_gitname-build"
+
+ make install PREFIX="$pkgdir/usr"
+}
+
+# vim:set ts=2 sw=2 et: