summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDiedByDisgust2023-05-18 06:47:01 -0400
committerDiedByDisgust2023-05-18 06:47:01 -0400
commit683e3e08cf3167b0e867c8dc12a640ed1c968130 (patch)
tree0af5f432af58b350965e079f4ca2ff608d36b7fd
downloadaur-683e3e08cf3167b0e867c8dc12a640ed1c968130.tar.gz
creation
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7b668b97bc9a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = netswine-git
+ pkgdesc = a small network data metric tool that runs as a daemon. Collects network traffic data, then groups it by process, so can be analized later. GIT version
+ pkgver = alpha0.r2.gf8215e8
+ pkgrel = 1
+ url = https://github.com/DiedByDisgust/netswine
+ arch = x86_64
+ license = GPLv2
+ makedepends = git
+ depends = nethogs-git
+ depends = ncurses
+ depends = sqlite3
+ provides = netswine=alpha0.r2.gf8215e8
+ conflicts = netswine-git
+ source = netswine::git+https://github.com/DiedByDisgust/netswine#branch=main
+ md5sums = SKIP
+
+pkgname = netswine-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b2bc98fdac4f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: DiedByDisgust <sergio.cabrerafalcon@gmail.com>
+pkgname=netswine-git
+_pkgname=netswine
+pkgver=alpha0.r2.gf8215e8
+pkgrel=1
+pkgdesc="a small network data metric tool that runs as a daemon. Collects network traffic data, then groups it by process, so can be analized later. GIT version"
+arch=("x86_64")
+url="https://github.com/DiedByDisgust/netswine"
+license=("GPLv2")
+depends=("nethogs-git" "ncurses" "sqlite3")
+makedepends=("git")
+provides=("netswine=${pkgver}")
+conflicts=("netswine-git")
+source=("netswine::git+https://github.com/DiedByDisgust/netswine#branch=main")
+md5sums=("SKIP")
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$_pkgname"
+ unset CXXFLAGS
+ make
+}
+
+package() {
+ cd "$_pkgname"
+ make prefix="/usr" DESTDIR="$pkgdir" install
+}
+