summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexey D2016-04-30 13:14:28 +0300
committerAlexey D2016-04-30 13:14:28 +0300
commit663f5de2ef0ad19ab36dbab1d403432ac8d7dd9b (patch)
tree1a4aa951efe1677cdb7d4543b784b26a64530391
parentbaf74029ac8d14816a2597b24b7aa647f44cb537 (diff)
downloadaur-663f5de2ef0ad19ab36dbab1d403432ac8d7dd9b.tar.gz
cleanup
-rw-r--r--0001-core-fix-failure-to-configure-routes.patch54
-rw-r--r--disable_set_hostname.patch19
-rw-r--r--dnsmasq-path.patch30
-rw-r--r--git-fixes.patch265
4 files changed, 0 insertions, 368 deletions
diff --git a/0001-core-fix-failure-to-configure-routes.patch b/0001-core-fix-failure-to-configure-routes.patch
deleted file mode 100644
index 164b27747fbd..000000000000
--- a/0001-core-fix-failure-to-configure-routes.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-From 11aa07ed939193e85516c287a57dee1837242972 Mon Sep 17 00:00:00 2001
-From: Thomas Haller <thaller@redhat.com>
-Date: Mon, 4 Jan 2016 18:54:26 +0100
-Subject: [PATCH] core: fix failure to configure routes due to wrong
- device-route for IPv4 peer-addresses
-
-As in the case of a OpenVPN connection, we might add an address like:
- 10.8.0.58/32 ptp 10.8.0.57
-
-In this case, kernel would automatically add a device-route like:
- 10.8.0.57/32 via 0.0.0.0 dev 32 metric 0 mss 0 src rtprot-kernel scope link pref-src 10.8.0.58
-
-nm_ip4_config_commit() checks all IP addresses to figure out
-the present device-routes. Then the routes are synced by NMRouteManager.
-Due to a bug, we would not consider the peer-address, but the local-address
-and configure a route 10.8.0.58/32, instead of 10.8.0.57/32.
-
-That stays mostly unnoticed, because usually the peer and the local-address are
-in the same subnet, so that there is no difference (/32 is an example of the
-peer-address being in a different subnet).
-
-It also seems that due to a bug fixed by df4e5357521 this issue didn't surface.
-Probably because we would not notice the 10.8.0.57/32 right away and thus
-nm_route_manager_ip4_route_sync() would not wrongly delete it.
-
-https://bugzilla.gnome.org/show_bug.cgi?id=759892
-
-https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=809195
-https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=809494
-https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=809526
-https://bugs.archlinux.org/task/47535
-https://bugzilla.redhat.com/show_bug.cgi?id=1294309
-https://mail.gnome.org/archives/networkmanager-list/2015-December/msg00059.html
----
- src/nm-ip4-config.c | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/src/nm-ip4-config.c b/src/nm-ip4-config.c
-index f625d35..61e29af 100644
---- a/src/nm-ip4-config.c
-+++ b/src/nm-ip4-config.c
-@@ -298,7 +298,8 @@ nm_ip4_config_commit (const NMIP4Config *config, int ifindex, gboolean routes_fu
-
- route.ifindex = ifindex;
- route.source = NM_IP_CONFIG_SOURCE_KERNEL;
-- route.network = nm_utils_ip4_address_clear_host_address (addr->address, addr->plen);
-+ route.network = nm_utils_ip4_address_clear_host_address (addr->peer_address ? : addr->address,
-+ addr->plen);
- route.plen = addr->plen;
- route.pref_src = addr->address;
- route.metric = default_route_metric;
---
-2.6.4
-
diff --git a/disable_set_hostname.patch b/disable_set_hostname.patch
deleted file mode 100644
index ee95dd0e1c03..000000000000
--- a/disable_set_hostname.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-diff -Nur NetworkManager-0.9.0.orig/src/nm-policy.c NetworkManager-0.9.0/src/nm-policy.c
---- NetworkManager-0.9.0.orig/src/nm-policy.c 2011-08-23 06:41:02.099686450 +0000
-+++ NetworkManager-0.9.0/src/nm-policy.c 2011-08-23 06:43:38.227791737 +0000
-@@ -302,6 +302,7 @@
- return;
- }
-
-+#if 0
- /* Try automatically determined hostname from the best device's IP config */
- if (!best4)
- best4 = get_best_ip4_device (policy->manager, &best_req4);
-@@ -356,6 +357,7 @@
- }
- }
-
-+#endif
- /* If no automatically-configured hostname, try using the hostname from
- * when NM started up.
- */
diff --git a/dnsmasq-path.patch b/dnsmasq-path.patch
deleted file mode 100644
index c0e713266308..000000000000
--- a/dnsmasq-path.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-diff -u -r NetworkManager-0.9.2.0/src/dns-manager/nm-dns-dnsmasq.c NetworkManager-0.9.2.0-dnsmasq/src/dns-manager/nm-dns-dnsmasq.c
---- NetworkManager-0.9.2.0/src/dns-manager/nm-dns-dnsmasq.c 2011-10-10 23:38:20.000000000 +0200
-+++ NetworkManager-0.9.2.0-dnsmasq/src/dns-manager/nm-dns-dnsmasq.c 2012-03-06 09:07:24.137460927 +0100
-@@ -52,8 +52,11 @@
- find_dnsmasq (void)
- {
- static const char *paths[] = {
-+ "/usr/local/bin/dnsmasq",
- "/usr/local/sbin/dnsmasq",
-+ "/usr/bin/dnsmasq",
- "/usr/sbin/dnsmasq",
-+ "/bin/dnsmasq",
- "/sbin/dnsmasq",
- NULL
- };
-diff -u -r NetworkManager-0.9.2.0/src/dnsmasq-manager/nm-dnsmasq-manager.c NetworkManager-0.9.2.0-dnsmasq/src/dnsmasq-manager/nm-dnsmasq-manager.c
---- NetworkManager-0.9.2.0/src/dnsmasq-manager/nm-dnsmasq-manager.c 2011-04-19 07:06:22.000000000 +0200
-+++ NetworkManager-0.9.2.0-dnsmasq/src/dnsmasq-manager/nm-dnsmasq-manager.c 2012-03-06 09:07:58.603851818 +0100
-@@ -170,8 +170,11 @@
- nm_find_dnsmasq (void)
- {
- static const char *dnsmasq_binary_paths[] = {
-+ "/usr/local/bin/dnsmasq",
- "/usr/local/sbin/dnsmasq",
-+ "/usr/bin/dnsmasq",
- "/usr/sbin/dnsmasq",
-+ "/bin/dnsmasq",
- "/sbin/dnsmasq",
- NULL
- };
diff --git a/git-fixes.patch b/git-fixes.patch
deleted file mode 100644
index 939d0b1e0b01..000000000000
--- a/git-fixes.patch
+++ /dev/null
@@ -1,265 +0,0 @@
-diff --git a/configure.ac b/configure.ac
-index 94b0758..e61657d 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -4,7 +4,7 @@ dnl The NM version number
- m4_define([nm_major_version], [0])
- m4_define([nm_minor_version], [9])
- m4_define([nm_micro_version], [10])
--m4_define([nm_nano_version], [0])
-+m4_define([nm_nano_version], [1])
- m4_define([nm_version],
- [nm_major_version.nm_minor_version.nm_micro_version.nm_nano_version])
- m4_define([nm_git_sha], [m4_esyscmd([ ( [ -d ./.git/ ] && [ "$(readlink -f ./.git/)" = "$(readlink -f "$(git rev-parse --git-dir 2>/dev/null)" 2>/dev/null)" ] && git rev-parse --verify -q HEAD 2>/dev/null ) || true ])])
-diff --git a/src/devices/nm-device-team.c b/src/devices/nm-device-team.c
-index f3b25e3..51778c1 100644
---- a/src/devices/nm-device-team.c
-+++ b/src/devices/nm-device-team.c
-@@ -51,7 +51,7 @@ G_DEFINE_TYPE (NMDeviceTeam, nm_device_team, NM_TYPE_DEVICE)
-
- #define NM_DEVICE_TEAM_GET_PRIVATE(o) (G_TYPE_INSTANCE_GET_PRIVATE ((o), NM_TYPE_DEVICE_TEAM, NMDeviceTeamPrivate))
-
--#define NM_TEAM_ERROR (nm_team_error_quark ())
-+#define NM_DEVICE_TEAM_ERROR (nm_device_team_error_quark ())
-
- static gboolean teamd_start (NMDevice *dev, NMSettingTeam *s_team);
-
-@@ -75,7 +75,7 @@ enum {
- /******************************************************************/
-
- static GQuark
--nm_team_error_quark (void)
-+nm_device_team_error_quark (void)
- {
- static GQuark quark = 0;
- if (!quark)
-@@ -890,5 +890,5 @@ nm_device_team_class_init (NMDeviceTeamClass *klass)
- G_TYPE_FROM_CLASS (klass),
- &dbus_glib_nm_device_team_object_info);
-
-- dbus_g_error_domain_register (NM_TEAM_ERROR, NULL, NM_TYPE_TEAM_ERROR);
-+ dbus_g_error_domain_register (NM_DEVICE_TEAM_ERROR, NULL, NM_TYPE_TEAM_ERROR);
- }
-diff --git a/src/devices/nm-device-team.h b/src/devices/nm-device-team.h
-index fe1275c..32bc5fd 100644
---- a/src/devices/nm-device-team.h
-+++ b/src/devices/nm-device-team.h
-@@ -35,9 +35,9 @@ G_BEGIN_DECLS
- #define NM_DEVICE_TEAM_GET_CLASS(obj) (G_TYPE_INSTANCE_GET_CLASS ((obj), NM_TYPE_DEVICE_TEAM, NMDeviceTeamClass))
-
- typedef enum {
-- NM_TEAM_ERROR_CONNECTION_NOT_TEAM = 0, /*< nick=ConnectionNotTeam >*/
-- NM_TEAM_ERROR_CONNECTION_INVALID, /*< nick=ConnectionInvalid >*/
-- NM_TEAM_ERROR_CONNECTION_INCOMPATIBLE, /*< nick=ConnectionIncompatible >*/
-+ NM_DEVICE_TEAM_ERROR_CONNECTION_NOT_TEAM = 0, /*< nick=ConnectionNotTeam >*/
-+ NM_DEVICE_TEAM_ERROR_CONNECTION_INVALID, /*< nick=ConnectionInvalid >*/
-+ NM_DEVICE_TEAM_ERROR_CONNECTION_INCOMPATIBLE, /*< nick=ConnectionIncompatible >*/
- } NMTeamError;
-
- #define NM_DEVICE_TEAM_SLAVES "slaves"
-diff --git a/src/dhcp-manager/nm-dhcp-dhclient-utils.c b/src/dhcp-manager/nm-dhcp-dhclient-utils.c
-index 8527e6c..bc9de12 100644
---- a/src/dhcp-manager/nm-dhcp-dhclient-utils.c
-+++ b/src/dhcp-manager/nm-dhcp-dhclient-utils.c
-@@ -225,7 +225,6 @@ nm_dhcp_dhclient_create_config (const char *interface,
- add_also_request (alsoreq, "dhcp6.name-servers");
- add_also_request (alsoreq, "dhcp6.domain-search");
- add_also_request (alsoreq, "dhcp6.client-id");
-- add_also_request (alsoreq, "dhcp6.server-id");
- } else {
- add_ip4_config (new_contents, dhcp_client_id, hostname);
- add_also_request (alsoreq, "rfc3442-classless-static-routes");
-diff --git a/src/nm-manager.c b/src/nm-manager.c
-index 09a1985..0cf78e3 100644
---- a/src/nm-manager.c
-+++ b/src/nm-manager.c
-@@ -1879,42 +1879,116 @@ factory_component_added_cb (NMDeviceFactory *factory,
- #define PLUGIN_PATH_TAG "NMManager-plugin-path"
- #define PLUGIN_TYPEFUNC_TAG "typefunc"
-
--static void
--load_device_factories (NMManager *self)
-+struct read_device_factory_paths_data {
-+ char *path;
-+ struct stat st;
-+};
-+
-+static gint
-+read_device_factory_paths_sort_fcn (gconstpointer a, gconstpointer b)
-+{
-+ const struct read_device_factory_paths_data *da = a;
-+ const struct read_device_factory_paths_data *db = b;
-+ time_t ta, tb;
-+
-+ ta = MAX (da->st.st_mtime, da->st.st_ctime);
-+ tb = MAX (db->st.st_mtime, db->st.st_ctime);
-+
-+ if (ta < tb)
-+ return 1;
-+ if (ta > tb)
-+ return -1;
-+ return 0;
-+}
-+
-+static char**
-+read_device_factory_paths ()
- {
-- NMManagerPrivate *priv = NM_MANAGER_GET_PRIVATE (self);
- GDir *dir;
- GError *error = NULL;
- const char *item;
-- char *path;
-- GSList *iter;
-+ GArray *paths;
-+ char **result;
-+ guint i;
-
- dir = g_dir_open (NMPLUGINDIR, 0, &error);
- if (!dir) {
-- nm_log_warn (LOGD_HW, "Failed to open plugin directory %s: %s",
-+ nm_log_warn (LOGD_HW, "device plugin: failed to open directory %s: %s",
- NMPLUGINDIR,
- (error && error->message) ? error->message : "(unknown)");
- g_clear_error (&error);
-- return;
-+ return NULL;
- }
-
-+ paths = g_array_new (FALSE, FALSE, sizeof (struct read_device_factory_paths_data));
-+
- while ((item = g_dir_read_name (dir))) {
-- GModule *plugin;
-- NMDeviceFactory *factory;
-- NMDeviceFactoryCreateFunc create_func;
-- NMDeviceFactoryDeviceTypeFunc type_func;
-- NMDeviceType dev_type;
-- const char *found = NULL;
-+ struct read_device_factory_paths_data data;
-
- if (!g_str_has_prefix (item, PLUGIN_PREFIX))
- continue;
- if (g_str_has_suffix (item, ".la"))
- continue;
-
-- path = g_module_build_path (NMPLUGINDIR, item);
-- g_assert (path);
-- plugin = g_module_open (path, G_MODULE_BIND_LOCAL);
-- g_free (path);
-+ data.path = g_build_filename (NMPLUGINDIR, item, NULL);
-+
-+ if (stat (data.path, &data.st) != 0)
-+ goto continue_with_error;
-+ if (!S_ISREG (data.st.st_mode))
-+ goto continue_silently;
-+ if (data.st.st_uid != 0)
-+ goto continue_with_error;
-+ if (data.st.st_mode & (S_IWGRP | S_IWOTH | S_ISUID))
-+ goto continue_with_error;
-+
-+ g_array_append_val (paths, data);
-+ continue;
-+
-+continue_with_error:
-+ nm_log_dbg (LOGD_HW, "device plugin: skip invalid file %s", data.path);
-+continue_silently:
-+ g_free (data.path);
-+ }
-+ g_dir_close (dir);
-+
-+ /* sort filenames by modification time. */
-+ g_array_sort (paths, read_device_factory_paths_sort_fcn);
-+
-+ result = g_new (char *, paths->len + 1);
-+ for (i = 0; i < paths->len; i++)
-+ result[i] = g_array_index (paths, struct read_device_factory_paths_data, i).path;
-+ result[i] = NULL;
-+
-+ g_array_free (paths, TRUE);
-+ return result;
-+}
-+
-+static void
-+load_device_factories (NMManager *self)
-+{
-+ NMManagerPrivate *priv = NM_MANAGER_GET_PRIVATE (self);
-+ char **path;
-+ char **paths;
-+
-+ paths = read_device_factory_paths ();
-+ if (!paths)
-+ return;
-+
-+ for (path = paths; *path; path++) {
-+ GError *error = NULL;
-+ GModule *plugin;
-+ NMDeviceFactory *factory;
-+ NMDeviceFactoryCreateFunc create_func;
-+ NMDeviceFactoryDeviceTypeFunc type_func;
-+ NMDeviceType dev_type;
-+ const char *found = NULL;
-+ GSList *iter;
-+ const char *item;
-+
-+ item = strrchr (*path, '/');
-+ g_assert (item);
-+
-+ plugin = g_module_open (*path, G_MODULE_BIND_LOCAL);
-
- if (!plugin) {
- nm_log_warn (LOGD_HW, "(%s): failed to load plugin: %s", item, g_module_error ());
-@@ -1939,7 +2013,7 @@ load_device_factories (NMManager *self)
- }
- }
- if (found) {
-- nm_log_warn (LOGD_HW, "Found multiple device plugins for same type: %s vs %s",
-+ nm_log_warn (LOGD_HW, "Found multiple device plugins for same type: use '%s' instead of '%s'",
- found, g_module_name (plugin));
- g_module_close (plugin);
- continue;
-@@ -1978,7 +2052,7 @@ load_device_factories (NMManager *self)
-
- nm_log_info (LOGD_HW, "Loaded device plugin: %s", g_module_name (plugin));
- };
-- g_dir_close (dir);
-+ g_strfreev (paths);
-
- priv->factories = g_slist_reverse (priv->factories);
- }
-diff --git a/src/platform/nm-linux-platform.c b/src/platform/nm-linux-platform.c
-index f73ff32..7b11a6b 100644
---- a/src/platform/nm-linux-platform.c
-+++ b/src/platform/nm-linux-platform.c
-@@ -1584,7 +1584,9 @@ announce_object (NMPlatform *platform, const struct nl_object *object, NMPlatfor
- */
- switch (change_type) {
- case NM_PLATFORM_SIGNAL_REMOVED:
-- check_cache_items (platform, priv->route_cache, address.ifindex);
-+ check_cache_items (platform,
-+ priv->route_cache,
-+ rtnl_addr_get_ifindex ((struct rtnl_addr *) object));
- break;
- default:
- break;
-@@ -3500,7 +3502,8 @@ _route_match (struct rtnl_route *rtnlroute, int family, int ifindex)
- rtnl_route_get_table (rtnlroute) != RT_TABLE_MAIN ||
- rtnl_route_get_protocol (rtnlroute) == RTPROT_KERNEL ||
- rtnl_route_get_family (rtnlroute) != family ||
-- rtnl_route_get_nnexthops (rtnlroute) != 1)
-+ rtnl_route_get_nnexthops (rtnlroute) != 1 ||
-+ rtnl_route_get_flags (rtnlroute) & RTM_F_CLONED)
- return FALSE;
-
- nexthop = rtnl_route_nexthop_n (rtnlroute, 0);
-diff --git a/vapi/NMClient-1.0.metadata b/vapi/NMClient-1.0.metadata
-index 12f1469..2d894d8 100644
---- a/vapi/NMClient-1.0.metadata
-+++ b/vapi/NMClient-1.0.metadata
-@@ -1,6 +1,6 @@
--RemoteSettings.new_async skip
-+RemoteSettings.new_finish symbol_type="function"
- RemoteConnection.updated#virtual_method skip
--Client.new_async skip
-+Client.new_finish symbol_type="function"
-
- ACTIVE_CONNECTION_* cheader_filename="nm-active-connection.h" name="ACTIVE_CONNECTION_(.+)" parent="NM.ActiveConnection"
- CLIENT_* cheader_filename="nm-client.h" name="CLIENT_(.+)" parent="NM.Client"