summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFadeMind2016-02-20 07:49:47 +0100
committerFadeMind2016-02-20 07:49:47 +0100
commit1cde38c56a90ad9389da28ba818000958fe8750e (patch)
tree52acf8febf861e86d96cd3f528e26b5129dacfd1
downloadaur-1cde38c56a90ad9389da28ba818000958fe8750e.tar.gz
update
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore6
-rw-r--r--10-ddclient9
-rw-r--r--LICENSE19
-rw-r--r--PKGBUILD18
5 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2bbf6675569b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Sat Feb 20 06:49:47 UTC 2016
+pkgbase = networkmanager-dispatcher-ddclient
+ pkgdesc = Dispatcher Script for ddclient
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://www.gnome.org/projects/NetworkManager
+ arch = any
+ license = MIT
+ depends = networkmanager
+ depends = ddclient
+ source = 10-ddclient
+ source = LICENSE
+ sha256sums = f2a2dbb1f30cb9f64ef5cbdc4006432aa0ff4e72eba4a138fb7c0d2748d45877
+ sha256sums = 1cab355e4f44252ba9943b18f934a6a06fc24b9fa98fceb85c0f23c104aa5cdd
+
+pkgname = networkmanager-dispatcher-ddclient
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..097acb55f2cb
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
+!10-ddclient
+!LICENSE
diff --git a/10-ddclient b/10-ddclient
new file mode 100644
index 000000000000..58bdf161eb7a
--- /dev/null
+++ b/10-ddclient
@@ -0,0 +1,9 @@
+#!/bin/bash
+case "$2" in
+ up)
+ systemctl start ddclient.service
+ ;;
+ down)
+ systemctl stop ddclient.service
+ ;;
+esac
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..a9fc9e3f1a3c
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,19 @@
+Copyright (c) 2016 Tomasz PrzybyƂ
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a0a63c76261b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: FadeMind <fademind@gmail.com>
+
+pkgname=networkmanager-dispatcher-ddclient
+pkgver=1.0
+pkgrel=1
+pkgdesc="Dispatcher Script for ddclient"
+arch=('any')
+license=('MIT')
+url="http://www.gnome.org/projects/NetworkManager"
+depends=('networkmanager' 'ddclient')
+source=("10-ddclient" "LICENSE")
+sha256sums=('f2a2dbb1f30cb9f64ef5cbdc4006432aa0ff4e72eba4a138fb7c0d2748d45877'
+ '1cab355e4f44252ba9943b18f934a6a06fc24b9fa98fceb85c0f23c104aa5cdd')
+
+package() {
+ install -Dm700 ${srcdir}/10-ddclient ${pkgdir}/etc/NetworkManager/dispatcher.d/10-ddclient
+ install -Dm644 ${srcdir}/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}