summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIlya Lipnitskiy2015-10-12 17:49:50 -0700
committerIlya Lipnitskiy2015-10-12 17:49:50 -0700
commitdd12365b55250d6e6daff694d4e776f22ca96dd4 (patch)
tree1ada3bf65c5a71129c083b94fcbf90845b9638eb
downloadaur-dd12365b55250d6e6daff694d4e776f22ca96dd4.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--10-ypconf14
-rw-r--r--LICENSE19
-rw-r--r--PKGBUILD17
4 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fb7ea9743007
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = networkmanager-dispatcher-ypconf
+ pkgdesc = Dispatcher Script for generating yp.conf
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://www.gnome.org/projects/NetworkManager/
+ arch = any
+ license = MIT
+ depends = networkmanager
+ depends = ypbind-mt
+ source = 10-ypconf
+ source = LICENSE
+ md5sums = 5f1c1e694d157801b5119d5b6cf44283
+ md5sums = 69120da70cc3f06557abc2d5575eee41
+
+pkgname = networkmanager-dispatcher-ypconf
+
diff --git a/10-ypconf b/10-ypconf
new file mode 100644
index 000000000000..d7f5eab529d7
--- /dev/null
+++ b/10-ypconf
@@ -0,0 +1,14 @@
+#!/bin/bash
+
+# DHCPv4
+if [ -n "$DHCP4_NIS_DOMAIN" ] && [ -n "$DHCP4_NIS_SERVERS" ]; then
+ case "$2" in
+ dhcp4-change)
+ yp_conf_new=/etc/yp.conf
+ echo "#Generated by NetworkManager dispatcher" > $yp_conf_new
+ for nis_server in $DHCP4_NIS_SERVERS; do
+ echo "domain $DHCP4_NIS_DOMAIN server $nis_server" >> $yp_conf_new
+ done
+ ;;
+ esac
+fi
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..9493751fe37b
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,19 @@
+Copyright (c) 2015 Ilya Lipnitskiy
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..45d923ee7741
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Ilya Lipnitskiy <ilya.lipnitskiy@gmail.com>
+pkgname=networkmanager-dispatcher-ypconf
+pkgver=1.0
+pkgrel=1
+pkgdesc="Dispatcher Script for generating yp.conf"
+arch=(any)
+license=('MIT')
+url="http://www.gnome.org/projects/NetworkManager/"
+depends=('networkmanager' 'ypbind-mt')
+source=("10-ypconf" "LICENSE")
+md5sums=('5f1c1e694d157801b5119d5b6cf44283'
+ '69120da70cc3f06557abc2d5575eee41')
+
+package() {
+ install -Dm755 $srcdir/10-ypconf $pkgdir/etc/NetworkManager/dispatcher.d/10-ypconf
+ install -Dm644 $srcdir/LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}