summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2018-06-25 12:54:49 -0400
committerSolomon Choina2018-06-25 12:54:49 -0400
commit312c16cfebb8ba0d1f0f17034326ac3cb9c99541 (patch)
treeb0f3b091e63808c3be18eb8c638491091dea97dd
parenta544f9a9455f0e6528438e3db6001fde99f32754 (diff)
downloadaur-312c16cfebb8ba0d1f0f17034326ac3cb9c99541.tar.gz
revert back to autotools
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD159
2 files changed, 91 insertions, 75 deletions
diff --git a/.SRCINFO b/.SRCINFO
index db2abcc97fe9..88eb7e02d27e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = networkmanager-git
pkgdesc = Network Management daemon
- pkgver = 1.11.3.r20184.gc905ee94f
+ pkgver = 1.13.0.r20464.g372c0eb3e
pkgrel = 1
url = http://www.gnome.org/projects/NetworkManager
arch = i686
@@ -9,10 +9,10 @@ pkgbase = networkmanager-git
license = LGPL2.1
checkdepends = libx11
checkdepends = python-dbus
- makedepends = meson
- makedepends = ninja
+ makedepends = dnsmasq
makedepends = intltool
makedepends = dhclient
+ makedepends = openresolv
makedepends = iptables
makedepends = gobject-introspection
makedepends = gtk-doc
@@ -76,6 +76,7 @@ pkgname = networkmanager-git
depends = polkit
depends = wpa_supplicant
depends = libsoup
+ depends = openresolv
depends = libmm-glib
depends = libnewt
depends = libndp
diff --git a/PKGBUILD b/PKGBUILD
index 0569fb263089..7e4c8c98865b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@
pkgbase=networkmanager-git
_gitname=NetworkManager
pkgname=(networkmanager-git libnm-glib-git libnm-git)
-pkgver=1.11.3.r20184.gc905ee94f
+pkgver=1.13.0.r20464.g372c0eb3e
pkgrel=1
pkgdesc="Network Management daemon"
arch=(i686 x86_64)
@@ -21,7 +21,7 @@ depends=(dbus-glib libmm-glib libndp libnewt libnl libsoup libteam libutil-linux
nss polkit wpa_supplicant)
checkdepends=(libx11 python-dbus)
_pppver=2.4.7
-makedepends=(meson ninja intltool dhclient iptables gobject-introspection gtk-doc "ppp=$_pppver" modemmanager
+makedepends=(dnsmasq intltool dhclient openresolv iptables gobject-introspection gtk-doc "ppp=$_pppver" modemmanager
dbus-glib iproute2 nss polkit wpa_supplicant iwd libsoup systemd libgudev libmm-glib
libnewt libndp libteam vala perl-yaml python-gobject git vala jansson bluez-libs
glib2-docs)
@@ -58,78 +58,84 @@ pkgver() {
prepare() {
mkdir -p libnm{,-glib}/usr/{include,lib/{girepository-1.0,pkgconfig},share/{gir-1.0,gtk-doc/html,vala/vapi}}
- NOCONFIGURE=1 $srcdir/$pkgname/autogen.sh
+ cd networkmanager-git
+ NOCONFIGURE=1 ./autogen.sh
}
build() {
- cd $pkgname/
- arch-meson build \
- -Difcfg_rh=false \
- -Difcfg_suse=false \
- -Difnet=false \
- -Difupdown=false \
- -Dmore_warnings=false \
- -Dstatic=false \
- -Dbluez5_dun=true \
- -Dconcheck=true \
- -Dibft=true \
- -Ddocs=true \
- -Dintrospection=true \
- -Djson_validation=true \
- -Dld_gc=false \
- -Dmodify_system=true \
- -Dpolkit=yes \
- -Dpolkit_agent=true \
- -Dteamdctl=true \
- -Dovs=true \
- -Dwifi=true \
- -Dconfig_dhcp_default=internal \
- -Dconfig_dns_rc_manager_default=resolvconf \
- -Dconfig_logging_backend_default=journal \
- -Dconfig_plugins_default=keyfile,ibft \
- -Dcrypto=nss \
- -Ddbus_sys_dir=/usr/share/dbus-1/system.d \
- -Ddhclient=/usr/bin/dhclient \
- -Ddist_version="$pkgver, Arch Linux" \
- -Ddnsmasq=/usr/bin/dnsmasq \
- -Ddnssec_trigger=/usr/lib/dnssec-trigger \
- -Dhostname_persist=default \
- -Diptables=/usr/bin/iptables \
- -Dkernel_firmware_dir=/usr/lib/firmware \
- -Dlibnm_glib=true \
- -Dlibsoup=true \
- -Dmodem_manager=true \
- -Dnmcli=true \
- -Dnmtui=true \
- -Dpppd_plugin_dir=/usr/lib/pppd/$_pppver \
- -Dpppd=/usr/bin/pppd \
- -Dresolvconf=/usr/bin/resolvconf \
- -Dsession_tracking=systemd \
- -Dsuspend_resume=true \
- -Dsystem_ca_path=/etc/ssl/certs \
- -Dsystemd_journal=true \
- -Dsystemd_logind=true \
- -Dsystemdsystemunitdir=/usr/lib/systemd/system \
- -Dudev_dir=/usr/lib/udev \
- -Dwext=true \
- -Dconsolekit=false \
- -Dlibaudit=no \
- -Dnetconfig=false \
- -Dofono=false \
- -Dselinux=false \
- -Diwd=true
-
- ninja -C build
+ cd $pkgname
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ runstatedir=/run \
+ --sbindir=/usr/bin \
+ --with-iwd=true \
+ --libexecdir=/usr/lib \
+ --disable-ifcfg-rh \
+ --disable-ifupdown \
+ --disable-lto \
+ --disable-more-logging \
+ --disable-more-warnings \
+ --disable-static \
+ --enable-bluez5-dun \
+ --enable-concheck \
+ --enable-config-plugin-ibft \
+ --enable-gtk-doc \
+ --enable-introspection \
+ --enable-json-validation \
+ --enable-ld-gc \
+ --enable-modify-system \
+ --enable-polkit \
+ --enable-polkit-agent \
+ --enable-teamdctl \
+ --enable-wifi \
+ --with-config-dhcp-default=internal \
+ --with-config-dns-rc-manager-default=symlink \
+ --with-config-logging-backend-default=journal \
+ --with-config-plugins-default=keyfile,ibft \
+ --with-crypto=nss \
+ --with-dbus-sys-dir=/usr/share/dbus-1/system.d \
+ --with-dhclient=/usr/bin/dhclient \
+ --with-dhcpcd-supports-ipv6 \
+ --with-dhcpcd=/usr/bin/dhcpcd \
+ --with-dnsmasq=/usr/bin/dnsmasq \
+ --with-dnssec-trigger=/usr/lib/dnssec-trigger/dnssec-trigger-script \
+ --with-hostname-persist=default \
+ --with-iptables=/usr/bin/iptables \
+ --with-kernel-firmware-dir=/usr/lib/firmware \
+ --with-libnm-glib \
+ --with-modem-manager-1 \
+ --with-nmcli \
+ --with-nmtui \
+ --with-pppd-plugin-dir=/usr/lib/pppd/$_pppver \
+ --with-pppd=/usr/bin/pppd \
+ --with-resolvconf=/usr/bin/resolvconf \
+ --with-session-tracking=systemd \
+ --with-suspend-resume=systemd \
+ --with-system-ca-path=/etc/ssl/certs \
+ --with-systemd-journal \
+ --with-systemd-logind \
+ --with-systemdsystemunitdir=/usr/lib/systemd/system \
+ --with-udev-dir=/usr/lib/udev \
+ --with-wext \
+ --without-consolekit \
+ --without-libaudit \
+ --without-more-asserts \
+ --without-netconfig \
+ --without-ofono \
+ --without-selinux
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+ make
}
check() {
- cd $srcdir/$pkgname
- ninja -C build test
+ cd $pkgname
+ make -k check || :
}
package_networkmanager-git() {
- depends=(libnm-glib iproute2 polkit wpa_supplicant libsoup libmm-glib libnewt libndp libteam
+ depends=(libnm-glib iproute2 polkit wpa_supplicant libsoup openresolv libmm-glib libnewt libndp libteam
bluez-libs)
optdepends=('dnsmasq: connection sharing'
'bluez: Bluetooth support'
@@ -140,17 +146,27 @@ package_networkmanager-git() {
backup=('etc/NetworkManager/NetworkManager.conf')
conflicts=('networkmanager')
provides=('networkmanager')
- cd $srcdir/$pkgname
- DESTDIR="$pkgdir" ninja -C build install
+
+ cd $pkgname
+ make DESTDIR="$pkgdir" install
+
+ # packaged configuration
+ install -Dm644 /dev/stdin "$pkgdir/usr/lib/NetworkManager/conf.d/20-connectivity.conf" <<END
+ [connectivity]
+ uri=http://www.archlinux.org/check_network_status.txt
+ END
+
install -dm700 "$pkgdir/etc/NetworkManager/system-connections"
install -d "$pkgdir"/etc/NetworkManager/{conf,dnsmasq}.d
- install -m644 ../NetworkManager.conf "$pkgdir/etc/NetworkManager/"
- install -Dm644 ../20-connectivity.conf \
- "$pkgdir/usr/lib/NetworkManager/conf.d/20-connectivity.conf"
-### Split libnm
+
+ install -m644 /dev/stdin "$pkgdir/etc/NetworkManager/NetworkManager.conf" <<END
+# Configuration file for NetworkManager.
+# See "man 5 NetworkManager.conf" for details.
+END
+
- cd ../libnm
+ cd ../libnm
mv "$pkgdir"/usr/include/libnm usr/include
mv "$pkgdir"/usr/lib/girepository-1.0/NM-* usr/lib/girepository-1.0
mv "$pkgdir"/usr/lib/libnm.* usr/lib
@@ -174,7 +190,6 @@ package_networkmanager-git() {
"$pkgdir"/usr/include \
"$pkgdir"/usr/lib/{girepository-1.0,pkgconfig} \
"$pkgdir"/usr/share/{gir-1.0,vala/vapi}
-
}
package_libnm-git() {