summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlejandro Perez2017-11-23 16:58:46 +0100
committerAlejandro Perez2017-11-23 16:58:46 +0100
commit07339eae3e060b59f29b4b65d5fe5ec351628ccb (patch)
tree19ae91543cc0e789564eee6cc2d4c2f950842d94
parentce1fb95d6d7c6ed4dbb24affdc2a5171ba54cc74 (diff)
downloadaur-07339eae3e060b59f29b4b65d5fe5ec351628ccb.tar.gz
Fix patch
-rw-r--r--PKGBUILD2
-rw-r--r--disable_wifi_scan_when_connected.patch34
2 files changed, 19 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a48c911b9fe7..8b4bdef3de3e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,7 +25,7 @@ source=("git+https://anongit.freedesktop.org/git/NetworkManager/NetworkManager#c
sha256sums=('SKIP'
'dd2d3a9c8a08ce961e263e1847453890f1b24c72a806d8c83a5b69b227a5ccec'
'477d609aefd991c48aca93dc7ea5a77ebebf46e0481184530cceda4c0d8d72c6'
- '50bc08476f9c799032230b909c4bdce58726f83cfc654aa3835c17ac99e500cc')
+ '860a772fcc26271f6a25a2baa0d92088e63dbf1770ccc4c25e71653dbe46b96b')
prepare() {
mkdir -p libnm{,-glib}/usr/{include,lib/{girepository-1.0,pkgconfig},share/{gir-1.0,gtk-doc/html,vala/vapi}}
diff --git a/disable_wifi_scan_when_connected.patch b/disable_wifi_scan_when_connected.patch
index b4188ef98aae..a484c95371ae 100644
--- a/disable_wifi_scan_when_connected.patch
+++ b/disable_wifi_scan_when_connected.patch
@@ -1,18 +1,20 @@
+diff --git a/src/devices/wifi/nm-device-wifi.c b/src/devices/wifi/nm-device-wifi.c
+index 5e92f47b7..32e281cd2 100644
--- a/src/devices/wifi/nm-device-wifi.c
+++ b/src/devices/wifi/nm-device-wifi.c
-@@ -1364,13 +1364,8 @@ scanning_prohibited (NMDeviceWifi *self,
- /* Can always scan when disconnected */
- return FALSE;
- case NM_DEVICE_STATE_ACTIVATED:
-- /* Prohibit periodic scans when connected; we ask the supplicant to
-- * background scan for us, unless the connection is locked to a specifc
-- * BSSID.
-- */
-- if (periodic)
-- return TRUE;
-- break;
-+ /* Prohibit periodic scans when connected */
-+ return TRUE;
- }
-
- /* Prohibit scans if the supplicant is busy */
+@@ -1364,13 +1364,8 @@ scanning_prohibited (NMDeviceWifi *self, gboolean periodic)
+ /* Can always scan when disconnected */
+ return FALSE;
+ case NM_DEVICE_STATE_ACTIVATED:
+- /* Prohibit periodic scans when connected; we ask the supplicant to
+- * background scan for us, unless the connection is locked to a specifc
+- * BSSID.
+- */
+- if (periodic)
+- return TRUE;
+- break;
++ /* Prohibit periodic scans when connected */
++ return TRUE;
+ }
+
+ /* Prohibit scans if the supplicant is busy */