summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcell Meszaros2024-02-12 00:04:47 +0100
committerMarcell Meszaros2024-02-12 00:04:47 +0100
commit7d5948bd748791b0cfc217e6b2a29b9d2d922b96 (patch)
tree9f49cc31d3ef450a11c456f80c3f309204e03f65
parent8833e700820d8e1731a6bc8487a633006058aa41 (diff)
downloadaur-7d5948bd748791b0cfc217e6b2a29b9d2d922b96.tar.gz
5.249.0.r2.g7bc1121-4: proper license fix, adding custom LicenseRef-KDE-Accepted-LGPL
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index be7707cd4392..7ebd0545cb46 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,11 +7,11 @@
_distname=networkmanager-qt
pkgname="${_distname}-git"
pkgver=5.249.0.r2.g7bc1121
-pkgrel=3
+pkgrel=4
pkgdesc="KDE's Qt wrapper for NetworkManager API (git build)"
arch=(x86_64)
url="https://invent.kde.org/frameworks/${_distname}"
-license=('LGPL-2.1-only OR LGPL-3.0-only')
+license=('LGPL-2.1-only OR LGPL-3.0-only OR LicenseRef-KDE-Accepted-LGPL')
depends=(gcc-libs
glibc
qt6-base
@@ -42,4 +42,7 @@ build() {
package() {
depends+=(networkmanager)
DESTDIR="${pkgdir}" cmake --install build
+
+ cd "${_distname}/LICENSES"
+ install -Dm644 LicenseRef-KDE-Accepted-LGPL.txt -t "${pkgdir}/usr/share/licenses/${pkgname}"
}