summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPopolon2020-09-09 22:25:50 +0200
committerPopolon2020-09-09 22:25:50 +0200
commit3d93554f95f50f561672fba10e5f5774faf549ee (patch)
tree177f2e434a6e03668cb3944ad3e19e00b0eeddc5
downloadaur-3d93554f95f50f561672fba10e5f5774faf549ee.tar.gz
initial networktablet commit, version 1.5
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a88136c949cf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = networktablet
+ pkgdesc = Linux driver for Android GfxTablet input
+ pkgver = 1.5
+ pkgrel = 1
+ url = http://rfc2822.github.io/GfxTablet/
+ arch = x86_64
+ arch = armv7h
+ arch = armv8
+ license = GPL3
+ source = https://github.com/rfc2822/GfxTablet/archive/android-app-1.4-linux-driver-1.5.tar.gz
+ sha512sums = 3f56c4982c95d0be4588424af9c8046e59a4bd7f310738fdc6099a4f93e1b58bf82d8730139167f74d86001e31fd6def20752405c15683ceeb04f7efa3f7c801
+
+pkgname = networktablet
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a38b3531a939
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Popolon <popolon@popolon.org>
+
+pkgname=networktablet
+pkgver=1.5
+pkgrel=1
+pkgdesc="Linux driver for Android GfxTablet input"
+arch=(x86_64 armv7h armv8)
+url="http://rfc2822.github.io/GfxTablet/"
+license=('GPL3')
+source=("https://github.com/rfc2822/GfxTablet/archive/android-app-1.4-linux-driver-$pkgver.tar.gz")
+sha512sums=('3f56c4982c95d0be4588424af9c8046e59a4bd7f310738fdc6099a4f93e1b58bf82d8730139167f74d86001e31fd6def20752405c15683ceeb04f7efa3f7c801')
+
+build() {
+ cd GfxTablet-android-app-1.4-linux-driver-$pkgver/driver-uinput/
+ make
+}
+
+package() {
+ cd GfxTablet-android-app-1.4-linux-driver-$pkgver
+ install -D driver-uinput/networktablet "$pkgdir"/usr/bin/networktablet
+ install -Dm 644 LICENSE.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}