summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSergej Schmidt2017-03-15 21:47:16 +0100
committerSergej Schmidt2017-03-15 21:47:16 +0100
commit7ee39bfb3bc86bc99743ff9ec19ad9288d1f9e96 (patch)
tree5edd6382f0e5e71e1f7269fa3e4a36ff87552c72
downloadaur-7ee39bfb3bc86bc99743ff9ec19ad9288d1f9e96.tar.gz
Initial netzob version v1.0.1.
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD47
2 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bc21944c59a6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = netzob
+ pkgdesc = Netzob is an opensource tool which supports the expert in its operations of reverse engineering, evaluation and simulation of communication protocols.
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = http://netzob.org
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = python-setuptools
+ makedepends = python-mock
+ depends = impacket
+ depends = python
+ depends = python-jsonpickle
+ depends = python-colorama
+ depends = python-numpy
+ depends = python-sphinx
+ depends = python-pcapy
+ depends = python-bitarray
+ depends = python-babel
+ depends = python-netaddr
+ depends = python-bintrees
+ depends = python-minepy
+ provides = netzob
+ conflicts = netzob-git
+ options = !emptydirs
+ source = netzob-Release-netzob-1.0.1.tar.gz::https://github.com/netzob/netzob/archive/Release/netzob-1.0.1.tar.gz
+ sha256sums = c1b8ed99ba631c567ff09759af0e0624546b6e3a142d458a6763e11a5a4b5931
+
+pkgname = netzob
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..03d95d05f500
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Sergej "winnie" Schmidt <sergej@hex.house>
+
+_py="python"
+pkgname=netzob
+pkgver=1.0.1
+_release_name=${pkgname}-Release-${pkgname}-${pkgver}
+pkgrel=1
+HOLDVER=1
+pkgdesc="Netzob is an opensource tool which supports the expert in its operations of reverse engineering, evaluation and simulation of communication protocols."
+arch=('i686' 'x86_64')
+url="http://netzob.org"
+license=('GPL3')
+depends=("impacket" "${_py}" "${_py}-jsonpickle" "${_py}-colorama" "${_py}-numpy" "${_py}-sphinx" "${_py}-pcapy" "${_py}-bitarray" "${_py}-babel" "${_py}-netaddr" "${_py}-bintrees" "${_py}-minepy")
+makedepends=("${_py}-setuptools" "${_py}-mock")
+conflicts=('netzob-git')
+options=(!emptydirs)
+install=
+source=(${_release_name}.tar.gz::https://github.com/netzob/netzob/archive/Release/${pkgname}-${pkgver}.tar.gz)
+provides=('netzob')
+sha256sums=('c1b8ed99ba631c567ff09759af0e0624546b6e3a142d458a6763e11a5a4b5931')
+
+build() {
+ cd "${srcdir}/${_release_name}"
+
+ msg "Starting build."
+ ${_py} setup.py build
+
+ msg "Building docs."
+ sphinx-apidoc -T -e -f -o doc/documentation/source/developer_guide/API/ src/netzob/
+ find doc/documentation/source/developer_guide/API/ -type f -exec sed -i ':a;N;$!ba;s/Subpackages\n-----------\n\n.. toctree::\n/Subpackages\n-----------\n\n.. toctree::\n :maxdepth: 1\n /g' {} +
+ sphinx-build -b html doc/documentation/source/ doc/documentation/build/
+
+}
+
+package() {
+ cd "${srcdir}/${_release_name}"
+
+ msg "Starting install."
+ ${_py} setup.py install --root="$pkgdir" || return 1
+
+ msg "Installing docs."
+ mkdir -p "$pkgdir/usr/share/doc"
+ cp -r doc/documentation/build "$pkgdir/usr/share/doc/netzob"
+
+ msg "Install successful. Cleaning up."
+}
+