summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrett Gilio2017-11-05 23:21:19 -0600
committerBrett Gilio2017-11-05 23:21:19 -0600
commitfbaba66645a7799b5d29e259f8e026452d925536 (patch)
tree6f23052f7c6f6698f57dd9ed4637229bfd20c15f
parentbcbb137c235eb1f545901cb26bf137ebec4c4560 (diff)
downloadaur-fbaba66645a7799b5d29e259f8e026452d925536.tar.gz
Neuron 7.5 - Adopt
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD63
2 files changed, 36 insertions, 53 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7667c40578d9..c9588ab6ca5f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,22 @@
-pkgbase = neuron
- pkgdesc = Empirically-based simulations of neurons and networks of neurons
- pkgver = 7.4
+pkgbase = neuron-bin
+ pkgdesc = Neuron for empirically-based simulations of neurons and networks of neurons. A flexible and powerful simulator of neurons and networks NEURON is a simulation environment for developing and exercising models of neurons and networks of neurons.
+ pkgver = 7.5
pkgrel = 1
- url = http://www.neuron.yale.edu
+ url = http://neuron.yale.edu/ftp/neuron/versions/v7.5/nrn-7.5.x86_64.deb
arch = i686
arch = x86_64
license = GPL
- depends = interviews
+ depends = aarch64-linux-gnu-gcc>=5.2
+ depends = libtinfo5>=6
+ depends = libx11
depends = openmpi
depends = python
- optdepends = python-numpy
- optdepends = python-scipy
- optdepends = mpich2
- options = libtool
- source = http://www.neuron.yale.edu/ftp/neuron/versions/v7.4/nrn-7.4.tar.gz
- md5sums = 2c0bbee8a9e55d60fa26336f4ab7acbf
+ depends = python-numpy
+ depends = python-scipy
+ options = !strip
+ options = !emptydirs
+ source_x86_64 = http://neuron.yale.edu/ftp/neuron/versions/v7.5/nrn-7.5.x86_64.deb
+ sha512sums_x86_64 = a4ad3e5b8a3ad7e480476232b32155b03c9dd313c22480690a96da3bd039b8d106f41e1907cbe4acdf153af297b98a195204bb5e8df46b5f911dde7fda08f131
-pkgname = neuron
+pkgname = neuron-bin
diff --git a/PKGBUILD b/PKGBUILD
index 2a5a77a7c596..5381d8c78e5b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,49 +1,30 @@
-# Maintainer: Ali Neishabouri <ali at neishabouri.net>
-# Contributor: David Campbell <davekong@archlinux.us>
-
-pkgname=neuron
-pkgver=7.4
+# Maintainer: Brett Gilio <mail@brettgilio.com>
+pkgname=neuron-bin
+pkgver=7.5
pkgrel=1
-pkgdesc="Empirically-based simulations of neurons and networks of neurons"
+pkgdesc="Neuron for empirically-based simulations of neurons and networks of neurons. A flexible and powerful simulator of neurons and networks NEURON is a simulation environment for developing and exercising models of neurons and networks of neurons."
arch=('i686' 'x86_64')
-url="http://www.neuron.yale.edu"
+url="http://neuron.yale.edu/"
license=('GPL')
-depends=('interviews' 'openmpi' 'python')
-optdepends=('python-numpy' 'python-scipy' 'mpich2')
-source=("http://www.neuron.yale.edu/ftp/neuron/versions/v$pkgver/nrn-$pkgver.tar.gz")
-options=('libtool')
-md5sums=('2c0bbee8a9e55d60fa26336f4ab7acbf')
+groups=('')
+depends=('aarch64-linux-gnu-gcc>=5.2' 'libtinfo5>=6' 'libx11' 'openmpi' 'python' 'python-numpy' 'python-scipy')
+options=('!strip' '!emptydirs')
+source_x86_64=("http://neuron.yale.edu/ftp/neuron/versions/v7.5/nrn-7.5.x86_64.deb")
+sha512sums_x86_64=('a4ad3e5b8a3ad7e480476232b32155b03c9dd313c22480690a96da3bd039b8d106f41e1907cbe4acdf153af297b98a195204bb5e8df46b5f911dde7fda08f131')
-build() {
- cd "$srcdir/nrn-$pkgver"
+package(){
- # We do this so the python libraries actually get installed in the package prefix
- sed -i "s_ac\_pysetup='--home=\$(prefix)'_ac\_pysetup='--home=$pkgdir/usr'_g" "$srcdir/nrn-$pkgver/configure"
- sed -i 's_exec\_prefix="${prefix}/${host\_cpu}"_exec\_prefix="${prefix}"_g' "$srcdir/nrn-$pkgver/configure"
+ # Extract package data
+ tar xf data.tar.xz -C "${pkgdir}"
- ./configure --prefix=/usr --libdir=/usr/lib --bindir=/usr/bin --with-paranrn --with-nrnpython=`which python`
- make
-}
+ # Fix directories structure differencies
+ cd "${pkgdir}"
+
+ install -D -m644 "/usr/share/doc/nrn/copyright" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ mkdir usr/bin 2> /dev/null; mv usr/local/bin/* usr/bin; rm -rf usr/local/bin
+
+ mv usr/local/* usr; rm -rf usr/local
+
+ cd ..
-package() {
- cd "$srcdir/nrn-$pkgver"
- DESTDIR="$pkgdir"
- sed -i "s_package\_dir\ =\ {'':instdir+'/share/nrn/lib/python'}\,_package\_dir\ =\ {'':'$pkgdir/usr/share/nrn/lib/python'}\,_g" src/nrnpython/setup.py
- make DESTDIR="$pkgdir" install
- #rm -f "$pkgdir/usr/lib/libnrnmpi.la"
- #rm -f "$pkgdir/usr/lib/libmeschach.la"
- #rm -f "$pkgdir/usr/lib/libivoc.la"
- #rm -f "$pkgdir/usr/lib/libscopmath.la"
- #rm -f "$pkgdir/usr/lib/libneuron_gnu.la"
- #rm -f "$pkgdir/usr/lib/libmemacs.la"
- #rm -f "$pkgdir/usr/lib/libnrnoc.la"
- #rm -f "$pkgdir/usr/lib/libnrnpython.la"
- #rm -f "$pkgdir/usr/lib/liboc.la"
- #rm -f "$pkgdir/usr/lib/libnrniv.la"
- #rm -f "$pkgdir/usr/lib/libsundials.la"
- #rm -f "$pkgdir/usr/lib/libsparse13.la"
- #rm -f "$pkgdir/usr/lib/libocxt.la"
-
- cd "src/nrnpython/"
- python setup.py install --root="$pkgdir/"
}