summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorg Schlisio2016-03-23 22:28:19 +0100
committerGeorg Schlisio2016-03-23 22:28:19 +0100
commit9a5ba7d70ba465590efaa6cff3701944e1b1b039 (patch)
treec460d68099df53aaac86a1c6c172b4694a734b30
downloadaur-9a5ba7d70ba465590efaa6cff3701944e1b1b039.tar.gz
initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD26
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..31085e148c72
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = neveralone-hib
+ pkgdesc = atmospheric puzzle platformer for 1-players or 2-players built in partnership with the Alaska Native community (humblebundle version)
+ pkgver = 2016.03.22
+ pkgrel = 1
+ url = http://neveralonegame.com/
+ arch = x86_64
+ license = commercial
+ options = !strip
+ source = hib://NeverAlone_ArcticCollection.v1.0.tar.gz
+ md5sums = fe1ca15db6cfe6c1db877e33ace378fa
+
+pkgname = neveralone-hib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4f18bc29f935
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: fordprefect <fordprefect@dukun.de>
+pkgname=neveralone-hib
+pkgver=2016.03.22
+pkgrel=1
+pkgdesc="atmospheric puzzle platformer for 1-players or 2-players built in partnership with the Alaska Native community (humblebundle version)"
+url="http://neveralonegame.com/"
+arch=('x86_64')
+license=('commercial')
+source=("hib://NeverAlone_ArcticCollection.v1.0.tar.gz")
+md5sums=('fe1ca15db6cfe6c1db877e33ace378fa')
+options=(!strip)
+PKGEXT=".pkg.tar"
+DLAGENTS+=('hib::/usr/bin/echo "Could not find %u. Manually download it to \"$(pwd)\", or set up a hib:// DLAGENT in /etc/makepkg.conf."; exit 1')
+
+package() {
+ mkdir -p "${pkgdir}/opt/neveralone"
+ mkdir -p "${pkgdir}/usr/bin"
+ cp "${srcdir}/NeverAlone_ArcticCollection/Never_Alone.x64" "${pkgdir}/opt/neveralone"
+ cp -R "${srcdir}/NeverAlone_ArcticCollection/Never_Alone_Data" "${pkgdir}/opt/neveralone"
+ cat >> "${pkgdir}/usr/bin/neveralone" << \here
+#!/bin/sh
+cd /opt/neveralone
+Never_Alone.x86
+here
+ chmod a+x "${pkgdir}/usr/bin/neveralone"
+}