summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorskydrome2015-06-01 16:32:42 -0400
committerskydrome2015-06-01 16:32:42 -0400
commitad4be27c4f230f28d64b486da7a48dba4f1b0cdf (patch)
treea53d0b80e24f3402229d3caa1152e57e8c018efc
downloadaur-ad4be27c4f230f28d64b486da7a48dba4f1b0cdf.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ebe5a9378928
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = nevow
+ pkgdesc = web application construction kit written in Python
+ pkgver = 0.11.1
+ pkgrel = 1
+ url = http://pypi.python.org/pypi/Nevow
+ arch = any
+ license = custom
+ depends = python2
+ depends = twisted
+ source = https://pypi.python.org/packages/source/N/Nevow/Nevow-0.11.1.tar.gz
+ md5sums = acc5d23bd94a5399752065baae6117f6
+
+pkgname = nevow
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7c813a995805
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Nicolas Pouillard <nicolas.pouillard@gmail.com>
+# Contributor: Peter Simons <simons@cryp.to>
+
+pkgname=nevow
+pkgver=0.11.1
+pkgrel=1
+pkgdesc="web application construction kit written in Python"
+arch=('any')
+url='http://pypi.python.org/pypi/Nevow'
+license=('custom')
+depends=('python2' 'twisted')
+source=("https://pypi.python.org/packages/source/N/Nevow/Nevow-${pkgver}.tar.gz")
+md5sums=('acc5d23bd94a5399752065baae6117f6')
+
+build(){
+ cd "$srcdir/Nevow-$pkgver"
+ python2 setup.py build
+}
+
+package(){
+ cd "$srcdir/Nevow-$pkgver"
+ python2 setup.py install --prefix=/usr --root="$pkgdir" --install-data=/usr/share/"$pkgname"
+ install -D LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}