summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbtd13372018-07-15 19:08:56 -0300
committerbtd13372018-07-15 19:08:56 -0300
commit1bf94671db0b959e6695e81751fcbd134d0914ae (patch)
tree19deb2c07cbf534e5e29637abd330fa055ab7ca9
parent28cfeff8b0d429670130a43ddb25f277fa1db4bd (diff)
downloadaur-1bf94671db0b959e6695e81751fcbd134d0914ae.tar.gz
update description
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD20
2 files changed, 17 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 518b2ab2e95c..3a8dfe2fe644 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,4 +1,4 @@
-pkgbase = newaita-icons-git
+pkgbase = newaita-git
pkgdesc = Newaita icon theme is a Linux icon theme combining old style and color of material design. If you urgently needed any icon, please write in the comments on the page https://store.kde.org/p/1243493/ If you want support me Paypal: ghostdmn2@gmail.com
pkgver = latest
pkgrel = 1
@@ -7,10 +7,11 @@ pkgbase = newaita-icons-git
arch = x86_64
license = CC BY-NC-SA 3.0
makedepends = git
- conflicts = Newaita
+ provides = newaita
+ conflicts = newaita
options = !strip
source = git+https://github.com/cbrnix/Newaita.git
sha256sums = SKIP
-pkgname = newaita-icons-git
+pkgname = newaita-git
diff --git a/PKGBUILD b/PKGBUILD
index a76249e7c8a3..020ff83c1a2d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,33 @@
# Maintainer: Helder Bertoldo <helder.bertoldo@gmail.com>
-pkgname=newaita-icons-git
-_gitname=Newaita
+gitname=Newaita
+pkgname=newaita-git
pkgver=latest
pkgrel=1
pkgdesc="Newaita icon theme is a Linux icon theme combining old style and color of material design. If you urgently needed any icon, please write in the comments on the page https://store.kde.org/p/1243493/ If you want support me Paypal: ghostdmn2@gmail.com"
arch=('i686' 'x86_64')
-url="https://github.com/cbrnix/${_gitname}"
+url="https://github.com/cbrnix/${gitname}"
license=('CC BY-NC-SA 3.0')
makedepends=('git')
options=('!strip')
-conflicts=(${_gitname})
+provides=("newaita")
+conflicts=("newaita")
source=("git+${url}.git")
sha256sums=('SKIP')
pkgver(){
- cd ${_gitname}
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "${gitname}"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
}
package() {
install -d ${pkgdir}/usr/share/icons
- cp -r ${srcdir}/${_gitname}* ${pkgdir}/usr/share/icons/
+ cp -r ${gitname}* ${pkgdir}/usr/share/icons/
find ${pkgdir}/usr -type f -exec chmod 644 {} \;
find ${pkgdir}/usr -type d -exec chmod 755 {} \;
+ rm -rf "$pkgdir/usr/share/icons/${gitname}/.gitignore"
+ rm -rf "$pkgdir/usr/share/icons/${gitname}/.git"
}