summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2017-10-18 22:38:25 +0200
committerhaawda2017-10-18 22:38:25 +0200
commitc50c6e4343ed385d0d968b6838c285b508eba984 (patch)
tree45737fbc748c8b079376641aa742221d38fc2953
downloadaur-c50c6e4343ed385d0d968b6838c285b508eba984.tar.gz
initial upload
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD36
-rw-r--r--filelist36
3 files changed, 90 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d7eea422a352
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Wed Oct 18 20:38:08 UTC 2017
+pkgbase = newmat-beta
+ pkgdesc = C++ matrix library
+ pkgver = 11
+ pkgrel = 1
+ url = http://www.robertnz.net
+ arch = i686
+ arch = x86_64
+ license = custom
+ options = staticlibs
+ source = http://www.robertnz.net/ftp/newmat11.tar.gz
+ source = filelist
+ md5sums = c78aab80613db1989d1ec4c525d9d69c
+ md5sums = 1257a4599e437254666aeac610b7d5c5
+
+pkgname = newmat-beta
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7e68429dce53
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=newmat-beta
+pkgver=11
+pkgrel=1
+pkgdesc="C++ matrix library"
+url="http://www.robertnz.net"
+arch=('i686' 'x86_64')
+license=('custom')
+source=("http://www.robertnz.net/ftp/${pkgname%-beta}$pkgver.tar.gz" filelist)
+md5sums=('c78aab80613db1989d1ec4c525d9d69c'
+ '1257a4599e437254666aeac610b7d5c5')
+options=('staticlibs')
+
+prepare() {
+ sed -i 's+//#define use_namespace+#define use_namespace+' include.h
+}
+
+build() {
+ make -f nm_gnu.mak
+}
+
+package() {
+ for _i in `cat filelist | awk '{print $1}'`
+ do
+ install -Dm644 ${_i} $pkgdir/usr/include/$pkgname/${_i}
+ done
+ install -Dm644 COPYING $pkgdir/usr/share/licenses/$pkgname/COPYING
+ install -Dm644 README $pkgdir/usr/share/licenses/$pkgname/README
+ install -Dm644 libnewmat.a $pkgdir/usr/lib/libnewmat.a
+ for _i in `cat filelist | awk '{print $1}'|sed s+.cpp+.o+|grep -v .h`
+ do
+ install -Dm755 ${_i} $pkgdir/usr/lib/$pkgname/${_i}
+ done
+ install -Dm644 nm10.htm $pkgdir/usr/share/doc/$pkgname/nm10.htm
+}
diff --git a/filelist b/filelist
new file mode 100644
index 000000000000..18508120fa6c
--- /dev/null
+++ b/filelist
@@ -0,0 +1,36 @@
+ boolean.h boolean class definition
+ controlw.h control word definition file
+ include.h details of include files and options
+ myexcept.h general exception handler definitions
+ newmat.h main matrix class definition file
+ newmatap.h applications definition file
+ newmatio.h input/output definition file
+ newmatnl.h non-linear optimisation definition file
+ newmatrc.h row/column functions definition files
+ newmatrm.h rectangular matrix access definition files
+ precisio.h numerical precision constants
+ solution.h one dimensional solve definition file
+ bandmat.cpp band matrix routines
+ cholesky.cpp Cholesky decomposition
+ evalue.cpp eigenvalues and eigenvector calculation
+ fft.cpp fast Fourier, trig. transforms
+ hholder.cpp QR routines
+ jacobi.cpp eigenvalues by the Jacobi method
+ myexcept.cpp general error and exception handler
+ newfft.cpp new fast Fourier transform
+ newmat1.cpp type manipulation routines
+ newmat2.cpp row and column manipulation functions
+ newmat3.cpp row and column access functions
+ newmat4.cpp constructors, resize, utilities
+ newmat5.cpp transpose, evaluate, matrix functions
+ newmat6.cpp operators, element access
+ newmat7.cpp invert, solve, binary operations
+ newmat8.cpp LU decomposition, scalar functions
+ newmat9.cpp output routines
+ newmatex.cpp matrix exception handler
+ newmatnl.cpp non-linear optimisation
+ newmatrm.cpp rectangular matrix access functions
+ sort.cpp sorting functions
+ solution.cpp one dimensional solve
+ submat.cpp submatrix functions
+ svd.cpp singular value decomposition \ No newline at end of file